Skip navigation

How do I delete a large file without my computer crashing?

501 Views 14 Replies Latest reply: May 18, 2012 8:14 AM by Paul_31 RSS
dalidrama Calculating status...
Currently Being Moderated
May 13, 2012 9:50 PM

I am playing around with HD video and have a very large Quicktime File (12.5GB) that froze my computer while rendering.  I need to delete it.  (CRASH: screen freezes and dark line slowly comes from top to bottom and once entire screen is slightly darker, a post in the middle pops up and tells me to turn off computer by holding power button).


After a lot of trial and error, it seems the problem is that the computer can't handle the massive deletion.  Unlike a lot of other similar issues on this forum, this is a single file and not hundreds, so i can't delete portions at a time and be done with it.  I have run through all my ideas and need help on how to delete this file from my computer and have come up with two possible ways:


1 - Split this video into smaller files.  I dont know how to do this: I have SPLIT-CONCAT but that duplicates (then splits) and does not actually split the original.  I tried "replacing" the video with the same-named smaller file and it crashed the computer.


2 - Change preferences on this computer somehow to allow this massive deletion. I tried a force empty through terminal and it did the same crash.  I dont know if there is a preference (disk manager) or otherwise to get rid of this file. 


I am on a 2006 Intel iMac running 10.7.4

Mac OS X (10.7.4)
  • PaulKemp Level 1 Level 1 (135 points)

    It sounds as though you are getting a Kernel Panic, which is only partially related to you deleting the file.


    Can you open Finder and click Go->Go To Folder and open ~/Library/Logs/DiagnosticReports/


    If you can paste the contents of the last kernel panic, that'd be helpful.

  • X423424X Level 6 Level 6 (14,190 points)

    Try deleting it from the terminal (in Utilities).  Type rm -f followed by a space.  Then drag the file icon into the terminal window.  You should have a line that looks similar to this:


    rm -f /path/to/file


    Hit return and hope for the best.  Given the file's size it still may take a little time before you see the terminal prompt again indicating completion.

  • X423424X Level 6 Level 6 (14,190 points)

    Boot from your recovery partition and run Disk Utility to repair/verify your drives (not repair permissions).  I think some disk repairs are needed.  The rm should work no matter what the size.


    Boot in safe mode and try the rm again while booted in this mode.

  • Don Archibald Level 10 Level 10 (101,125 points)

    There is an old trick which may work.


    Make a new folder and move the problem file into it.


    Outside of that folder (like on the desktop) create a TextEdit file; it can be empty. Give it the exact same name as the problem file. Then drop it into the folder containing the problem file. A splash screen should appear; one of the choices offered should be "replace" - select that one.


    If this works, the problem file should disappear immediately, replaced by the far smaller TextEdit file.

  • Don Archibald Level 10 Level 10 (101,125 points)

    No, using a TextEdit file is just convenient; it can be any kind of file as long as the name is the same. Since you already tried it, doing it again probably won't work.

  • PaulKemp Level 1 Level 1 (135 points)

    Looking at the last 4 loaded kexts:

    com.seagate.driver.PowSecLeafDriver_10_5          5.1.1

    com.Logitech.Control Center.HID Driver          3.4.0

    com.seagate.driver.PowSecDriverCore          5.1.1          1.7.1


    Makes me wonder why the msdos file system kext is loaded.. a 15GB file cannot fit on a FAT partition if I remember correctly. Where is the file located and what file system is it on?


    You may want to remove the Seagate and Logitech software temporarily and see if that helps (and make sure the kext is not loaded).


    Lastly, if you really want to eliminate the possiblility of a HW issue, you can boot to another OS and try to delete the file. I'd say try the Lion Recovery Partition and Utilities->Terminal, but not sure if that mounts the HD with R/W access and don't currently have the ability to test that as an option.


    Good luck!

  • X423424X Level 6 Level 6 (14,190 points)

    My last suggestion was to boot in safe mode and try the rm that way.  A safe boot will suppress all those third party extensions (among other things) so that they don't have to be removed.


    It is curious however why that msdosfs kext is running.

  • X423424X Level 6 Level 6 (14,190 points)

    Did you ever run Disk Utility from the recovery partition?

  • Paul_31 Level 6 Level 6 (12,195 points)

    Restart holding down Command+R and it should be clear from there.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.