Skip navigation

XCode 4 hanging on startup

1325 Views 4 Replies Latest reply: May 13, 2012 11:54 PM by L2020 RSS
zelz Calculating status...
Currently Being Moderated
Mar 25, 2012 10:57 PM

I installed XCode 4.3.1 a couple of days ago from the app store but it's not working - It keeps hanging on startup.

 

When I create a new user and log in as that user xcode works without problem - so the problem is specific to my user.

 

During startup, before it hangs, xcode appears to be trying to recover 2 "unsaved xcode documents."

XCode hangs showing 2 screens with the message "No Editor."

 

To fix the problem I've been trying to get rid of my user specific XCode settings.

I deleted the following but there was no change...

~/Library/Developer/Xcode

~/Library/Autosave/com.apple.dt.Xcode.plist

 

I've also deleted anything I could find re old versions of xcode - but I can't recall the specifics.

 

Any suggestions?

iMac, Mac OS X (10.7.3)
  • Johnny Hack Calculating status...
    Currently Being Moderated
    Apr 12, 2012 8:51 AM (in response to zelz)

    Can someone tell me the fix for this? Why does Xcode work for the "new user" and not me? I am running Xcode 4 and Lion.

     

    Come on "somebody", throw me a bone!

  • L2020 Calculating status...
    Currently Being Moderated
    May 13, 2012 11:54 PM (in response to zelz)

    I just fixed this problem.  

     

    Go to ~/Library/Cashes,  search for  Xcode,  delete all "Unsaved Docs".  Empty Trash.  It worked fine afterwards.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.