7 Replies Latest reply: May 18, 2012 7:59 AM by Warren T.
Warren T. Level 1 Level 1 (10 points)

Hi, all -

 

After more than 5 years of having to constantly reboot my router because of lost connections to the Internet, I thought it would be time for a change. So I purchased a new Netgear router that works great with my mobile devices, including a PC notebook I have on my home network. (I should note that while all the other devices on my home network would lose their connection, the iMac somehow never did.)

 

However, when it came time to connect my iMac G4 I ran into some trouble. The iMac recognizes the new router and the WiFi signal strength is perfect, but I was unable to connect to the Internet. I opened the Network utility in Preferences to try to check the settings, and the following error message appeared:

 

<<Your network settings have been changed by another application.>>

 

What happens is, even though I click OK to clear the message, it keeps on reappearing on an endless loop; the only way out is to Force Quit the Network utility. Although this problem occurred with my older router, I was still able to connect to the Web; now I can't.

 

Can anyone recommend something that would help me restore the Network utility, as well as provide me with some guidance about getting connected to my home network?

 

Thanks!

 

Warren T.


iMac (Flat Panel 2003), Mac OS X (10.4.11), Airport card installed.
  • 1. Re: Why Can't I Connect to the Internet?
    Allan Jones Level 7 Level 7 (30,435 points)

    If you Google the error message verbatim, you'l find lots about this. However, the answer marked as "Solved" in this thread:

     

    https://discussions.apple.com/message/8318865?messageID=8318865&amp%3b#8318865?m essageID=8318865&amp%3b

     

    usually fixes the problem.

     

    You may be behind on software updates. The problem appeared after a security update released four years ago, and most people have worked through it with newer updates.

  • 2. Re: Why Can't I Connect to the Internet?
    Warren T. Level 1 Level 1 (10 points)

    Thanks very much... problem solved. But it now seems that I just can't connect to the Web no matter what, using Airport and my new Netgear router. The system recognizes the router—it's got a very strong signal—but no matter what, I cannot bring up a Web page.

     

    Help!

  • 3. Re: Why Can't I Connect to the Internet?
    Allan Jones Level 7 Level 7 (30,435 points)

    It might be worth asking in the Airport forums here:

     

    AirPort

     

    I'm sure it's a setting issue but did not have to troubleshoot our wireless Macs when I set up our wiresless system four years ago. I suspect someone there will know if you need to select a different form of encryption of some other setting alteration.

     

    I don;t have a 10.4 Mac set up that has wireless so can't check from here.

  • 4. Re: Why Can't I Connect to the Internet?
    Warren T. Level 1 Level 1 (10 points)

    Thank you, Allan-

     

    But it seems I've got some other issues that may be the source of my connectivity problems. There appears to be a corruption in my keychain, as it is not accepting my administrator password when I make changes to my Network preferences. I'm also experiencing some problems with permissions, etc., on my hard disk (as well as with an external USB HD), which the Apple Disk Utility cannot repair. Can you recommend a good disk repair that would take care of these problems for me, for my iMac G4 OS 10.4.11?

     

    Thanks again,

     

    Warren T.

  • 5. Re: Why Can't I Connect to the Internet?
    Allan Jones Level 7 Level 7 (30,435 points)

    I'm also experiencing some problems with permissions,

     

    Don't get too worried about permissions reports; there are a lot of "spurious" permissions reports or ones that, although correct, do not have any bearing on the proper operation of the computer. You can safely ignore most, as pointed out in this article:

     

    http://support.apple.com/kb/TS1448

     

    Although the article talks about OS 10.5 and later, some of these will show up in OS 10.4 as well:

     

    Note: when repairing permissions, you should do it from a normal boot, not while booted from a system CD/DVD. Permissions are part of the user/ownership system and, if booted from an external device, the computer sees no owner/user so cannot do much.

     

    The most highly regarded disk repair utility is Alsoft's Disk Warrior (http://alsoft.com/). If you decide to buy, I strongly recommend you get it directly from Alsoft and ask before buying for a version that will work on a PPC Mac and OS 10.4. The system reqs for the current version here:

     

    http://alsoft.com/DiskWarrior/requirements.html

     

    say the current DVD requires at least a 867 mHz processor so you may need to request an older version from them. On that page are instructions for how to get a version on a CD if your iMac does not have a DVD-capable optical drive, but my bigger concern getting a version that supports the 800 mHz processor in you iMac

     

    This list of troubleshooting and maintenace articles:

     

    http://www.thexlab.com/faqs/faqs.html

     

    has helped me many times. Might want to review ones that sound pertinent to your issues or simply bookmark it for future reference. It's close to the top of my bookmark lists.

  • 6. Re: Why Can't I Connect to the Internet?
    Warren T. Level 1 Level 1 (10 points)

    Hi, Allan -

     

    I appreciate your comprehensive response to my concerns. I am hoping that the Alsoft product can repair my system so that when I make changes to my Network preferences and am asked for my Administrator password, I do not receive an error message saying I entered an incorrect password.

     

    What do you think?

     

    Thanks again.

     

    Warren

  • 7. Re: Why Can't I Connect to the Internet?
    Warren T. Level 1 Level 1 (10 points)

    Hello, again -

     

    Thank you for your advice. I've been in touch with someone at Alsoft who is making recommendations.

     

    I should also like to mention that one of the errors I get when attempting to load a web page concerns my DNS settings. Any idea how I can set them correctly so that I can get on the Internet? Just to reiterate, my iMac recognizes the router but that's as far as it goes (while all other devices on the network work fine).

     

    Thanks again.

     

    Warren