Skip navigation

Photos gone after iCloud restore

1733 Views 3 Replies Latest reply: Sep 9, 2012 7:02 PM by pvonk RSS
igho.st Calculating status...
Currently Being Moderated
May 14, 2012 7:11 PM

After restoring from iCloud, the photos in the photos app only have thumbnails (when tapped it just expands the thumbnail)and and when trying to play a video, it returns with an error "The requested URL was not found on this sever" (it was supposed to be stored on the device)

It had been a day since i restore the iPad, and I've already delete the camera roll backup to make room for other stuff. I've tried killing the app, restart the iPad, hard reboot, and resetting all my settings without success :(      

 

I have been restoring from icloud many times and NEVER had this problem, i suspect something went wrong druing the restore (everything else was fine, except the apps download slowly and I had to tap them to keep them from freezing) if you know anything about what might have caused this or preventing this from happening again, please reply, any help will be greatly  appreciated

 

Incase you're wondering, I have an iPad 3 gen wifi, and the wifi/internet connection was fast(I tested with the speed test app as soon as it installed) and everything else restore correctly, although slow for some reason (iCloud sever problem?)

iPad (3rd generation) Wi-Fi, iOS 5.1
  • ezyjules Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2012 4:09 PM (in response to igho.st)

    I fixed this issue after a lot of time and pain (see below)

     

    Seems to have come up on various threads so it seems to be an issue and should be escalated by Apple. They were none the wiser at the genius bar apart from telling me the iCloud backup is probably corrupted and I should call Apple care (as if that is going to do anything)

     

    https://discussions.apple.com/message/18829957#18829957

    https://discussions.apple.com/message/17988389#17988389

    https://discussions.apple.com/message/17887940#17887940

    https://discussions.apple.com/message/18811914#18811914

    https://discussions.apple.com/message/18688593#18688593

    https://discussions.apple.com/message/19426061#19426061

    https://discussions.apple.com/message/19203831#19203831

    https://discussions.apple.com/message/18390030#18390030

     

    I experienced the same problem with the iCloud restore not working properly. I had my iPhone 4 replaced as the home button was defective. When attempting to restore an 9.5GB iCloud backup from the day before it just would not work properly. Firstly, half my apps did not restore, they would begin to download showing the progress indicator then just disappear, leaving my home screen naked. No big deal as apps can be downloaded again.

     

    However, what was a big deal for me was the 1,625 photos on my camera roll, including many of the first year of my kid's life. The camera roll would say downloading x of 1,625 photos, download a few of them, then simply stop downloading any new shots. When I would restart the phone it did not show any downloading message, it believed the restore was complete. I tried about ten different restore scenarios, listed below, all of which gave me varying results (some resulting in all my apps restoring) but all of which would only give me some of my photos back.

     

    What was a comfort was that I once got about 700 of the shots back. So the photos were still in the cloud rather than gone and this indicated that it was the restore process or the iCloud backup on my phone that was the problem. These are the things I tried in sequence as I despairingly tried to get my photos back...

     

    Things I tried that DID NOT work

     

    1) Erase all settings and attempt to restore again from scratch (four times)

    2) Tried the restore from a different WiFi network (once)

    3) Tried the restore from one WiFi network then switched to another once the restore 'hung' (once)

    4) Tried the restore from an Apple store WiFi network (once)

    5) Tried the restore from a previous iCloud backup (twice)

    6) Had Apple replace the iPhone 4 (once)

     

    With all of these I got a varying amount of my photos and apps back before it stopped restoring. I was also making the mistake (I learnt afterwards) of opening and moving between apps during the download to check progress.

     

    Thing I tried that DID work

     

    1) Did not plug the phone into my MacBook, I used the wall charger only to prevent any iTunes sync activity

    2) Erase all settings and data, restore from the iCloud backup and input passwords in all the pop up windows once it reboots.

    2) Open photos app gallery to see photos downloading and show the progress message "downloading xx of x,xxx"

    3) Left it on this photo screen and did not touch the phone at all for the entire restore. I did not close the photo galley/camera roll app once, open any other apps.

     

    Finally this time round it work and all my photos and apps restored in full. I am going to go back to syncing with iTunes as I don't trust iCloud for restores. It seems that iCloud does not handle photo restores that well, especially if the gallery is large. In short: Wall charger only, restore from iCloud, open Photos app, don't touch. Really hope this works for you too if you've had the same issue.

  • pvonk Level 6 Level 6 (13,670 points)
    Currently Being Moderated
    Sep 9, 2012 7:02 PM (in response to igho.st)

    ALWAYS sync your photos to a computer as a storage medium. You can either use USB to sync or with Photo Stream (if that works for you) to got copies of the photos to the computer. Do this as you would save photos from a camera to your computer.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.