Skip navigation

My iPhone 4S is not charging when plugged into clock radio. What's wrong?

10934 Views 12 Replies Latest reply: Sep 20, 2013 2:00 PM by nkrn RSS
Nubwagon Calculating status...
Currently Being Moderated
Mar 16, 2012 2:01 PM

So about a week ago, I docked my iPhone 4S into my Sony ICF-C7iP clock radio as I do every evening before going to bed. I bought this clock radio back in August and have had no problems with it at all. However this time, I noticed my phone was not charging. It didn't make the charging beep nor did it show on the display that it was charging. I tried removing it & re-seating it...nothing. I tried rebooting my phone which resulted in the same problem. When I plug my iPhone into either a standard sync cable or an iPhone dock, it charges/syncs as normal.

 

Suspecting the problem was with the alarm clock, I contacted Sony support. The clueless support rep on the other line suggested I return the clock in exchange for a refurbished one. For a $60 clock, this was more trouble than it was worth, so I decided against it.

 

I then decided to purchase an iHome iA9 which was sure to work. I just unpacked it and set it up. When I docked the iPhone on it...you guessed it...nothing. It is still not charging. The funny thing is that the iPhone will play music through the iHome with no problems. I had also tried plugging the iHome into a different outlet with no luck either. I am out of ideas. I am left to assume that for some reason, my phone does no longer like charging when docked on to an alarm clock.

 

Does anyone have any ideas or suggestions on how I can get this to work again? I recently upgraded to iOS 5.1 and honestly don't know if that would have anything to do with it. But the likelihood of 2 completely different clock radios exhibiting the same problem is virtually non-existent.

 

As mentioned, I tried rebooting the phone with no luck. Docking the phone to a standard charging cable plugged into the wall charges the phone fine. Docking the phone on an iPhone compatable dock charges the phone fine. Is the problem with my phone?

 

Thank you in advance for your assistance!

  • madforit73 Level 1 Level 1 (75 points)

    hi nubwagon

    check and make sure your sony clock docking points are clean and theres nothing (for example any dust/fluff stuck in it)

    make sure the iphone is clean to at the bottom were you connect your usb cable

    As i had similar problem,but with my macbook,i would plug it in to charge (macbook this is )and the little orange light would not illuminate (this is on the macbook charger cabe),then the charging icon at the top of the screen would not show it was charging.

    so i check the connection point,and you know what was causing the problem?yeh you guessed it ,a little piece of fluff!!

    cleaned it,and hey it worked.

    im not saying its what your problem is,but worth checking

    good luck

  • rockmyplimsoul Level 5 Level 5 (5,375 points)

    Sometimes iOS updates affect compatibility with devices that used to work.  While it is natural to assume it is Apple's fault, it can easily be the accessory manufacturer's fault for not incorporating certain(existing) iOS requirements, which may only reveal itself after an iOS update.  The manufacturer may offer a firmware update soon, so check with iHome (you may have more success with them than Sony).  Of course, it could be Apple's fault, which may be resolved in a future update.

  • KiltedTim Level 8 Level 8 (35,975 points)

    There is no supported way to downgrade iOS. Once you upgrade, you can't go back.  Doing so will void your warranty and forfeit your right to support from Apple or on these forums.

  • KiltedTim Level 8 Level 8 (35,975 points)

    Nubwagon wrote:

     

    I'm left to assume the iOS upgrade knocked out the ability to charge on all 3rd party charging devices.

    Your logic does not stand. If fact, you disproved this statement in the previous sentence:

     

    Nubwagon wrote:

     

    So I can charge my iPhone on my old iH9 but not on the iA9 or the Sony clock radio.

    Apple did not disable the ability to charge with other devices.  What you have is 3rd party alarm clock/docks that didn't meet the specs laid out by Apple from the beginning.

     

    Talk to the manufacturer of the clock.

  • rockmyplimsoul Level 5 Level 5 (5,375 points)

    Nubwagon wrote:

     

    So how is this not Apple's fault?

    Tim touched on it, but I'll elaborate ...

     

    As you can imagine, as a designer there can be multiple ways to implement a particular function in the complex relationship between software and hardware. One of the ways will be "correct" (or at least more correct) but other approaches may work, for a time.  As the software changes, these "alternate" approaches no longer work, giving the impression that it is the software's fault.  Accessory manufacturers are supposed to follow set rules for interfacing with iOS, but it is quite possible that their implementation is not correct, but may function just fine upon release.  Eventually the accessory manufacturer's implementation no longer functions because they didn't explicitly follow iOS defnitions.

     

    One could also argue that Apple did not define the rules clearly, or maybe even changed the rules along the way, but we'll really never know.  Your best bet is to contact the accessory manufacturers to see if they have a firmware update (but don't hold your breath).

  • Simplelivn Calculating status...

    Did you try rebooting the iPhone while it was in the dock?  That's what worked for me on a iHome IA9.

  • papaman6 Calculating status...

    FYI my iPhone 4S stopped charging on the iHome alarm clock with no changees or updates made on on the 4S.  I really appreciate your comments of 6/28/2012.  I contacted iHome and was told the thing.  I was about to send my iP23 for repair but now i am going to send it to the recycle yard. 

  • nkrn Calculating status...

    I have two IHome clock radios one for the front part of the house & one for the bedroom.  The older one works fine & charges my iphone.   But the newer model IP9 keeps showing a warning "Charging is not supported with this accessory"  and when I was playing music from the iphone such as Pandora, it was cutting off.  I called iHome Customer Support and was told it was probably the docking connecter and I should purchase a new one for $13.50 (must send check before they would mail me the part).   So I receive the new part and install it with no printed instructions.  Customer Service rep said it was really easy just a couple of screws.  Wonder if she had ever replaced one as it was more than than.   But after replacing the new docking connecter, I still get the message, "Charging not supported with this accessory".   After reading others experiences....& my experience.the newer iHome radio goes to the trash bucket.   What a waste! 

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.