7 Replies Latest reply: May 16, 2012 6:49 AM by ds store
Catherine Lloyd-Evans Level 1 Level 1 (0 points)

I'm getting this error message when I try to launch Mail, having upgraded to Snow Leopard 10.6.3

 

'You can't use this version of the application Mail with this version of Mac OSX.  You have Mail 3.6.' 

 

Where can I find a link to the latest version of Mail?  I have tried doing the software update, but the problem persists.


Mac Pro, Mac OS X (10.6.3)