Skip navigation

Bookmarks not syncing in iCloud

24189 Views 16 Replies Latest reply: Jan 19, 2013 7:53 AM by mrsurefire RSS
1 2 Previous Next
Geez Jan Level 1 Level 1 (0 points)
Currently Being Moderated
May 5, 2012 3:54 PM

I have an iMac and a MacBook Pro. Both are on Lion 10.7.3 and iCloud. Bookmarks are set to sync to iCloud on both computers, but they don't sync automatically. If I add a bookmark on one, it will not appear on the other unless on the second computer I go to System Preferences->iCloud and uncheck and recheck Bookmarks. Everything else seems to sync as expected. Anyone else have this?

iMac, Mac OS X (10.7.3)
  • MikeNJ Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 7, 2012 10:55 AM (in response to Geez Jan)

    I have the same issue.  MacAir, ipad, iMac.  Bookmarks only thing not syncing.  What's the cure here?

  • pcoley Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 15, 2012 8:37 AM (in response to Geez Jan)

    I have the same. The workaround until such a time as Apple Releases a fix is to check and then un-check tick box in System Settings > iCloud, then select Merge.

  • aut0maticdan Level 1 Level 1 (45 points)
    Currently Being Moderated
    May 15, 2012 3:53 PM (in response to Geez Jan)

    I have the same issue.  One thing I also have going on is that I use Xmarks to sync in addition to icloud.  Anyone else doing this?

     

    I'm pretty dissatisfied with how much they've dumbed down the sync tools.  Why is merge the only option?  Why can't I overwrite local or cloud?  I really miss the advanced tab which allowed you to clean up messes like this in a few clicks.  I'll probably have to just go premium on Xmarks so I can sync to iOS and be done with it.

  • Valentin Starke Level 1 Level 1 (40 points)
    Currently Being Moderated
    May 16, 2012 10:36 PM (in response to Geez Jan)

    Hello ... I believe once the problems with sync start the system is in a state of "Lost in the middle", and changes are no longer passed on. This happened to me. You can durably solve this issue by bringing all computers to exactly to the state in which the iCloud copy of your bookmarks is, and syncing starts working again flawlessly: Across my Macs, my iPhones and my iPads - everything worked.

     

    1) Export your bookmarks: In Safari go to File -> Export

     

    2) Switch off iCloud synchronization for Bookmarks in "System Preferences" -> iCloud.

     

    3) Exit Safari.

     

    4) Delete current local copy of Bookmarks: Go to Finder -> Go, press alt-key to show the hidden menu items under "Go", click on Library. In Library find Safari and drag the file "Bookmarks.plist" to a safe location.

     

    5) Switch on iCloud synchronization for Bookmarks.

     

    You will see the system doesn't propose to "merge" anymore (because there are no local bookmarks anymore to merge with). After the initial synchronization your bookmarks are completely in sync and keep in sync for whatever changes you do. You may need to check whether the iCloud copy which was synced to your local user included all Bookmarks and you can add the missing ones by using the file you exported in step 1.

     

    I had to repeat this procedure on every Mac but then I had never again any problems.

     

    On the iPhone, iPad things are much easier. You just switch off sync, choose to "Delete Bookmarks on iPad/iPhone" and switch it on again. Presto.

     

    V.

  • AllMacs Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 17, 2012 4:51 PM (in response to Valentin Starke)

    To Valentin Starke. I just want to make sure I'm doing this right. I went to Safari - File and Export Bookmarks to my Documents. Where would you suggest a safe location for the Bookmarks.plist file?

  • Ricky\'sLinda Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 15, 2012 10:43 AM (in response to Geez Jan)

    Thanks so much for this.  It works perfectly.  If anyone is confused about deleting bookmarks file on iPhone and iPad, when you switch off Safari Bookmarks in iCloud settings, it asks if you want to merge.  Say yes, but then trun them right off again and it will prompt you to delete all bookmarks.  Then when you turn it back on, you will get the fresh version from iCloud, and as stated above all should stay syncing with iCloud going forward.  I did a MacPro, MacBook, iPad and iPhone.  Appreciate this!

  • mervb Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2012 2:43 AM (in response to Valentin Starke)

    Thanks, worked perfectly!

  • Jeffrey Frankel Level 1 Level 1 (25 points)
    Currently Being Moderated
    Aug 4, 2012 2:01 PM (in response to Valentin Starke)

    Valentin, thank you for this solution.

  • Jim Berryhill Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2012 6:38 AM (in response to Valentin Starke)

    Valentin, thank you for the clear information.

     

    Just one question. In System Preferences, the iCloud option is simply "Safari". When you say "Switch off iCloud syncronization for Bookmarks", is unchecking/checking the box for Safari the correct action to do this?

     

    That makes sense to me but I just want to make sure :-).

  • avogadro23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2012 11:33 AM (in response to Valentin Starke)

    Had the same problem and this Valentin's solution worked for me.

  • Larry Auerbach Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 18, 2012 6:34 AM (in response to Valentin Starke)

    Thanks. This just worked for me.

  • UK Gord Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 9:55 AM (in response to Geez Jan)

    Can I suggest a rather simple workaround?

     

    New bookmarks that you create on any iOS device will sync with Safari properly and therefore will propagate across any other browser. Job done. Same if you create them in Safari. No problem.

     

    New bookmarks will not propagate properly to iOS if you create on another desktop browser.But, they will make it as far as Safari on your computer.

     

    So, if you create new bookmarks in a desktop browser other than Safari, then just put them in the bookmarks bar, or in the root directory, or someplace else you can easily find them. Then when convenient you can go into Safari and move them to the place you actually want them.

     

    Why? The act of moving the bookmark makes iCloud notice it, and therefore it is then correctly synced with all devices. Not ideal, but quite easy and probably good enough until the Xmarks team can fix it properly.

  • UK Gord Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 9:57 AM (in response to UK Gord)

    Sorry, this is in the wrong thread - this makes Xmarks sync work. Apologies.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.