Skip navigation

HT4014: About the Mac OS X v10.6.3 Update

Learn about About the Mac OS X v10.6.3 Update

HT4014 Need a link to correct version of Mail...

1015 Views 7 Replies Latest reply: May 16, 2012 6:49 AM by ds store RSS
Catherine Lloyd-Evans Calculating status...
Currently Being Moderated
May 15, 2012 6:45 AM

I'm getting this error message when I try to launch Mail, having upgraded to Snow Leopard 10.6.3

 

'You can't use this version of the application Mail with this version of Mac OSX.  You have Mail 3.6.' 

 

Where can I find a link to the latest version of Mail?  I have tried doing the software update, but the problem persists.

Mac Pro, Mac OS X (10.6.3)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.