Skip navigation

Address Book... Can't edit anything anymore?

1201 Views 7 Replies Latest reply: Nov 15, 2012 8:19 AM by Columkil RSS
cp_whaley Level 1 Level 1 (0 points)
Currently Being Moderated
May 15, 2012 12:34 PM

Somehow, I've lost the ability to make changes to anything in my address book desktop app. All edit options in the menu are greyed out, and there is no Edit button on each card like there used to be.


If I knew where the database was located, I might be able to check the permissions, but I don't.





G5 iMac, Mac OS X (10.6.5)
  • mo\'green Calculating status...
    Currently Being Moderated
    Jun 14, 2012 12:35 AM (in response to cp_whaley)

    Hi. I got the same issue, but I found this which solved my problem:


    Try rebuilding the database file Address Book uses.


    To do that, quit Address Book, then while in Finder hold down the Option key and click the Go menu - select Library from the list. That will open the hidden Library folder in your user home folder. In that folder, locate and open the Application Support folder, then the AddresBook folder. In that folder locate the file named AddressBook-v22.abcddb and throw it away.


    Then close all those windows and start up Address Book, then test.


    I think my problem initially began after migrating in 3D:

    - to a new computer via migration assistant,

    - from OS 10.6.7 to OS 10.7.4 and finally

    - from MobileMe to iCloud.


    I had some permission issues and some trouble with multiple iTunes accounts.

    Still bugging me though is, that my Mac says "no devices syncing" when I press the sync circular arrows in the menu line. Did the sync function stop working with iCloud??


    Anyway, hope this helps,

    ...... Mo'.

  • MaartenAertsGeldrop Calculating status...
    Currently Being Moderated
    Aug 15, 2012 3:08 AM (in response to cp_whaley)

    Thanks for the solution. I was about to give up on addressbook...

  • Robin Imandt Calculating status...
    Currently Being Moderated
    Oct 22, 2012 2:33 PM (in response to mo\'green)

    You are a genius! It worked like a charm. Thank you!!!

  • Columkil Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2012 8:19 AM (in response to cp_whaley)



    Thanks! A headache solved!



More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.