Skip navigation

am i the only one having problems with mainstage 2.2.1 and lion 10.7.4?

3760 Views 29 Replies Latest reply: Jul 18, 2013 7:05 AM by Elevatormusicmaker RSS
1 2 Previous Next
timb3 Level 1 Level 1 (0 points)
Currently Being Moderated
May 16, 2012 11:50 AM

Mainstage crashing , cpu spiking, and a couple of new things - the cpu panel in mainstage started flashing white before the last crash and if you edit the   EX24 inside mainstage, it keeps asking if you want to save but won't let you. Anyone else had these sort of problems? have tried to eliminate any potential problems like cpu heavy AU,s, changed M audio settings (now much more latency) still crashes when I actually play any smudges or fast riffs (Yes, I still pretend to be keith Emerson!) Now looking at hardware solutions again as mainstage is now IMHO not stable enough for gigging.

Come on Apple sort out the bugs please.

MainStage, Mac OS X (10.6.8)
  • Blueberry Level 4 Level 4 (2,825 points)

    No, 10.7.4 broke MainStage. Go back to 10.7.3 e.g. via your Time Machine backup and the problems are gone.

  • Peteyvee Calculating status...

    You are joking, right? I updated to 10.7.4 and then purchased Mainstage 2 day before yesterday. I've just finished downloading all the stuff and after 20 straight hours, I'm letting the Mac rest. If it doesn't work and I go back to 10.7.3, I'll have to reinstall mainstage and then take another 20 hours to get all the packs re-loaded. So what other issues are you guys having, so I can look for them when  I go home and fire it up? It didn't crash when I opened it for a couple of minutes and then went to bed last night.

     

    15" MacProbook 2.4ghz i7 quadcore 8 GB RAM Mainstage 2.2.1 OSX 10.7.4

  • Ellio Biagi Calculating status...

    I’m  having exactly the same problem with mainstage 2.2.1 / Lion 10.7.4.  I’m a backline tech running to to new macbooks pro through a Radial SW8 and the two Mainstage crashes simultaneously after about 20 min of playing. This is scary, scary stuff as the band is totally dependent on steady computers.

     

    Played more than 60 shows and hade problems at only one show, unfortunately  at very big festival  in the dessert close to LA (esx started to cut the samples after 2 sec....) . That’s why I updated  but it looks as the troubles only got worse. Should I stay with Mainstage  2.2.1 and downdate to the earlier Lion?  Any experience out there?

     

    2 x Macbook pro 13"   2.8 ghz i7 4 gb ram 128 ssd Mainstage 2.2.1 osx 10.7.4

  • Blueberry Level 4 Level 4 (2,825 points)

    I got a hint from a friend, that seems to fix this problem:

     

    1. Control-Click into the toolbar of MainStage, select "Customize" and remove the CPU/MIDI/Memory meter display.

     

    If you want to add some additional safety: switch MainStage to 64-bit mode.

  • kallisti Level 1 Level 1 (0 points)

    Hey are any of you using Logitech input devices?

     

    I managed to trace my mainstage crashes to the logitech drivers

     

    unplugging my mouse stopped the crash as well as removing the 2 kernel extensions (and rebooting)

     

    running 10.7.4 here

     

    mainstage so far does not crash in 32bit mode

     

    if its running in 64bit mode with mouse and drivers active, Mainstage automatically performs an AU test at launch:

    • aborting the test will crash Mainstage

    • when the test is complete, if I refuse the option to check the results of the test via the AU manager, Mainstage will crash.

    • viewing the AU test result for some reason allows Mainstage to run without crashing

     

    so whacky

     

     

    I'm about to do the pram/nvram reset

  • RhythmCulture Calculating status...

    Please. does any one here have a solution to solve the crashing of MainStage 2.2.1?

    My MainStage version does not open while it is in the Apple search mode window.

  • kallisti Level 1 Level 1 (0 points)

    did you bother reading the thread?

  • mindprinting Calculating status...

    Yes seems the 10.7.4 is the problem. I had Mainstage 2.2 32bit (was not able successfully set 2.2.1) running very stable on 10.7.3 and just after updating OS X all is gone wrong. My symptoms are that once the song reaches the ned of the backtracks (using playback plugin) I will stuck in that position and I cannot change patches. The other is that even during the a song the graphics in full screen will get stuck and and the end again I cannot switch to any patch. Resulting only in Mainstage to have it restarted almost after every song.

     

     

    If during the playback the patch did not freeze and I managed to stop it before it reached end I was able switch to a different patch. Notice that the instruments and the tracks played until end with no glitches.

     

     

    I have now to figure out how to revert to 10.7.3, but it already cost me yesterday a very stressful gig not to mention I got not payed for it since the band leader got fed up with it. Really disappointed with the quality check of apple team on OSX and Mainstage.

     

     

    When producing software for realtime usage I would expect more quality and reliability. Very sad.

  • RhythmCulture Level 1 Level 1 (15 points)

    Yes, I have read the thread.

    None of the solutions help.

     

    It appears that the Apple OS X programmers have not fixed this bug.

  • mindprinting Level 1 Level 1 (0 points)

    I do use Logitech BlueTooth mouse V470, but during live shows it's off and also the BlueTooth is turned off on the MacbookPro.

  • Dane Bryant Calculating status...

    Same Problem here. Machine is running so hot. I can't launch app Mainstage 2.2 in 64bit at all since 10.7.4 update. I make my living using this rig which was fine for the last 2 years. Now I am having to use hardware backup which is no where near the quality of the plugins I use.

    I am in the recording business and have used Apple products for over 20 years.......

    Come on Apple What's the problem here? WE NEED A SOLUTION and we need accountability.

    Some how I have a feeling this post will be deleted like the other complaints that are starting to emerge.

    Thanks Apple

  • RhythmCulture Level 1 Level 1 (15 points)

    I e-mailed Apple and explained the "bug" problem.

    Apple sent me a new download via iTunes.

    After I installed it, it opened without any problem in Mac OS X 10.7.4

    This may help those who are havong a problem with MainStage.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.