4 Replies Latest reply: May 17, 2012 9:18 PM by Hovej
Hovej Level 1 Level 1 (0 points)

I have a setup where my ISP router hands out DHCP addresses and my 2 time capsules is used to backing up our mac computers. I´ve installed the TC´s in bridged mode and their ip addresses is from the DHCP. Then today I tried to setup both my TC´s with an ip address just outside the scope, this way I always know what their ip addresses are, useful for some of my other clients that uses them as fileshares. But if I do that it looks like they wont relay DHCP addresses anymore?? If my scope is 192.168.1.10 - 99 and the gateway is .1, the TC´s should agree fine with being .2 and .3. But everyone connected to the TC´s (ethernet and wireless) stops receiving DHCP addresses.. Is this by design or is it a bug. I´ve never seen any other network devices do this??

 

It would be ok, if I was able to enable the relay again, but I can´t.

 

Regards


Time Capsule 802.11n (3rd Gen), Mac OS X (10.7.4)
  • 1. Re: DHCP Relay
    LaPastenague Level 8 Level 8 (35,375 points)

    If the TC are in bridge it should not be handling dhcp at all.

     

    The issue may be the main router and it is unable to handle the TC with a static address.. this does happen and lots of routers will not work or not work well unless they handle the dhcp address to the bridge device.

     

    On the main router can you use a dhcp lock to MAC address.. so the TC will still get IP from the router but will always get the same one. This is a better way to work.. it has various names. Fixed dhcp, fixed host, static dhcp. Check the manual of the main router for details.

  • 2. Re: DHCP Relay
    Hovej Level 1 Level 1 (0 points)

    Hi,

     

    Thanks for the reply.

     

    No the Time Capsule shouldn't be handling DHCP, but it should relay the DHCP server, to the clients that is connected to it.

     

    The problem is the Time Capsule not the router. I've tried adding a netgear range extender to the setup. I gave it the same ip as the Time Capsule and connected to it with my laptop and got an ip instantly. So the router will hand out dhcp through any device that relays.

     

    Creating a static mapping on the router to the Time Capsules mac addresses, doesn't solve my problem. When the DHCP goes down, the Time Capsule assigns a private ip to itself after the lease period is over. And my lease period is 1 hour only for other reasons.

  • 3. Re: DHCP Relay
    LaPastenague Level 8 Level 8 (35,375 points)

    Go back to the start.. something is strange.. I run a number of TC in bridge and they have no issues getting IP and in fact in bridge if there is no dhcp server they will self-assign a 169.254.x.x address. Each time the lease expires the TC should simply find itself an address.. i have set this up with numerous different modems and routers. and not one has had issues. Although it is not unknown for dhcp to fail. You will generally have to do some rather intensive investigation, using a hub or a managed switch where you can mirror the ports and use a utility like wireshark to check dhcp requests.

     

    You stated the ISP is giving you dhcp address.. does this mean you have a block of Public IP addresses?

    I didn't think so because you then give the address range as 192.168.1.10-99.. that has nothing to do with the ISP and is purely from the modem router. So what did you mean by that statement??

  • 4. Re: DHCP Relay
    Hovej Level 1 Level 1 (0 points)

    I stated that the router from my ISP hands out addresses in the range 192.168.1.10 - 99, a private range. When I configure the Time Capsules with a fixed address that is outside the configured scope, but still in the same subnet, they stop relaying dhcp addresses to the clients connected to the Time Capsules.

     

    And yes the will self-assign a 169.254.. Address if the dhcp is off-line long enough, but thats not good, I need them to have a fixed address in the subnet mentioned.