Skip navigation

iwork free trial can't be downloaded ?

6292 Views 4 Replies Latest reply: May 18, 2012 11:26 AM by sametar RSS
sametar Calculating status...
Currently Being Moderated
May 18, 2012 5:06 AM

Hi have a year old mac air and in my older one i had iwork6.

 

I tried to use the free 30 days trial for iwork but for some reason I just can't activate it   I don't even get this sign:

 

Download the free iWork '09 30 days trial version.

 

 

I downloaded all my files from older mac to this one, could this be the reason?

 

I

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.