Skip navigation

Choppy Scrolling in Lion

26365 Views 75 Replies Latest reply: Sep 1, 2013 2:19 PM by txparticleman RSS
  • viciousvex Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 24, 2011 5:10 AM (in response to viciousvex)

    Hello!

     

    Just wanted to say that my choppy scrolling problem has appeared again. Don't know what is causing it, but neither a new user nor disabling blurry backgrounds in Terminal windows does change that. I also upgraded my iMac to 6 GB. Scrolling is all fine after a reboot and terrible after putting the Mac to sleep and waking it up again.

     

    Scrolling stays ugly and choppy even after minutes of use and doesn't go away. Only a restart seems to solve this issue.

     

    Anybody else still experiencing this?

     

    Alex

  • Foureyes2006 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2011 6:24 AM (in response to viciousvex)

    Do turn your wireless keyboard off. It will send your computer to safe model if you turn on the wireless keyboard during your computer start. Never turn off your wireless keyboard even you turn off the computer. Good luck!

  • Karlo Facherpour Calculating status...
    Currently Being Moderated
    Sep 25, 2011 4:20 PM (in response to WeBey)

    After upgrading to Lion, I noticed the choppy scrolling after my macbook pro 13 2011 goes to sleep. I thought it was something i installed but have since done a clean install of Lion and till notice the choppy scrolling through out the OS. It drives me nuts because the only way to solve this is to restart the laptop. I used to restart snow leapard once a month or two. With Lion i have to restart once or twice a day.

  • Brooke Cargill Level 1 Level 1 (35 points)
    Currently Being Moderated
    Oct 18, 2011 3:49 PM (in response to Karlo Facherpour)

    I deleted Adobe AIR and Flash Player and scrolling is perfect again, even without restarting after the uninstalls. 'Course, my Zinio app won't work without AIR, so I guess I'll have to figure that out!

  • ronny.holmstrom Calculating status...
    Currently Being Moderated
    Oct 22, 2011 2:52 PM (in response to WeBey)

    I’ve discovered the choppy scrolling to disappear if I touch my Magic Mouse with only the finger doing the scrolling. If I put down other fingers on the mouse the choppy scrolling comes back. Looks like there is a ”disadvantage” from the multi-gestures. Please try this and get back with your experience.

  • joemamajoe Calculating status...
    Currently Being Moderated
    Oct 29, 2011 5:29 PM (in response to WeBey)

    All -- my system has been unusable since the upgrade 2 months ago.  Fortunately i have two other machines.

     

    At any rate, I believe I have achieved success -- and I wish you all the best with this highly vexing problem.   Mac Pro, 2 Screens, 8 GB of RAM.   Perfectly fine on cold start, basically unusable after sleep.   I unplugged one monitor, and it worked perfectly on a single monitor setup.   sleep several times, all good.

     

    then i plugged back my 2nd monitor into the system, and it worked too.   sleep several times, still good.

     

    god willing, this will be the last of it [hope springs eternal].

  • Tuco09 Calculating status...
    Currently Being Moderated
    Nov 8, 2011 9:41 AM (in response to WeBey)

    Hello All;

     

    Just a not to advise that the scrolling issue is not just for Lion as my Imac with Snow leopard has developed the same problem.  I am using magic mouse.

  • mcbillion Calculating status...
    Currently Being Moderated
    Nov 14, 2011 1:09 PM (in response to WeBey)

    I´ve been experienceing the same thing, along with a reboot time that makes my i7 seem like a g3 with MS windows instead of Apples latest OS on it.

     

    I hope Lion gets a serious reworking soon, so these bugs are cleared out. Its not fun scrolling with this probelm.

     

    Clearing the cashe, restting PRAM and deleting dock plists helped some, but not enough.

  • jsmd80 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2011 1:13 AM (in response to WeBey)

    Hi,

     

    I got the same scrolling issues here, especially with safari. I am using a MBA 2010 and an iMac 2010 3.2 GHz Inel Core i3 with 4 GB RAM, pointer device is a amgic trackpad and a magic mouse, latest Lion incarnation. The scrolling issues worsens when you zoom into a homepage with safari (doubletap with the track pad).

     

    I already sent a bug report to apple. Hopefully they will solve this problem ASAP, it is annoying.

     

    BTW: the videos in system preferences explaining the multi gesture stuff with the trackpad are a little bit choppy, too. :-)

     

    Apple really needs to work this out. Maybe it is helpfull, when every one involved in this thread writes a bug report via http://www.apple.com/feedback/macosx.html

     

    -j

  • viciousvex Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 12, 2011 3:24 AM (in response to jsmd80)

    Hello everyone!

     

    User Hakaitz of the Apple Support Communities has worked out a solution, that has helped me getting my old Mac performance back. It involves installing the graphics drivers from Snow Leopard in Lion.

     

    This performance bug really annoyed me to no ends... Here's what user Hakaitz says in https://discussions.apple.com/thread/3198002?start=45&tstart=0:

     

    There is a fix for this problem.

     

    I just load with kext helper, the Snow Leopard Kexts from version 10.6.2 for the Radeon.

     

    End of stutters on laggy animations on any version of lion. Works on 7.1 and 8.1 imacs (at least).

     

    Here the fix:

     

    http://www.megaupload.com/?d=11INQM1D

     

    How to use ONLY RADEON 2600 USERS:

     

    execute kext helper

    drag and drop this files ONLY:

    ATIFramebuffer.kext

    ATISupport.kext

    ATI2600Controller.kext

     

    put your admin password and click on "easy install". I tooks a while to do the work. When finished, reboot (the kext helper aaaaalways hangs, its normal.

     

    After that reboot your computer wont stutter anymore.

     

    Hope it helps!

  • macpsychdoc Calculating status...
    Currently Being Moderated
    Dec 14, 2011 8:19 PM (in response to Strgzr)

    Please, everyone, give Apple lots of feedback on the problems with scrolling in Lion. (For me pretty much confined to lateral scrolling in Finder--almost unusable.)

  • justinxtreme2 Calculating status...
    Currently Being Moderated
    Dec 24, 2011 12:28 AM (in response to WeBey)

    Having the same problems too! At first I thought it was just me because my iMac is a bit older, it's a Mid-2007 aluminium iMac with a 2GHz Intel Core 2 Duo, 4GB of DDR2 RAM, and ATI Radeon HD 2400XT 128MB graphics. It doesn't feel as natural as before scrolling on my Magic Mouse. I only realized it might be a Mac OSX Lion problem when it did the same to my fairly new Macbook Pro (2009 model), which has a 9600GT (and 9400). It's not as bad as the iMac's but there's still a millisecond lag. Hmm...

  • mulligans missus Level 2 Level 2 (370 points)
  • WebJIVE Calculating status...
    Currently Being Moderated
    May 18, 2012 11:53 AM (in response to mulligans missus)

    The answer for me was to login as root, use terminal to rename my user directory to a new name, then create a new user with that user folder name and then let the system fix persmissions on all the files.

     

    Once I had the new profile up and running, Safari got smoother again.

     

    Here is where Safari still ***!  One tab crashes, they all have to be reloaded so, back to Chrome!!

     

    Apple, your webkit is broken compared to Chrome.  Why not just use their webkit with the safari framework on top and call it done.. sheesh..

  • myimac34 Calculating status...
    Currently Being Moderated
    Jul 15, 2013 4:28 PM (in response to viciousvex)

    For All having problem with scrolling depents on what did you downloaded for the Safari EXTENSIONS before if so for the resolve the problem TURN OFF the extensions and try again. If its worked it is mean one of your downloaded extentions causing the problem if you need any one of this extentions try one by one turn on and off  to find out which one is causing the problem. If you have Adware extension definitly will cause the scrolling problem.

    Open Safari

    Click on Safari (on left top corner)

    Click on Preferences

    Clik on Extensions and TURN OFF

    GOOD LUCK

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.