1 2 3 4 5 Previous Next 516 Replies Latest reply: Aug 21, 2013 3:10 PM by nicowieditz Go to original post Branched to a new discussion.
  • 30. Re: Logic 9's UI extremely laggy - any fixes?
    Thomas Colontonio Level 1 Level 1 (25 points)

    I removed ALL graphic analyzers AND set all EQ's to low quality (Under analyzer settings) and I am now running wayyy better.

     

    I realized I had my default set at High Quality, Analyzer turned on... whoops!

     

    This problems been driving me insane.. and I think I hav it fixed now.

     

     

    2008 Mac Pro 3.07 GHZ Dual processors Intel Xenon

    16 gig of memory

    10000 rpm Velociraptor gamer drive

    Logic Pro (Latest)

  • 31. Re: Logic 9's UI extremely laggy - any fixes?
    Thomas Colontonio Level 1 Level 1 (25 points)

    Also just upgraded toa  Crucial M4 SSD today and this has made the problem DISSAPEAR! WOW these things are fast!

  • 32. Re: Logic 9's UI extremely laggy - any fixes?
    Boyd Ostroff Level 2 Level 2 (195 points)

    Interesting - since I am using a MacBook Air with the SSD, maybe that's why I don't see these problems?

  • 33. Re: Logic 9's UI extremely laggy - any fixes?
    Thomas Colontonio Level 1 Level 1 (25 points)

    Whats your processor on your MB pro? I have an i7 newer one and never have those problems either. I swear it destroys my Dual processore 3.07 GHZ Mac Pro in my studio

  • 34. Re: Logic 9's UI extremely laggy - any fixes?
    fluffy Level 1 Level 1 (25 points)

    It doesn't seem like a disk I/O issue, although it could be a contributing factor.  Maybe there's something with integrated chipsets where the disk blocks the video system in some weird way.

     

    I did have this problem on my previous system (PowerMac unibody, the original C2D rev from late 2008) which had an aftermarket SSD in it, but that aftermarket SSD was having other I/O issues with OSX itself so it's hard to tell.

  • 35. Re: Logic 9's UI extremely laggy - any fixes?
    Michael Siedenbiedel Level 1 Level 1 (0 points)

    It's definitly a gpu issue. Some months ago, I changed the system prefs to use the better graphics chip (

    NVIDIA GeForce GT 330M 256 MB) everytime in my Macbook Pro, and now I realized this problem after some longer Logic sessions. So I tried to use the internal gpu (Intel HD Graphics 288 MB) and logics ui isn't laggy anymore... very strange...

     

    However it seems to be an 10.7.4 problem, for the actual build of 10.7.5 the developers got the instruction to have an eye on the graphics efficiency and network stablity... I hope the update will be soon available...

  • 36. Re: Logic 9's UI extremely laggy - any fixes?
    Darren Burgos Level 1 Level 1 (10 points)

    Ealier on this thread I had said that the problem was resolved after swapping out my video card. I hate to say that it's not actually entirely fixed. Using a stronger video card absolutely reduces the problem, but doesn't completely get rid of it.

     

    It seems like it's the Channel EQ's analyzer when placed on a secondary display. I use other third party EQ plug-ins like FabFilter's Pro-Q ...it's analyzer doesn't seem to cause the problem.

  • 37. Re: Logic 9's UI extremely laggy - any fixes?
    hypnotik Level 1 Level 1 (0 points)

    yeah Darren the problem is still here!

     

    I've also spent more than 500 dollars to reslove this, no luck.

     

    http://www.logicprohelp.com/forum/viewtopic.php?f=1&t=78028

     

    please read the whole thread on logicprohelp i've posted many videos to show the problem.

  • 38. Re: Logic 9's UI extremely laggy - any fixes?
    Thomas Colontonio Level 1 Level 1 (25 points)

    I also said that installing a SSD helped but now it hasent. Its a simple case of the logic EQ analyzer. If I have them turned off I have NO problems. Apple needs to fix this ASAP!

  • 39. Re: Logic 9's UI extremely laggy - any fixes?
    hypnotik Level 1 Level 1 (0 points)

    It is more than only channel eq analyzer many third party plugins use the same kind of ressource than channel eq uses.

     

    clean install of lion : nothing installed even not my apogee audio drivers! using core audio default settings


    4 channel EQ with analyzer on high in an empty project with 8 TRACKS using only stock channel strips and my 2009 Mac pro dual cpu with 16gb is on his knees, acting like crap as an old windows pc!


    Same problem! So......now what else ? You can add many SSDs, graphics card, ram, cpu's you want, you will have the same problem because there is a problem with performance / graphics allocation or whatever, it's hardcoded! Pure software thing!

     

    Please guys, join http://www.logicprohelp.com/forum/viewtopic.php?f=1&t=78028&start=100

     

    It is a real problem which exists since Lion came out 1 year ago........and nothing has changed.

     

    Apple please, please, please dooooooo somethinnnnnnnng i'm crying now!

     


  • 40. Re: Logic 9's UI extremely laggy - any fixes?
    Mike Connelly Level 4 Level 4 (1,785 points)

    Is there a list of plugins that have the issue?

  • 41. Re: Logic 9's UI extremely laggy - any fixes?
    fluffy Level 1 Level 1 (25 points)

    I've only come across it in the ChanEQ/PhaseEQ/etc. plugins with the analyzer turned on. Something about how the analyzer does its screen updates also messes up OSX Lion's UI eventing, or something.  I wonder if they're doing the screen updates by shoving a repaint event into the window's event queue but generating them faster than the app can service them.

  • 42. Re: Logic 9's UI extremely laggy - any fixes?
    Pancenter Level 5 Level 5 (7,640 points)

    fluffy wrote:

     

    I've only come across it in the ChanEQ/PhaseEQ/etc. plugins with the analyzer turned on. Something about how the analyzer does its screen updates also messes up OSX Lion's UI eventing, or something.

     

    The high CPU use of the channel EQ analyzer has been around for a long time (it's even mentioned in the Logic documentation)  however the effects it causes vary with different operating systems and different versions of Logic. As OSX added graphic layers (eye candy) the analyzer CPU use seems to be causing more problems,

     

    OSX/Logic have to support more hardware variations than at any other time in Apple's history, there's a greater chance for performance issues on some combinations. Hopefully ML can correct some of the performance problems.

  • 43. Re: Logic 9's UI extremely laggy - any fixes?
    fluffy Level 1 Level 1 (25 points)

    Except that it uses barely any CPU on a modern computer. Look at your CPU usage meter when ChanEQ's analyzer is turned on.  The problem isn't that it makes the system slow, the problem is that it introduces a huge amount of input latency, which makes it feel slow, but that's a very different thing than actually being slow.

  • 44. Re: Logic 9's UI extremely laggy - any fixes?
    Pancenter Level 5 Level 5 (7,640 points)

    fluffy wrote:

     

    Except that it uses barely any CPU on a modern computer. Look at your CPU usage meter when ChanEQ's analyzer is turned on. 

     

    I suggest opening Activity monitor and see what kind of CPU use you see with a couple of channel EQ's/Analyzers running in High resolution mode with their windows open. Now try it with 4 CEQ's in analyzer high resolution mode, with their windows open. The realtime graphic updating is the cause.

1 2 3 4 5 Previous Next