Skip navigation

Aperture 3 preview of raw file greenish

6259 Views 44 Replies Latest reply: Aug 27, 2012 5:19 PM by apple support user RSS
1 2 3 Previous Next
Klahane Calculating status...
Currently Being Moderated
May 13, 2012 10:06 AM

Just recently, perhaps after a Digital Camera Raw update, the previews of raw images Aperture 3.2.3 imports are dark with a distinctly green cast.

 

This happens when I let Aperture import direct from the camera, a Lumix FZ 150 with either of my two Lexar SDXC cards. During import, the thumbnail previews look normal. But during processing they turn green one by one. (The first time I saw this, I turned green. I thought there was something wrong with my camera or new 600x card.)

Double clicking the thumbnail produces a greenish full-sized image, which then changes to a normal image (I assume as Aperture displays the raw image).

 

If I drag the same raw files from the Finder, Aperture generates the previews normally.

 

This problem is easy to solve: select the greenish images, hold down option and choose Photos > Generate Previews. This forces Aperture to rebuild the preview.

 

(I found a few older discussions with similar-sounding problems, but none exactly the same.)

iMac (27-inch Mid 2010), Mac OS X (10.7.4)
  • dbmoore Calculating status...
    Currently Being Moderated
    May 13, 2012 2:57 PM (in response to Klahane)

    You can try all the trouble shooting ideas from the previous posts., dumping Cache, plist files. Boot into Safe Mode, run scrips like Cocktail, Iceclean etc.  Or use a card reader rather than connecting to camera.  Sorry kind of like the old Dr joke.... Doc it hurts when I do this.... Well dont do that.   I use a card reader all the time its faster and Im not likely to bump the camera off the desk.  Cheers

  • dbmoore Level 1 Level 1 (95 points)
    Currently Being Moderated
    May 13, 2012 8:17 PM (in response to Klahane)

    Well you surpassed my knowlege hopefully someone with a higher  level will chime in (not too hard to find).  Report it to apple so they know they might have a problem with that camera.  Did you reinstall AP or just migrate it over??   Good luck 

  • Alan Roseman Calculating status...
    Currently Being Moderated
    May 19, 2012 9:28 AM (in response to Klahane)

    I have a pair of Panasonic M-43 (micro four thirds) cameras and a full array of lenses.

     

    On both laptop and desktop using Aperture 3, with 10.7.4.

     

    I now get a very heavy green / brown overcast on every image during RAW import.  I must select every imported image and add a white balance adjutsment of "sunlight" to have a file normal in appearance.

     

    That said.  I attempted to apply the white balance adjust ment during import and it failed to make the correction.

     

    This occurs:

     

    Both Camera bodies

    All Memory Cards

    Core i7 MBP / 8 gig

    Mac Pro Dual core

    All running 10.7.4

     

    This appears to be a corruption of the RAW importer since the last OS upgrade.

  • mckenneym Calculating status...
    Currently Being Moderated
    May 20, 2012 1:43 PM (in response to Klahane)

    Me too. I have an LX5. And 190 images that have a green cast to them. Is the a way to back out the last update pending a resolution of this issue? I assume this also impacts iphoto.

  • dbmoore Level 1 Level 1 (95 points)
    Currently Being Moderated
    May 20, 2012 2:00 PM (in response to Klahane)

    Klahane and Mckenneym   If rebuilding the previews fixes the issue then there is no need to revert to an older Aperture version. imho  cheers

  • stephouaz Calculating status...
    Currently Being Moderated
    May 20, 2012 2:11 PM (in response to dbmoore)

    The greenish problem comes for me with another problem : now raw and jpeg are separated in my new project (before raw and jpeg photo come together and i can swich from one to the other). For information i have a panasonic gf1. Thanks for the information.

  • dbmoore Level 1 Level 1 (95 points)
    Currently Being Moderated
    May 20, 2012 2:24 PM (in response to stephouaz)

    Stephouaz  Did you change the import dialog box? Specifically where you have Raw + Jepg Pairs in the File type.

     

    For the green issue everyone should try the rebuild preview option under photo  and hold the option key to get "generate Preview"  If that fixes it great you are done.  If it generated the priveiw and returns to green then you have other issues.   Keep up dating your sofware to make sure you are using the bes raw converter.

  • Adamalicious Calculating status...
    Currently Being Moderated
    May 20, 2012 3:03 PM (in response to Klahane)

    I'm having the same issue with files from my GX-1. What color space are you using in camera?

  • mckenneym Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 20, 2012 4:19 PM (in response to Klahane)

    True, I was not able to recreate the problem in iPhoto, and for me with an LX5, the problem is resolved with a rebuild of the previews. Thanks

  • Alan Roseman Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 20, 2012 5:34 PM (in response to mckenneym)

    Here is the fix.

     

    I got this from another area, and unfortunately can not attribute the origin here on the support forums.

     

    Open the terminal, paste this text in and hit return.  This repaired the issue in both my MacBook Pro and my Mac Pro.

     

    Thanks to the original poster!

     

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -R /System/Library/CoreServices/CoreTypes.bundle/Contents/Library

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.