Skip navigation

Permission locked files OSX 10.7.4

2733 Views 10 Replies Latest reply: May 19, 2012 5:59 PM by Ashka RSS
Ashka Level 4 Level 4 (3,760 points)
Currently Being Moderated
May 19, 2012 2:22 PM

1. MBP with 10.7.3 dead. recent FireWire TM backup, have never used USB option.

2. New MB Air.10.7.3.

3. Set up with Air with TM attached.. failed, bad USB cable.

4. Used Migration assistant with TM.. New name needed..

5. All looked OK. kept new user, deleted first one.

6. TM Drive wouldn't work with Air, used Disc utility to erase.. now works fine.

7. Updated to 10.7.4.

8. Found locked budget spreadsheets 08, 09, 10 & 11 plus others. One 2008 & all 2012 not locked.

9. Couple of docs also locked.

10. Cannot delete, cannot move, cannot use the normal get info to change user permissions which are set on fetching?.. Can duplicate.

 

I would really like to be able to move and or delete these if possible.. Thanks.

get info.png  locked Icon.png

MacBook Air, Mac OS X (10.7.4), iPod Classic, iPad1 & 2.
  • ds store Level 7 Level 7 (30,305 points)
    Currently Being Moderated
    May 19, 2012 2:27 PM (in response to Ashka)

    See the #5 Reset users permissions here

     

    Step by Step to fix your Mac

     

     

    You could also change the "everyone" to read and write, that would include you.

     

     

    Place all in a folder and apply to enclosed items.

  • Linc Davis Level 10 Level 10 (107,540 points)
    Currently Being Moderated
    May 19, 2012 2:47 PM (in response to Ashka)

    Repairing the permissions of a home folder in Lion is a complicated procedure. I don’t know of a simpler one that always works.

     

    Back up all data now. Before proceeding, you must be sure you can restore your system to its present state

     

    Launch the Terminal application in any of the following ways:

     

    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    Open LaunchPad. Click Utilities, then Terminal in the page that opens.

     

    Drag or copy — do not type — the following line into the Terminal window, then press return:

     

    chmod -R -N ~

     

    The command will take a noticeable amount of time to run. When a new line ending in a dollar sign ($) appears below what you entered, it’s done. You may see a few error messages about an “invalid argument” while the command is running. You can ignore those. If you get an error message with the words “Permission denied,” enter this:

     

    sudo !!

     

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up.

     

    Next, boot from your recovery partition by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

     

    When the recovery desktop appears, select Utilities ▹ Terminal from the menu bar.

    In the Terminal window, enter “resetpassword” (without the quotes) and press return. A Reset Password window opens. You’re not going to reset the password.

     

    Select your boot volume if not already selected.

     

    Select your username from the menu labeled Select the user account if not already selected.

     

    Under Reset Home Directory Permissions and ACLs, click the Reset button.

     

    Select ▹ Restart from the menu bar.

  • Linc Davis Level 10 Level 10 (107,540 points)
    Currently Being Moderated
    May 19, 2012 3:27 PM (in response to Ashka)

    If you can drag or copy, you can carry out that procedure. No typing is involved, except the word "resetpassword" and possibly your login password, and you type that anyway. If you're still not able to do it, get someone to help you.

  • Linc Davis Level 10 Level 10 (107,540 points)
    Currently Being Moderated
    May 19, 2012 4:59 PM (in response to Ashka)

    Close the Terminal window and confirm that you want to quit the running process. Open a new window and press the up-arrow key once to re-enter the command, but don't press return yet. Post a screenshot of the window with the command entered so I can see whether it's correct.

  • Linc Davis Level 10 Level 10 (107,540 points)
    Currently Being Moderated
    May 19, 2012 5:27 PM (in response to Ashka)

    Some of your files are locked. To correct that, enter the command below in the same way as before. Press the down-arrow key first to get rid of the line you already entered.

     

    chflags -R nouchg,nouappnd ~

     

    Then proceed as above.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.