2 Replies Latest reply: Jan 6, 2013 8:19 AM by Sitara
ltt2011 Level 1 Level 1 (0 points)

When I attempt to sign in to order prints, Aperture asks me to enter a new password.  After doing that, it asks me to answer the security question (but it already has the answer prefilled).  When I try to proceed, it tells me to enter the answer correctly. No matter what I enter, it does not let me move forward.  How can I get beyond this point to order prints?


Aperture 3
  • 1. Re: Cannot sign in to order prints
    ltt2011 Level 1 Level 1 (0 points)

    I tried entering a different security question and tried another answer - it let me get to the terms and conditions and then the billing information.  The shipping/billing information was properly prefilled and so I entered the remaining required fills and attempted to continue, but it tells me my billing city, state and zip are not valid.  I have a valid city, state and zip, so I can't understand why it won't let me continue.

  • 2. Re: Cannot sign in to order prints
    Sitara Level 1 Level 1 (0 points)

    Some people with this problem could resolve it by entering a longer answer, more letters to the secret question. But for me it did not work at all.

     

    After accepting my "new" password, and my new ansver to the secret question (with more letters than 4 or 5, less is not possible), I managed to enter the next page. Everything here was ok, except I received the message  after updating my account: "Try again later".

     

    It is not possible to purchase print outs from Aperture. This error has been there since Aperture 3 arrived (se several posts here in the forum)

     

    My solution was to open iPhoto instead and order the print from there.

     

    Apple: How can you live with this one without solving it for so long??????