Skip navigation

Aperture 3 preview of raw file greenish

6270 Views 44 Replies Latest reply: Aug 27, 2012 5:19 PM by apple support user RSS
  • Alan Roseman Calculating status...
    Currently Being Moderated
    May 20, 2012 6:28 PM (in response to Klahane)

    Here is the fix.

     

    I got this from another area, and unfortunately can not attribute the origin here on the support forums.

     

    Open the terminal, paste this text in and hit return.  This repaired the issue in both my MacBook Pro and my Mac Pro.

     

    Thanks to the original poster!

     

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -R /System/Library/CoreServices/CoreTypes.bundle/Contents/Library

  • Damon Saylor Level 1 Level 1 (35 points)
    Currently Being Moderated
    May 20, 2012 6:45 PM (in response to Alan Roseman)

    I'm having the same issue but this did not fix it.  I had to reprocess the masters and then remove all adjustments.

  • Alan Roseman Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 20, 2012 6:50 PM (in response to Damon Saylor)

    Worked for both of my machines...

     

    Make sure when you paste into the terminl there is no white space in the

     

    "/LaunchSe rvices.framework"   see the white space between the e and the r?

     

    Take that space out in a text editor and then paste it into terminal.

     

    It'll do the trick.

  • Damon Saylor Level 1 Level 1 (35 points)
    Currently Being Moderated
    May 20, 2012 6:57 PM (in response to Alan Roseman)

    I've tried again after removing the space - no change.  Weird.

  • stephouaz Calculating status...
    Currently Being Moderated
    May 21, 2012 1:44 AM (in response to dbmoore)

    Hello,

     

    I do not change the import dialog box and my color space on my camera (lumix gf1) is Adobe RGB.

     

    In fact i have 3 problem :

    - green RAW (that i can change when i generate the preview)

    - aperture can't erase anymore photo in my camera (but i can do it manualy)

    - i have now two photo in my project : a raw AND a jpeg instead of one photo that i can switch from RAW to jpeg when i need it (i don't find any solution for this and this is a big problem for me to have this double photo in my new project)

     

    Thanks

  • léonie Level 8 Level 8 (46,710 points)
    Currently Being Moderated
    May 21, 2012 4:52 AM (in response to Alan Roseman)

    Alan,

    this fix may and may not work. Since you are reluctant to explain what the fix is supposed to do, let me elaborate a little on it:

     

    The lsregister command registers the document types with the lauch service database, and the

    "-R" option forces the recursive registration of the contained bundles, if you register a bundle. The "CoreTypes.bundle" contains the following bundles:

     

    MachineTypes.bundle
    iLifeMediaBrowserTypes.bundle
    MobileDevices.bundle

    iLifeSlideshowTypes.bundle

    RawCameraTypes.bundle

     

     

    including the RawCameraTypes.bundle; so the above command will register the known raw file types supported by the OS, e.g. Canon CRW raw image.

    If you want to find out, which formats are actually registered,  run the "lsregister" command with the "-dump" option; this will give you a very long list of registered file types:

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -dump

     

    To check if your own raw format is registered you may want to filter this list using grep, e.g.

     

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -dump | grep "Canon CR2 raw image"

     

    will filter for the output lines containing "Canon CR2 raw image" and show that the Canon CR2 raw image format is registered:

                        description:   Canon CR2 raw image

                        description:   Canon CR2 raw image

     

    In all cases, where you find that your raw file type is not yet registered, Alan Roseman's fix will be very helpful, in the other cases it will make no difference.

     

    Regards

    Léonie

  • Alan Roseman Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 21, 2012 5:06 AM (in response to léonie)

    Hello LeonieDF,

     

    Not reluctant, just unable to provide the perfect explanation you've been so kind as to offer.

     

    It has worked for both of my machines with Aperture and Lion 10.7.4

    I hope it will solve the Panasonic RAW import / Green-Brown Caast issue for others as well.

     

    Thanks for your perfect explanation!

     

    Alan

  • léonie Level 8 Level 8 (46,710 points)
    Currently Being Moderated
    May 21, 2012 7:10 AM (in response to Alan Roseman)

    Hi Alan,

    my post is just stub, I got interrupted by maintainance work while still editing. I think it is clear from what I found out, that this fix may be very helpful forraw  image formats directly built into 10.74 and includes in the CoreTypes.bundle and its  RawCameraTypes.bundle.

     

    For problems with previously supported cameras it might be necessary to check  as well, if their types are properly registered and to register the corresponding raw support package in a similar manner.

     

    Regards

    Léonie

  • Alan Roseman Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 21, 2012 7:22 AM (in response to léonie)

    Hello leonieDF,

     

    I shoot Panasonic / Olympus MU-43 bodies.

     

    All bodies, all lenses

    all computers

    all card readers

     

    were affected in the same negative way after upgrading to 10.4.7.  Heavy green / brown cast on import.

     

    The code placed in the terminal worked fine for all of my issues.

     

    I believe the folks having problems are NOT removing the white space, athen re-entering and restarting.

     

    Thanks for your thoughtfull comments.

     

    Cheers,  Alan

  • dbmoore Level 1 Level 1 (95 points)
    Currently Being Moderated
    May 21, 2012 8:26 AM (in response to léonie)

    Leonie   Thank you.  I was at the end of my very limited knowledge.  Stephouaz may still need help hopfully he will chime back in.   Someday Id like to get your opinon on AP3 color Management.  We could take that off line if you like.  Thanks Cheers

     

    <Edited By Host>

  • léonie Level 8 Level 8 (46,710 points)
    Currently Being Moderated
    May 21, 2012 8:22 AM (in response to dbmoore)

    Hi,

    sure, you are welcome to contact me off line if you like; but I am really no expert on color management. For that you would be far better off if you could get Kirby Krieger's attention!

     

    Cheers

    Léonie

     

    P.S: I tried to contact you directly at your email address to send you mine, but the mail was returned undelivered. So look at my profile to find my email.

    Probably the hosts will edit your post, since it contains an email address.

  • dbmoore Level 1 Level 1 (95 points)
    Currently Being Moderated
    May 21, 2012 8:45 AM (in response to léonie)

    Thanks Leonie

    My fingers failed me but again.    I have posted about a color management (CM) bug in the past but the topic dies pretty fast.  Im not wanting to chatise Apple but want Photographer to be aware and thus put pressure on Apple to speed up a fix or tell us this is the new standard.  I have shared my results with Apple and supposely the powers that be are looking at it,  (AP4?).  I get a since that few people know of this and thats frustrating.

     

    The bug

    Try importing into Aperture a large color Tiff file like Adobe98 and add a solid color fill like (72, 182, 70)  into a selection, (collapse all layers).   The imported image in aperture 3.2.3, the previews and thumbnails of the color green  looks hosed or dead.   Export that image out of AP3 via versions with no adjustments and the image is not the same as the original its still dead. Color Loss via importing and exporting.  This happens in other colors but green is pretty easy to see.   First brought to my attention on ApertureExpert.com forums.

     

    I dont want to start a new thread cuz it will look like Im just a AP hater but I really want to be a fanboy again.

    thanks

     

    <Email Edited by Host>

  • léonie Level 8 Level 8 (46,710 points)
    Currently Being Moderated
    May 21, 2012 8:41 AM (in response to Alan Roseman)

    I believe the folks having problems are NOT removing the white space, athen re-entering and restarting.

    Hello Alan,

    Yes, both parts seem to be necessary; the white space in "/LaunchSe rvices.framework" breaks the filename in two parts and makes the command useless; the rebooting will ensure that the modified lauch service database will be used after a restart.

     

    I had help from Linc Davis with figuring out what the "lsregister" command is doing in this case, he directed me to the relevant documentation and most of all, confirmed that this fix is safe to use. Thanks, Linc!

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,710 points)
    Currently Being Moderated
    May 21, 2012 8:53 AM (in response to dbmoore)

    The bug

    Try importing into Aperture a large color Tiff file like Adobe98 and add a solid color fill like (72, 182, 70)  into a selection, (collapse all layers). 

    Yes, I saw your previous post at that time and tried to reproduce the problem - exacly the same result. Unfortunately I had no solution to offer, so I fall back on sending feedback to Apple.

     

    Cheers

    Léonie

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.