Skip navigation

Apple TV 2 has big problems homesharing - fixes?  firmware update needed!

125500 Views 283 Replies Latest reply: Dec 25, 2013 10:27 AM by jamesn00 RSS Branched to a new discussion.
  • Essexmacboy Calculating status...

    I bought my AT2 a year ago it worked well for 3months then stopped and have been following these threads and others posted all in the vain hope of fixing this problem with my macbookpro. Still no solution! I now have an ipad3 which also cannot connect through homesharing. If it weren't for icloud ATV2 would be worthless to me and I would be getting on plane to San Fransico and throwing "it" at the Apple head quarters front windows. Very, very frustrated and I hope the next update can solve this!

  • victor3234 Calculating status...

    I share your pain. The problem isn't Apple TV it's that arrogant giant Apple that refuses to offer good troubleshooting for the customers. They have millions. Why can't they offer better support without customers having to pay them each time they upgrade your Applel TV and screw up everything. I'm hoping Ruku might be a better company that supports clients without taking all their cash out of their pockets.

  • cidrock Calculating status...

    I wouldn't dare say that I found a solution but so far it's been three days without dropping out. My wifi network comes from an Airport extreme and it's extended by another AE. Everything was updated to its last version. After many tests changing the configuration of my net, trying to find a solution to the problem with HOME SHARING, I eventually gave up and restored my AE,s. I started the set up from the beginning. But, surprisingly, the process was smoother than I recalled, using the new version of Airport utility. Specially, when setting up the secondary AE. Airport utility did everything automatically. And now it seems to work just fine. Best way to find is stop searching...

  • sneirbo2k7 Calculating status...

    It's time for Apple to take AppleTV seriously and enough of the "hobby" comments.  Quite frankly I have way too much money invested in the iTune eco-system for it to be called a "hobby" any longer!


    My recent cause of pain and anger - I purchased Game of Thrones Season 1 over the weekend.  Trying to watch this has been a lesson in futility!  Starts, stops, stuttering, delays, reboots, sign in, sign out, sign in, dropped out, on and on and on.  I should have spent the extra $5 and bought the Blu ray version off of Amazon, which is exactly what I'll do the next time I want to download a movie of TV show from iTunes.


    Fix it, or give up on it.  But enough of this "hobby" horseshi#!!

  • latandatt Calculating status...

    We are having the same issues, not network related. As all other equipment on the network is working fine. So far have found that "could not connect to "XXXX's Library" is fixed by shutting down the itunes Library on the computer it is located on or by rebooting the compter, some times requiring rebooting the appletv too. A fix would be nice.

  • deimosman Calculating status...

    Worked for me too... see my other discussion here:


    There is something wrong with how Apple TV handles network connections when connected via ethernet cable.

  • beegeeuk Calculating status...

    Woohoo!! Loaded new ATV update last night and - fingers crossed - everything working OK all evening!! Hopefully Apple have listened to all the complaints and fixed the problem but only time will tell.

  • Floyd O\\\'Neil Level 1 Level 1 (5 points)

    All, after the latest OS Software update last week and the ATV Firmware update I am pleased to report problem is solved!

    The Lion OS update adddressed several issues one being "Improve Internet Sharing of PPP0E connections"


    Now Apple NEVER acknowledged an issue with Home Sharing and ATV but I suspect very strongly that this is where the issed was. But it is all working now, watched a dozen 45 minute movies and slide shows without a single interruption. And itunes streams fine with home sharing.

  • Charmiepoo Level 1 Level 1 (0 points)

    Where does that leave those of us using Windows based PCs I wonder?

  • beegeeuk Level 1 Level 1 (0 points)

    I'm on Windows 7 and two nights and counting now with no problems after the update!! Still got fingers crossed though!!!

  • mrmuppet Calculating status...

    Well, so far so good for me.


    After having it 'broken' for so long, I'll always have that sinking feeling that something's going to go wrong though!

  • Jeff Heusser Calculating status...

    Still having the same issue even with all the latest updates. In fact worse after updates... more consistently the AppleTV does not see Mac Mini home share. Quitting and relaunching iTunes fixes.  Have tried fixed IP addesses, no difference.

  • ThoricCLA Calculating status...

    Performed the ATV update a couple of days ago, had a chance to test it yesterday, and at first I thought all was fixed, but alas no. We got through one whole movie, then 20 mins of another, then it stopped streaming. We got it to restart the movie, but that only lasted 10 minutes, and then it lost connection altogether.


    This *****. What's gets me most is the complete absence of communication from Apple on these support forums. Not a single post, it leaves me feeling completely abandoned. They've got my money for this expensive brick, and now they don't care. I got it for one purpose only, to stream from my computer, and it can't do it. Complete waste of money!!!

  • ThoricCLA Level 1 Level 1 (0 points)

    As an experiment, can I ask those who have it working to reply with details of their network hardware and setup, and the same of those who can't. Maybe if we all list this info we might find a correlation.


    To start us off, my 'failing' network is:

    TP-Link TD-W8950ND, all wireless access. Win 7 (very recent install), latest iTunes (fresh install on clean Win 7).

  • GS455 Calculating status...

    I downloaded the ATV update and voila - it streams just like it used to stream.  Now I have another problem.  I iPhone can't find the iTunes library on my media server through the Remote app.  This used to be my work around - I would remote app to the iTunes library and then send whatever to the ATV and it would stream flawlessly.  Now I can't find the iTunes library.  While all this was going on with the ATV,  I downloaded iPhone 5.1.  That is probably where I lost it.  It is getting more and more difficult to tell the difference between the boys from Renton and the boys from Cupertino.


    To refresh my configuration from previous posts:

    Giga-bit wired ATV

    iTunes resides on a Windows 7 Home Premium computer giga-bit wired connection

    iPhone interfaces to the wired network through an Airport Extreme

1 ... 10 11 12 13 14 ... 19 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (4)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.