7 Replies Latest reply: May 21, 2012 7:25 PM by Slandes_TechSupport
HT24 Level 1 Level 1 (0 points)

I have just got my new iphone 4 today and when I try to send a message to my friend who also has an iphone she says although sent as an imessage it comes through as an email. When I go to receive at in settings it has my mobile no which is greyed out and it has my email address in bold so she suggested deleting my email from this but the option to delete is greyed out. Has anyone got any ideas what to do?


iPhone 4, iOS 5.1.1
  • 1. Re: imessage going through as an email
    randers4 Level 9 Level 9 (57,285 points)

    Go to Settings>Messages>Receive At>Caller ID, choose your phone number rather than your email address.

  • 2. Re: imessage going through as an email
    ckuan Level 7 Level 7 (21,515 points)

    What the Settings > Messages > Caller ID and make sure your phone number is checked.

  • 3. Re: imessage going through as an email
    dray1986 Level 1 Level 1 (0 points)

    what if there is no recieve at option like you can only pick your email i dont have a caller id options anywhere in any settings i think i got a bad copy of the new softwear def the worst mistake ever was upgrading to 5.1.1

  • 4. Re: imessage going through as an email
    randers4 Level 9 Level 9 (57,285 points)

    This means your phone number is not yet activated with the iMessage server.  You will probably see "waiting for activation" under iMessage.

  • 5. Re: imessage going through as an email
    dray1986 Level 1 Level 1 (0 points)

    so how do i activate my phone number for imessages?

  • 6. Re: imessage going through as an email
    randers4 Level 9 Level 9 (57,285 points)

    If you search the forum you will see many posts on this question (search for "iMessage waiting for activation").  Many things can case issues with activation so there isn't a single fix.  Some things to check/try include:

    1. Turn iMessage off, wait a few minutes, then turn it back on again
    2. Go to Settings>General>Date & Time, make sure Set Automatically is set to On
    3. Makes sure you are able to send and receive messages
    4. Go to appleid.apple.com/ and make sure the Apple ID you are using is active and that the primary email has been verified.

    If these don't help there are other solutions that other users have reported worked for them.  Search the forums and perhaps you will find one that will work for you.

  • 7. Re: imessage going through as an email
    Slandes_TechSupport Level 1 Level 1 (25 points)

    The reason people aminly have problems with using only their phone number with iMessage is because that is not what it is designed for. Just like FaceTime it is usually activated with your Apple ID so it does not have to go through you carriers network. This is why Apple has advertised the features as being "free" because you are supposed to use your already existing wi-fi network to use these features. This is why a  lot of people have problems only using their phone number as their primary recieve at in iMessage.