1 2 3 4 5 Previous Next 124 Replies Latest reply: Jan 26, 2014 2:19 PM by moonmen Go to original post
  • 30. Re: kernel_task running wild!
    makalu57 Level 1 Level 1 (0 points)

    Oops I am seeing the same problem again and clicking on inspect does not fix the problem. I stand by my guess that the problem is caused by the CPU overheating, though. If I restart the MBA after a few minutes it goes away, and it never really appears if I remove the Cinema Display.

  • 31. Re: kernel_task running wild!
    IEBA1 Level 1 Level 1 (5 points)

    Okay, here's a weird one.

     

    My kernel-task has been running for 1:49:12:53, but that's just the part of it- it's been running for several days straight. Despite several reboots, and even starting up off a different external drive... I replaced my HDD with a SSD and did a completely clean install, and then installed some other software that I use regularly. The now external HDD has a lot more installed.

     

    Typically the Kernel task would do it's busines in a day or so and go away. But this has been going on for almost a week now, no matter which drive I boot from.

     

    Inspecting the Kernel task says 80,613 faults. 60 threads, 2 ports. Not much RAM in use , but it's a constant 20-30% of the CPU and the fans in my laptop are going strong.

     

    It has NOTHING to do with an external display, as I normally edit video in FCP and FCP with this setup and have a Dell 1920x1200 display connected to the DVI of my 2006 Macbook Pro and this never causes such a Kernel Task. I've had this display connected to my laptop for years.

     

    I've turned off Dropbox, and Xmarks, and the kernel task continues.

     

    I use the Sonnet Qio with gobs of external storage but I'm certain that this is NOT the cause as I doubt ANYONE else having this problem is also using a Sonnet Qio. (Or even knows what it is.) I even disconnected the Qio from the Expresscard slot andkernel_task came right back within about 20-30 seconds after rebooting.

     

    I'm not backing up. My drives haven't changes so Spotlight isn't busy doing anything.

     

    This is a core issue with the system.

     

    I need kernel task to STOP sucking what little horsepower I have to do today's work down the drain.

     

    We are all grasping at straws and sending in a bug report to Apple has never got me anywhere. Ever.
    HAs anyone taken their computer to the Genius bar and had them prescribe anything besides wipe the drive clean, start from scratsh with a new install?

     

    I mean, I'd like to know what the problem is, not perform genocide every time it comes back, never knowing what the cause is. Because, well, backing up, wiping the drive, starting over, clean, with fresh installs of everything taks a lot of friggin time. And I just DID that with the new drive. And her I am with this damm kernel_task that I can't get rid of.

  • 32. Re: kernel_task running wild!
    makalu57 Level 1 Level 1 (0 points)

    I think I have cracked it. I have a MB Air 13" with OSX 10.7.4 (latest). The Kernel Task used to run wild, slowing down everything. I thought it was the external Cinema Display, and removing that did help for a while, but then the problem came back. Rebooting only deferred the problem for an hour or so.

     

    Then I carried out the lowest tech procedure I could think of: I removed the leather sleeve covering my laptop. The problem went away and never came back! This problem is absolutely temperature related. When you are on external power the CPU works at max clock speeds. If the laptop is not cooled properly then the processor overheats and the Kernel Task runs wild. Removing the sleeve allowed the cooling fans to work better and the problem went away immediately. When I travel I use the sleeve, but not the Cinema Display, and the problem doesn't occur as much. It never occurs when I am on battery alone, operating in power saving mode, sleeve or no sleeve.

     

    I would have thought that it would be relatively easy for Apple to flag a message on screen telling the user that the device is too hot, and automatically enable power save mode to reduce the CPU speed. I wonder why the Kernel Task start running wild instead.

     

    Nevertheless it looks like I have solved the problem on my MB Air for now.

  • 33. Re: kernel_task running wild!
    IEBA1 Level 1 Level 1 (5 points)

    Update for me.

     

    No external monitor connected. No USB. No Expresscard Qio. No ethernet. Boot up and before I can even get to the log in, the fans have kicked in.

     

    I immediately disable dropbox and Xmarks. Other than Safari to write this, and Activity Monitor to see what's going on, the next heaviest activity is pmTool at 0.8% of CPU.

     

    SMC Fan Control reports that my CPU is 140°. I've had it as high as 160 when editing. (or watching a  lot of YouTube) so this 20-30% activity should not push the fans to max. Which it has. For many days now.

     

    I have my laptop elevated so air can pass underneath and above. I have a ceiling fan in the room. It's cool and comfortable here. I have my computer set to turn itself off at night and on in the morning. When I come downstairs, the fans are on, even after a cold shutdown over night.

     

    So it's not a heat issue that causes a kernel-task, which causes CPU load, which causes a heat issue.

     

    It's bad code that cuases kernel_task to not finish what it's doing and let the cpu go down to nothing.

  • 34. Re: kernel_task running wild!
    Eric89GXL Level 1 Level 1 (0 points)

    No external monitor here, no USB, no expresscard, no ethernet. Same here, fans kick in even before I log in. And the computer is /not/ hot, I've had it much hotter previously without kernel_task taking up the CPU. Inspecting kernel_task has no effect. Maybe if enough of us send in bug reports, they'll notice?

  • 35. Re: kernel_task running wild!
    Eric89GXL Level 1 Level 1 (0 points)

    My CPU temperature reads 91F, by the way. I ran the hardware check, and it threw me a "4SNS/1/C00000008: TNOD--124", so it looks like my problem is hardware-related. I let my computer sit, off, for about an hour, and now it's working fine, although probably temporarily so. Since this is probably going to happen again before I have a chance to send my computer in to be fixed, it would be nice if there were a way to stop the high kernel usage when it does happen again.

  • 36. Re: kernel_task running wild!
    Topher Kessler Level 6 Level 6 (9,340 points)

    You can't kill the kernel. It is outside of userland, so nothing has "control" over it, not even root. You can corrupt and crash it, but doing so will only crash your computer and force a restart.

  • 37. Re: kernel_task running wild!
    Eric89GXL Level 1 Level 1 (0 points)

    Yeah, I was more hoping for some userland control over the hardware components or how the kernel interacts with them, i.e. power saving mode or whatever the kernel is activating to try to save itself from the corruptted heat sensor. I'm used to Linux where you can access hardware settings via "cat /sys/whatever"-style commands, and I'm hoping there's some similar control somewhere in OSX to try out to see if it helps (although I doubt it will).

  • 38. Re: kernel_task running wild!
    Topher Kessler Level 6 Level 6 (9,340 points)

    There are many commands for controlling hardware components in OS X. Look up the following:

     

    nvram

    pmset

    sysctl

    kextstat/kextutil

    ioreg/iostat

    dtrace

  • 39. Re: kernel_task running wild!
    Topher Kessler Level 6 Level 6 (9,340 points)

    It looks like the north bridge temperature sensor is not working properly, or is overheating. This is likely why the system is cranking on the fans. You can try forcing the fans to run at a lower rate with SMCFanControl, but do keep in mind that given your sensor issue you might damage the system by doing this.

  • 40. Re: kernel_task running wild!
    Eric89GXL Level 1 Level 1 (0 points)

    Yeah, and modifying the fan profile probably won't solve the kernel_task dominating my CPU, which is what really makes the computer unuseable (I can deal with fan noise). I'll send it in to be fixed, but in the meantime when kernel_task strikes again I'll try adjusting some of those system commands. I don't completely understand why turning my computer off for an hour made it work again temporarily, but I'll take it. Maybe the NB chip is on the fritz, and starting from cool/cold made it work again temporarily? In any case, thanks for being tolerant of and helpful toward an OSX newbie!

  • 41. Re: kernel_task running wild!
    colin N Level 1 Level 1 (0 points)

    Used to have kernel_task at 400+%

     

    Instructions:

     

    1. Return to Apple Authorized Service Center
    2. Describe problem (intermittent problem)
    3. They replaced Logic Board (only once)
    4. It's fine now
    5. Thank goodness for AppleCare extended - replacement was free

     

    Rendering videos in Final Cut Pro X on battery.

     

    not sure if you can do that too (still under warranty)

    good luck!

  • 42. Re: kernel_task running wild!
    IEBA1 Level 1 Level 1 (5 points)

    Okay. I've had my MacBook Pro off for a week. (Personal trip let me shut it down cold for a week.)

     

    I've turned it back on with nothing external attached and after two hours of use, kernel_task is staying put at <2% of CPU. If I do nothing and just watch Activity monitor, kernel_task hovers around 1%. Fans have not turned on.

     

    Will try adding all my external accessories and seeing if kernel_task comes back with a vengence.

  • 43. Re: kernel_task running wild!
    IEBA1 Level 1 Level 1 (5 points)

    Added the external 24" monitor "hot" to the computer.

     

    2.5 more hours have passed.

     

    kernel_task doesn't care.

  • 44. Re: kernel_task running wild!
    nijikon Level 1 Level 1 (0 points)

    Does anyone came to any conclusion / solution on this issue?

     

    I have this kernel_task issue for the last 2 weeks.

     

    Plus dmesg says:

     

    SMC::smcHandleInterruptEvent WARNING status=0x0 (0x40 not set) notif=0x0

    IOSurface: buffer allocation size is zero

1 2 3 4 5 Previous Next