Skip navigation

Safari Help on Download

335 Views 4 Replies Latest reply: May 22, 2012 3:15 PM by DMM_PinkLady RSS
DMM_PinkLady Calculating status...
Currently Being Moderated
May 22, 2012 2:31 PM

I have been trying to download XCode 4.3.2 for Lion for a few days now. I have an excruciatingly slow internet connection so it has taken a while. This is not my problem just giving background. How I have been doing this is changing my computer settings so that it never sleeps and just allowing the file to download. This has mostly worked; I dropped the internet connection a few times, which just meant I had to "resume" the download. I have downloaded 766Mb of a 1,85 GB file so far.

 

However, when I came back to my computer this evening to check progress I saw that the downloading had stopped. I clicked on the file in the Safari download window to try and resume the download but it doesn't allow me to resume. When I double click I get a message that the file type is not recognised. I went to the downloads folder in Finder and found that the file, which previously was of a "Safari Download" type, had now changed to "Disk Image" type. When I try to open this file I can not.

 

I tried something very simple to try and fix this problem. I took a copy of the file and changed the extention to ".download". The file type changed but when I try to download a message in Safari says that this is not a valid download file. Fair enough! I didn't expect this to work. Something interesting happened when I did this however. The original file, which had a ".dmg" extention, changed by adding another ".dmg" so that the file name is now "xcode_432_lion.dmg.dmg".

 

I got the file from the Apple Developer website so I presume it is legitimate. This is obviously very frustrating so if anybody can help it would be very much appreciated. Otherwise I have to start all over again

MacBook Pro, Mac OS X (10.6.8), Safari Download Question
  • Carolyn Samit Level 10 Level 10 (84,160 points)
    Currently Being Moderated
    May 22, 2012 3:01 PM (in response to DMM_PinkLady)

    Hi...

     

    Going by your profile (10.6.8)

     

    Instead of using Safari, you can download Xcode 4.3.2 from the App Store. The file size is 1.43GB

     

    You can access the App Store from your Apple menu:  Apple > App Store

     

    Or from your Dock App Store image for ASC.jpeg or from your Applications folder.

     

     

    I have an excruciatingly slow internet connection so it has taken a while

     

    If possible, you may want to consider upgading your internet connection.

     

     

     

    edited by: cs

  • Carolyn Samit Level 10 Level 10 (84,160 points)
    Currently Being Moderated
    May 22, 2012 3:10 PM (in response to DMM_PinkLady)

    Ok......  it sounds like the connection is "timing out" before it can finish. A slow connection can cause that.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.