Skip navigation

Safari Bookmarks

1157 Views 10 Replies Latest reply: Jun 1, 2012 6:00 AM by CarolT2 RSS
SilverHawke Level 1 Level 1 (0 points)
Currently Being Moderated
May 14, 2012 8:49 AM

I have a problem with Safari bookmarks. Whenever I add a bookmark to bookmarks bar, it shows up but when I add a bookmark to bookmark menu, it doesn't show up in the menu in any of the folders or subfolders. However, when I ckick on the bookmarks collection icon (the second icon from the left, next to reading pane), I can see the bookmark. Does anybody have any idea whats going on?

 

It is pretty annoying to open the bookmarks collection every time I need to open a bookmark and not being able to open bookmarks from the bookmarks menu.

MacBook Pro, Mac OS X (10.7.4), Corei7 Quad Core, 2.2 GHz, 8GB RAM
  • Carolyn Samit Level 10 Level 10 (84,230 points)
    Currently Being Moderated
    May 14, 2012 12:12 PM (in response to SilverHawke)

    Hi ...

     

    Your Safari preferences may be corrupted (.plist)

     

     

     

    Quit Safari.

     

    Go to ~/Library/Preferences/com.apple.Safari.plist

     

    Move the com.apple.Safari.plist file from the Preferences folder to the Desktop.

     

    Relaunch Safari. If that helped, move the .plist file to the Trash. If not, move it back to the Preferences folder.

     

    If that didn't help, go to ~/Library/Caches/com.apple.Safari/Cache.db

     

    For Lion v10.7x:  To find the Home folder in OS X Lion, open the Finder, hold the Option key, and choose Go > Library

     

    Move the Cache.db file to the Trash. Quit then relaunch Safari to test.

  • Carolyn Samit Level 10 Level 10 (84,230 points)
    Currently Being Moderated
    May 24, 2012 10:58 AM (in response to SilverHawke)

    There are two libraries. One is root dnoted by:  /Library

     

    The other is your Home (user)  ~/Library  (Tilde) character represents the home folder.

     

    Try it this way.

     

    Open the Finder.

     

    From the Finder menu bar click Go > Go to Folder

     

    Type this exactly as you see it here:    ~/Library/Preferences/com.apple.Safari.plist

     

    Click Go

     

    I have tried finding the plist with both safari turned on and turned off.

     

    It doesn't matter whether not you are running Safari or not. That .plist file is there regardless.

  • Carolyn Samit Level 10 Level 10 (84,230 points)
    Currently Being Moderated
    May 24, 2012 11:31 AM (in response to SilverHawke)

    Ok..

     

    Lion "hides" the user library by default but you can fix that.

     

    Open the Terminal app located in /Applications/Utilities

     

    Follow the instructions for showing the user library here >  http://osxdaily.com/2011/07/04/show-library-directory-in-mac-os-x-lion/

     

    If you do this now then you'll be have access to all your ~/Library files again, not just Safari.

     

    As an advanced computer user I'm surprised you weren't aware of this.

  • Carolyn Samit Level 10 Level 10 (84,230 points)
    Currently Being Moderated
    May 24, 2012 2:27 PM (in response to SilverHawke)

    Ok now for you?

  • CarolT2 Calculating status...
    Currently Being Moderated
    May 31, 2012 9:12 PM (in response to Carolyn Samit)

    I tried but "access to library" is denied. I am the only user set up except it must set up guest as a default. I restarted to put in my password but it still denies me access. Thank you.

    I have my bookmarks arranged by category, I have no way to expand them. I know that is what you answered.

    I might call Apple, I bought this Mac Book Pro in February and have the support.

    I thought it was something I did, but now I see it is now.

    Carol

  • CarolT2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 1, 2012 6:00 AM (in response to SilverHawke)

    SilverHawke,

    I have my Safari bookmarks arranged by category.  I thought I may have changed a setting by accident, but I did not.  I can't acces all the bookmarks now. I am new to Apple. I bought an iPad last year and loved it, then an iPhone and replaced my 4 year old Dell laptop with a Mac Book Pro.

    • The caret? is not next to each category in bookmarks folder.  I have to scroll to each page in the collection to go to the bookmark I want.  My iPhone and iPad bookmarks are fine.  I have the problem on the Mac.

     

    I looked here yesterday and see you had same problem.

    From what I read here it's from the Lion upgrade. I read what  Carolyn told you to do.  I tried and I did not have an error message, it only said "access denied".

     

    I paid for the extra support from Apple and unless it's a quick fix, I will call them.

    Thank you,

    Carol

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.