4 Replies Latest reply: May 26, 2012 2:46 PM by johnrdelaney
johnrdelaney Level 1 Level 1 (0 points)

Have RX580 connected to ethernet network using printer server.

 

From iMac using 10.6 (snow leopard), I can print fine using gutenprint v5.2.3. Haven't tried later versions.

 

From MacBook Pro using 10.7 (lion) want to do same. What version of gutenprint should I use?

 

Thanks in advance for any help.

  • 1. Re: gutenprint driver for Epson Photo Stylus RX580
    Matt Broughton Level 5 Level 5 (4,905 points)

    The latest version is 5.2.8-pre1.  You can download it from http://gimp-print.sourceforge.net/MacOSX.php.

  • 2. Re: gutenprint driver for Epson Photo Stylus RX580
    johnrdelaney Level 1 Level 1 (0 points)

    Thank you for the prompt response. Sorry if the following sounds churlish. I do appreciate the effort.

     

    That is the latest version of gutenprint and the place to get it. Documentation says it supports Lion. Take note, the rest of you with similar problems.

     

    The documentation also lists the supported Epson printers; the RX580 isn't one of them. Given that, I was reluctant to try it (esp. since it is marked "pre"), have it not work, and maybe have trouble removing it. I thought I would first ask here (and on Epson's web site and on the Gimp print developer's website) to see if anyone had relevant experience. Might get told it works find or might get a warning about some pitfall to be avoided.

     

    Thank you again.

  • 3. Re: gutenprint driver for Epson Photo Stylus RX580
    Matt Broughton Level 5 Level 5 (4,905 points)

    johnrdelaney wrote:

     

    The documentation also lists the supported Epson printers; the RX580 isn't one of them.

    Could you please be more specific as to what documentation to which you are referring.  If some of the Gutenprint documentation needs updating, I can try to get that done. The Gutenprint web page that lists the supported printers does list the Epson RX580.  Also, I can assure you that Gutennprint has not dropped support for any of Epson printers it has previously supported.

     

    Given that, I was reluctant to try it (esp. since it is marked "pre"), have it not work, and maybe have trouble removing it.

    If you do not feel comfortable installing the 5.2.8-pre1 release, you can install the 5.2.7 release that is listed on the same page.  It too is fully compatible with Lion.  Also note that the Gutenprint page has an uninstaller.  The uninstaller is also included in all installeer packages.

  • 4. Re: gutenprint driver for Epson Photo Stylus RX580
    johnrdelaney Level 1 Level 1 (0 points)

    I was refering to the documentation that came with 5.2.8-pre1. Looked at it again; it lists not all supported printers but just those newly supported by 5.2.8-pre1.

     

    Mea culpa. And thank you.