Skip navigation

iMac function keys stopped working (f1-f9)

1811 Views 9 Replies Latest reply: Apr 8, 2014 4:19 AM by IBurchett RSS
athst Calculating status...
Currently Being Moderated
Apr 4, 2012 10:12 AM

For some reason most of the function keys on the top row of my keyboard have stopped working.  It's the function keys from f1 to f9.  The biggest problem is that I can't control the brightness for the computer now, and the display is way too bright.  Oddly enough, the volume controls (f10 - f12) do still work.

 

I have a 27" iMac from 2009, and use the basic wireless aluminum Apple keyboard that came with it.  Snow Leopard (10.6.8).

 

Before I ran into a similar problem where it wouldn't let me control the brightness when the iMac was in target display mode with my MacBook Air - but after restarting the iMac, it would work again.  But this time, restarting the computer did not help.

 

Things that I've tried based on tips that I've seen in other threads:

  • restarting the computer
  • resetting PRAM
  • restarting the keyboard
  • removing and re-pairing the keyboard
  • re-mapping the function controls (brightness, etc) to different keys
  • installed all software updates

 

None of these things have helped, I still can't control the brightness and it's burning my eyes.

 

For what it's worth, I can't even get the functions to activate when I use the on-screen keyboard, which makes me think that this is a software problem rather than a problem with a keyboard.  But I'm not sure if you're supposed to be able to use the functions from the on-screen keyboard in the first place, so I wasn't sure if this mattered.

 

Any ideas on what could be causing the problem or how to fix it?

iMac, Mac OS X (10.6.8)
  • Don Archibald Level 10 Level 10 (101,125 points)
    Currently Being Moderated
    Apr 4, 2012 12:09 PM (in response to athst)

    Do they work if you hold down the Fn key while pressing the F1, etc. keys?

     

    If they do, go to System Preferences > Keyboard > Keyboard and uncheck the item "Use all F1, F2, etc. keys as standard function keys".

  • IkeMcfadden Calculating status...
    Currently Being Moderated
    Apr 17, 2012 10:07 PM (in response to athst)

    I'm havin the exact same problem.  Seemed to start (shockingly!) with the last OSX update that included the Flashback Java fix in mid-March.

     

    Unfortunately, I don't think you'll find getting a new keyboard helps. I have 3 different Apple Aluminum Wireless Keyboards.  I have connected all of them, sequentially, to my iMac 27". 

     

    All have the exact problem.  And none of them have similar problems when I connect them to my MacBook Pro.

     

    And on all of them...the function keys magically swapped to various random roles.  The volume key now displays the dashboard widgets, for example.

     

    So, no...it's not just you.  If you look at the forums, you will see lots of people with this problem. 

     

    And of course, Apple manages to remain silent. 

     

    Whee!

  • iMac2009 c Calculating status...
    Currently Being Moderated
    May 17, 2012 3:33 AM (in response to athst)

    I have had the same problem for some time so if you have been able to find a solution I would love to hear it.

  • kiminfl Level 1 Level 1 (45 points)
    Currently Being Moderated
    May 26, 2012 8:16 AM (in response to iMac2009 c)

    Same exact problem here... my volume keys haven't worked for several months -- and now none of the top row keys work (some used to).. I can't quite narrow it down to a certain update, but that makes sense to me..

     

    I'm getting ready to call Apple Care -- I can't deal with it anymore.. but after reading these posts, I'm guessing they won't have an answer for me??

  • raver1002 Calculating status...
    Currently Being Moderated
    Jul 11, 2012 2:24 AM (in response to athst)

    i had the same problem. i had another media program working in the backround (spotify). once i closed that program the buttons worked. try closing your other media programs one by one and try the buttons again. Hope this helps ^_^

  • digitalbetts Calculating status...
    Currently Being Moderated
    Jan 2, 2014 2:31 PM (in response to athst)

    I was havinga  similar problem where the F keys were doing crazy things. F12 was moving all the windows off the screen and displaying the desktop, F11 was showing the widgets panel.

     

    I found the problem by going to system preferences/ keyboard/ and unchecking

    "Use all F1,F2, etc. keys as standard function keys".

     

    Probably a simple solution unrelated to others problems but is what brought me to this page and thought it may help others.

  • IBurchett Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 8, 2014 4:19 AM (in response to athst)

    This is exact probem I have - occured out of nowhere!

     

    F1-9 and Right-Shift not working at all.

     

    Does anyone have an explanation/solution (two years on!)

     

    iMac 27" mid-2011

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.