Skip navigation

Can't download podcasts

559 Views 1 Reply Latest reply: May 28, 2012 8:01 AM by Clairefromaz RSS
Clairefromaz Calculating status...
Currently Being Moderated
May 27, 2012 8:30 PM

Something is blocking my computer from downloading podcasts. I have NetBarrier and Little Snitch installed but disabling both of them didn't help. When I try to download a podcast in iTunes, I get an exclamation point next to the podcast and nothing downloads. I tried this with several podcasts and none will download. I can download the podcasts onto my iPad so the problem is with something on my MacBook that is blocking iTunes podcasts. The App Store is working fine in iTunes and I could download apps to the MacBook. The problem seems to be only with the podcasts. I'm using the latest versions of Lion and iTunes. I checked the link to my iTunes library (on a separate partition) and that is working fine. Thanks in advance for any help.

iTunes, Mac OS X (10.7.4)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.