Skip navigation

Lion Sleep issues

590 Views 8 Replies Latest reply: May 29, 2012 5:57 PM by mbp20111 RSS
mbp20111 Level 1 Level 1 (0 points)
Currently Being Moderated
May 27, 2012 4:25 AM

My macbook pro (early 2011) won't go to sleep when I close the lid ever since I upgraded to Lion (10.7.4) from Snow Leopard (10.6.8).

 

The computer will still sleep when I click on "sleep" from the Apple menu. The computer just won't automatically sleep when I close the lid.

 

I tried a number of things:

 

1. enabling/disabling internet sharing (don't have it enabled in the first place)

 

2. uninstalling Little Snitch

 

3. Delete printer queues. Also tired deleting all printers & reseting printing system.

 

4. SMC reset

 

5. Delete: Macintosh HD > Library > Preferences > SystemConfiguration.

 

 

Nothing works!!!!

Any ideas?

Macbook Pro (2011), Mac OS X (10.7.4)
  • softwater Level 5 Level 5 (5,370 points)
    Currently Being Moderated
    May 27, 2012 5:04 AM (in response to mbp20111)

    Try a PRAM reset, too. Can't hurt. Apple's help page says:

     

    A small amount of your computer’s memory, called “parameter random-access memory” or PRAM, stores certain settings in a location that Mac OS X can access quickly. The particular settings that are stored depend on your type of Mac and the types of devices connected to it. The settings include your designated startup disk, display resolution, speaker volume, and other information.

    Note: To print these instructions, open the Help Viewer’s Action pop-up menu (looks like a gear) and choose Print.

    1. Shut down the computer.
    2. Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Immediately press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.Continue holding the keys down until the computer restarts, and you hear the startup sound for the second time.
    5. Release the keys.

    Resetting PRAM may change some system settings and preferences. Use System Preferences to restore your settings.

  • Linc Davis Level 10 Level 10 (107,400 points)
    Currently Being Moderated
    May 27, 2012 5:07 AM (in response to mbp20111)

    Test after each of the following steps that you haven’t already tried:

     

    Step 1

     

    ▹ System Preferences ▹ Energy Saver ▹ Power Adapter ▹ Wake for network access: uncheck. You may need to unlock the preference pane by clicking the lock icon in the lower left corner and entering your administrator password.

     

    Step 2

     

    ▹ System Preferences ▹ Energy Saver ▹ Schedule… ▹ Start up or wake: uncheck

     

    Step 3

     

    ▹ System Preferences ▹ Print & Scan ▹ Open Print Queue...

    Check all printers for unfinished jobs. Deal with any you find.

     

    Step 4

     

    Disconnect all wired peripherals except keyboard, mouse or trackball, and monitor, if applicable.

     

    Step 5

     

    Launch the Activity Monitor application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Activity Monitor in the page that opens.

     

    Select All Processes from the menu in the toolbar, if not already selected. Enter “powerd” (without the quotes) in the "Filter" text field. Select the powerd process and click the Quit Process button in the toobar (stop-sign icon.) In the sheet that opens, click Force Quit. You’ll be prompted for your administrator password. The process will be relaunched immediately.

     

    Step 6

     

    Boot in safe mode and log in. The instructions provided by Apple are as follows:

     

    1. Be sure your Mac is shut down.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Note: If FileVault is enabled under Mac OS X 10.7 or later, you can’t boot in safe mode.

     

    Safe mode is much slower to boot and run than normal. Don’t launch any applications at first. If sleep still doesn’t work properly, back up all data and reinstall the Mac OS. After that, if you still have the issue, make a “Genius” appointment at an Apple Store to have the machine tested.

     

    If sleep now works as expected, go on to the next step.

     

    Step 7

     

    Still in safe mode, launch the usual set of applications that are running when you have the problem, including your login items, one at a time, testing after each one. Some applications may not work; skip them. You might be able to identify the cause of the problem this way.

     

    Step 8

     

    If sleep is still working after you’ve launched all the usual applications, reboot as usual (not in safe mode) and test again. If sleep still works, you’re done, at least for the moment.

     

    If you still have the sleep issue after booting out of safe mode, post again.

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    May 29, 2012 3:08 AM (in response to mbp20111)

    Launch Terminal (in Utilities), and copy/paste the following command line.

     

    pmset -g

     

    Hit return and post the result.

  • Linc Davis Level 10 Level 10 (107,400 points)
    Currently Being Moderated
    May 29, 2012 6:03 AM (in response to mbp20111)

    Please boot into Recovery (command-R at startup) and test. If the machine still doesn't sleep when the lid is closed, you have a faulty lid sensor or some other hardware fault.

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    May 29, 2012 12:48 PM (in response to mbp20111)

    I agree it may be hardware since there is nothing wroing with the sleep setting in the pmset, i.e., no process is preventing sleep.  It's set for 10 minues.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.