Skip navigation

Couldn't display "image~1.jpg" because it is corrupted.

1619 Views 6 Replies Latest reply: Nov 13, 2012 2:26 PM by Tom_in_Tampa RSS
MLGKillAHz Level 1 Level 1 (0 points)
Currently Being Moderated
May 19, 2012 7:31 AM

I've had this issue ever since I opened an image that I wanted to view with Picture Viewer (Quicktime), it then told me something about associating files blah blah and it was a yes or no answer, I forgot what it said exactly but I know I used to always say no to it to continue to view the image I opened before then today I accindently clicked yes and now it gives me that error message! When I open my image with Paint and any other program, it works, but with Picture Viewer it doesn't! I liked having my picture viewer as my default. Please help D:

Windows Vista
  • Kenny904 Level 1 Level 1 (0 points)

    Having the same problem after updating QT.

  • Kenny904 Level 1 Level 1 (0 points)

    Did you find a solution for this. I tried re-installing an older version if QT and that didn't work. Hard to believe more people are not having this issue. Nothing on google either.

  • Kenny904 Level 1 Level 1 (0 points)

    Sort of a partial solution. Uninstalled QT 7.7.2, re-installed QT 7.7.1 (couldn't find this on Apple's support site....they force you to dl the binary which installs the latest version) and everything worked as before. But when opening an image file, the file association box came up. Selected "no" and checked off "don't ask me again", but it re-appeared the next time I opened another image file. So I gave in and selected "yes" and everything worked as before. So i'm sticking with 7.7.1 until the next update. I may try 7.7.2 again when I have some time. Hope this helps. Good luck.

  • bartgrefte Level 1 Level 1 (0 points)

    Ran into this problem as well, so far it only seems to happen with pictures that are saved from Facebook. If I open them with MS Paint and save them, they can be opened by Quicktime Picture Viewer.

     

    @Kenny904: The file association question is something I ran into as well. It didn't disappear till I hit yes instead of no. Even though I checked the "don't ask me again".

     

    Now I'm gonna look for v7.7.1, see if that solves it here as well.

     

    edit: Going back to 7.7.1 solved it, thanks for the tip Kenny

  • Tom_in_Tampa Level 1 Level 1 (0 points)

    I had experienced this same issue (Pictureviewer saying image file is corrupted). Like others in this thread, I uninstalled Quicktime 7.7.2 and installed 7.7.1 and the problem went away.

     

    Today, I got a prompt that Quicktime 7.7.3 was available and I installed it. After the installation completed and I restarted my system (Windows 7), I do not get the image corrupted messages. So it appears that 7.7.3 has fixed the problem. YMMV, but if you still have the 7.7.1 install files, you could always go back if 7.7.3 doesn't work for you.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.