Skip navigation

How do I repair java?

5273 Views 26 Replies Latest reply: Nov 28, 2012 3:18 AM by tobystarr RSS
1 2 Previous Next
WindSong Calculating status...
Currently Being Moderated
Mar 27, 2012 3:00 PM

Java appears to be broken on my machine as a particular web app works on other machines but not on mine.  How do I delete and re-install java?

MacBook, Mac OS X (10.6.8)
  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    Mar 27, 2012 4:45 PM (in response to WindSong)

    How do you know it is "broken" and needs reinistallation?  How do you know it is even Java that is the problem with the web pages?   If the code is there odds are very high it isn't "broke".  Code doesn't "break" and if it is then odds are pretty high some other code in your system is borken as well.   But it could be some  data is corrupted some how and reinstallation of the code won't change that.  Anyway, assuming it is a Java problem try the following.


    In your Utilities folder you have an application called Java Preferences.  Launch it and click its Restore Defaults button.  Also probably have all the checkboxes checked (General tab).  See if that fixes your problem.

  • alexisjarome Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 12, 2012 7:46 AM (in response to X423424X)

    Hi There,


    I also have a problem with the Java installed on my machine.


    For this reason, I can't even open my Java Preferences. Please see attached console message.



    Console Messages.jpg

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    Apr 12, 2012 11:53 AM (in response to alexisjarome)

    Not sure this will affect anything but try deleting (renaming, moving, whatever) the following file in your account:




    where the X's are a sequence of hyphanated letters and numbers.


    Also might try another account.  And also see if booting in safe mode has any effect.

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    May 29, 2012 6:58 PM (in response to WindSong)

    However, java worked when I logged in with another account.  What does this mean?  What clues does this offer about fixing the problem in my primary account?


    Post the list of files you see in the following:


    your login items


  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    May 29, 2012 10:13 PM (in response to WindSong)

    login items (from yiour Accounts system preferences)?

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    May 31, 2012 11:47 AM (in response to WindSong)

    Open your System Preferences, Accounts, click Login Items tab, and there will be a list of applications that are launched when you log in (similar to LaunchAgents).


    Also, there's nothing suspicious in your LaunchAgents although as a personal rule I always trash  But that's just me. Leave the stuff in there alone.

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    Jun 3, 2012 4:28 PM (in response to WindSong)

    Since you don't have a problem in other account and you do in yours my intial guess was that it might be due to something running specifically in your account that isn't running in the others.  Such things can come from your LaunchAgents and Login Items. 


    There's nothing suspecious that I would think would cause your problem in your LaunchAgents.  That left the Login Items.  You have two I don't recognize. 


    The vzwwirelessd, after a little googling, appears to come from  VZAccess Manager which I guess you use for Verizon.


    The other is Missing Sync Monitor.  I am not sure of that one since there's a whole bunch of different Missing Sync apps and I don't know which one you have.


    It is really hard to believe either of these login items could be the reason for your java problem.  You could try removing the Missing Sysc Monitor as an expirement (select the item in Login Items and click the minus).  It will probably come back when you use Missing Sync the next time. 


    Log out and back in to make sure that process is no longer running.  See f the java problem remains -- I'm guessing it will.


    So if not the login items, and not the LaunchAgents then something is wrong with some account-specific setting (e.g., a preference plist), or a cache, or some other piece of data and not a running process.  That's harder to flush out since there's a lot of this kind of stuff.

  • X423424X Level 6 Level 6 (14,190 points)
    Currently Being Moderated
    Jun 4, 2012 5:34 PM (in response to WindSong)

    I think it would just "keep the botched settings".  That's essentially what I said in my first post.

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.