Skip navigation

I cannot get Web Sharing to turn on.

3573 Views 37 Replies Latest reply: Oct 15, 2012 12:01 PM by etresoft RSS
1 2 3 Previous Next
EChrisDenney Level 1 Level 1 (0 points)
Currently Being Moderated
May 31, 2012 10:12 AM

Ever time I click the check box to turn on Web Sharing, the gray light blinks quick to orange, then turns back to gray. I try it over and over and still it will not turn on. I've read many other support discussions related to this and I have tried many of the "solutions", including:


  1. Changing the name of my computer, multiple times
  2. Replacing the existing httpd.conf file with the "original" httpd.conf file
  3. Commenting out LoadModule fastcgi_module     libexec/apache2/ from the httpd.conf file
  4. Starting apache in the terminal by typing sudo /usr/sbin/apachectl start
  5. Removing the lines <key>Disabled</key> <true/> from the /System/Library/LaunchDaemons/org.apache.httpd.plist
  6. Removing old users from the /etc/apache2/users/ directory


Nothing has worked so far. I've redownloaded Lion hoping to be able to use the files contained within the installer package to restore all of the relevent files that might have become corrupted somehow. I haven't done this though because I don't know how.


When I try to start Web Sharing while Console is running I get the following message


5/31/12 12:57:43.618 PM org.apache.httpd: httpd: Could not reliably determine the server's fully qualified domain name, using ChrisMacBook.local for ServerName

5/31/12 12:57:44.549 PM System Preferences: -[__NSCFDictionary setObject:forKey:]: attempt to insert nil value (key: NSLink)

5/31/12 12:57:44.551 PM System Preferences: (

          0   CoreFoundation                      0x00007fff9205bf56 __exceptionPreprocess + 198

          1   libobjc.A.dylib                     0x00007fff88f04d5e objc_exception_throw + 43

          2   CoreFoundation                      0x00007fff9205bd8a +[NSException raise:format:arguments:] + 106

          3   CoreFoundation                      0x00007fff9205bd14 +[NSException raise:format:] + 116

          4   CoreFoundation                      0x00007fff92018c4b -[__NSCFDictionary setObject:forKey:] + 219

          5   SharingPref                         0x000000010bc5e48f SharingPref + 115855

          6   SharingPref                         0x000000010bc5e3a0 SharingPref + 115616

          7   SharingPref                         0x000000010bc5e315 SharingPref + 115477

          8   SharingPref                         0x000000010bc4d970 SharingPref + 47472

          9   SharingPref                         0x000000010bc47d60 SharingPref + 23904

          10  Foundation                          0x00007fff90dc4f40 __NSFireTimer + 102

          11  CoreFoundation                      0x00007fff92010934 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20

          12  CoreFoundation                      0x00007fff92010486 __CFRunLoopDoTimer + 534

          13  CoreFoundation                      0x00007fff91ff0e11 __CFRunLoopRun + 1617

          14  CoreFoundation                      0x00007fff91ff0486 CFRunLoopRunSpecific + 230

          15  HIToolbox                           0x00007fff8acd44d3 RunCurrentEventLoopInMode + 277

          16  HIToolbox                           0x00007fff8acdb781 ReceiveNextEventCommon + 355

          17  HIToolbox                           0x00007fff8acdb60e BlockUntilNextEventMatchingListInMode + 62

          18  AppKit                              0x00007fff9108fe31 _DPSNextEvent + 659

          19  AppKit                              0x00007fff9108f735 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

          20  AppKit                              0x00007fff9108c071 -[NSApplication run] + 470

          21  AppKit                              0x00007fff91308244 NSApplicationMain + 867

          22  System Preferences                  0x000000010719fb30 System Preferences + 6960

          23  ???                                 0x0000000000000002 0x0 + 2



This is really driving me crazy. If anybody can help, please let me know.

MacBook, Mac OS X (10.7.4), 2.0Ghz - 4GB RAM
  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    May 31, 2012 11:39 AM (in response to EChrisDenney)

    Please post the recent messages in /var/log/apache2/error.log.

  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    May 31, 2012 12:31 PM (in response to EChrisDenney)

    Launch the Activity Monitor application and select All Processes from the toolbar menu. Enter "httpd" (without the quotes) in the Filter text box. You should have two httpd processes, one owned by root and one by _www. Is that what you have? And is the server working?

  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    May 31, 2012 12:56 PM (in response to EChrisDenney)

    Are any error messages logged when the server fails to start?

  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    May 31, 2012 12:59 PM (in response to EChrisDenney)

    The same one you checked before.

  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    May 31, 2012 1:33 PM (in response to EChrisDenney)

    Have you edited the Apache configuration file at




    If so, compare it with



    or just replace the former with a copy of the latter. Then restart Apache.
  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    May 31, 2012 2:10 PM (in response to EChrisDenney)

    Launch the Terminal application and enter the following command:


    /usr/sbin/httpd -t


    The output should be


    Syntax OK

    If you get any other output, post it.
  • etresoft Level 7 Level 7 (23,895 points)
    Currently Being Moderated
    Jun 1, 2012 5:06 AM (in response to EChrisDenney)

    Sorry I missed your question. It would be best to undo any changes you have made to the plist and configure files. This is a known problem with Lion. If you just keep trying, eventually it will work, as you have discovered.

  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    Jun 1, 2012 6:16 AM (in response to Linc Davis)

    It's not clear to me that you have an actual problem. Yes, sometimes you get an abnormal display in System Preferences when you activate Web Sharing. But every time you check whether the web server is working, it is. Maybe the solution is to activate it and leave it alone.


    You can suppress the warning message about the domain name by giving the server a fixed IP address on the network and adding a line to the hosts file, or running an internal DNS server (which is a lot more work to set up.) Maybe that will also make Apache start up more smoothly.

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.