Skip navigation

Lion Won't Wake For Incoming Network Access

4418 Views 31 Replies Latest reply: Nov 30, 2012 7:38 PM by TiredNGrouchy RSS
1 2 3 Previous Next
garygladstone Level 1 Level 1 (5 points)
Currently Being Moderated
Jun 2, 2012 8:44 AM

Hello, All:

 

After Lion upgrade I cannot get my  remote access program (Timbuktu) to show my desktop to remote users. The sleeping screen (not the hard drive) is set for "Wake for network access" and all other settings are checked and appropriate including an update to the newest Timbuktu 8.8.3.

 

The screen wakes from keyboard or trackball activity but not for incoming access.

 

Note: The remote user sees the frame for the desktop in Timbuktu but is shows a sleeping (dark) screen. The file and clipboard exchanges still work but the screen ignores the instruction to wake.

 

Access worked perfectly with Timbuktu until three weeks ago. Then it just sleeps like a teenager on Saturday morning unless tapped on the shoulder by a parent. Call-ins don't get answered.  ;-)

 

Any ideas would be dearly appreciated.

 

 

Thanks

iMac, Mac OS X (10.7.4)
  • Linc Davis Level 10 Level 10 (107,725 points)
  • Linc Davis Level 10 Level 10 (107,725 points)
    Currently Being Moderated
    Jun 2, 2012 11:53 AM (in response to garygladstone)

    It won't change anything. You don't even have to install it. Just drag it to the Trash if you don't want it.

  • John iSight Calculating status...
    Currently Being Moderated
    Jun 9, 2012 3:01 AM (in response to Linc Davis)

    Sorry Guys but WakeOnLan DOES NOT do the job with 10.7.4

     

    at least, it does not wake the Screen, which is the issue we all have with 10.7.4 and Timbuktu 8.8.3.

    I tried may different setup over our Lan with 5 mac all running 10.7.4 and WakeOnLan.

     

    I had to set Screen to never sleep and Computer to never Sleep, then set Screen Saver Black screen with time after 5 minutes

    this works fine, until Timbuktu is fixed or Apple address the issue in a next OS update.

  • ZeddybearCA Calculating status...
    Currently Being Moderated
    Jun 12, 2012 4:50 AM (in response to garygladstone)

    Too bad Apple didn't discuss with other software manufacturers before they made the screen wake change in 10.7.4. I use Timbuktu and have been burned by this. Anyone notice that Apple updated their Apple Remote Desktop software at the same time? I agree that the solution is to have the screen never to go to sleep and just use a screen saver. However, I have computers that sit idle for days and I hate the thought of all those screens being on. There *is* a way to remotely wake up a screen with 10.7.4, but you need to meet the following requirements:

     

    1. You must know the public IP Address (or DNS name) of the target computer. (DynDNS has a free service available for up to 2 hosts on dynamic IP Addresses)

    2. If you are using a NAT router, there must be a rule to allow TCP/IP on an external port number of your choice to port 22 of the target computer.

    3. Remote Login must be turned on in the Sharing pane of the System Preferences of the target computer and accessible by your user account. It must be an Admin account.

     

    If you can fulfill the above, then you can SSH with the Terminal into the target computer:

    SSH -p [external port number] username@hostname_or_IP_Address

     

    This command will wake the screen:

    sudo pmset -a displaysleep 0

     

    When you are finished working on the computer, you can open the Energy Saver pane of the System Preferences and change the sleep setting from the now Never back to the preferred interval. Or issue the command with the Terminal:

    sudo pmset -a displaysleep [time in minutes]

     

    Hope this helps someone.

  • John iSight Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 12, 2012 5:46 AM (in response to ZeddybearCA)

    Thank you for the above work Around. FYI

     

    - Timbuktu Develloper, told me they expect Apple to fix it, if they don't , TB team will have to do it themselves.

    So there is a solution on the way, ...... few months !

  • ZeddybearCA Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 13, 2012 4:26 AM (in response to garygladstone)

    Gary,

     

    I see your point exactly. I agree the issue has nothing to do with hostnames or port forwarding. I can appreciate your reluctance to change settings after every session. I posted the above as a rather clunky work around I found for using Timbuktu connecting to a Mac with 10.7.4 when the display was asleep.

     

    My beef is with Apple. They made a change to the wake up routine of the display and didn't give developers notice or time to revise their products, not to mention the legitimate users of those products. When 10.7.4 was released, there was also an update to Apple Remote Desktop Client 3.5.3. No doubt one of the changes was to revise the way the display was wakened on a remote Mac. ARD has no problem with a sleeping display. It is wakened as soon as contact is made.

     

    I actually like the fact that after putting the display to sleep via a Hotspot in 10.7.4, after 5 seconds a mouse movement will not wake the display. I keep my keyboard and mouse on a sliding drawer and sometimes sliding the drawer in after putting the display to sleep, there would be a small movement of the mouse; waking the screen. That annoyance hardly ever happens now.

     

    I doubt very much Apple will revert the system change and developers will need to fall in line with revisions of their products. Unfortunately, in my experience that's the way Apple does business.

     

    –ZB

  • ZeddybearCA Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 13, 2012 5:58 AM (in response to garygladstone)

    I think we're straying from the original topic of this post, but here goes.

     

    From Wikipedia:

     

    "For LCDs, burn-in develops in some cases because pixels permanently lose their ability to return to their relaxed state after a continued static usage profile. In more typical usage profiles this image persistence in LCD is only transient."

     

    I prefer to have a display "sleep." This will put an energy-compliant display in a very low state of power consumption. If a display is using a black screen saver, it will continue to use the normal amount of power and produce heat. In these eco-conscious times, I'm very aware of the power consumed and the heat produced from a display. It's bad enough that a Mac cannot be put to sleep for remote access.

     

    Regards,

     

    ZB

     

    p.s. Please, no discussions about the accuracy of Wikipedia articles.

  • LEOinDC Calculating status...
    Currently Being Moderated
    Jun 22, 2012 7:56 AM (in response to garygladstone)

    On an LCD-based display, the backlight never turns off with a screen saver. Backlighting is turned off with screen sleep.

     

    There is a product called BlackenedPixels from b-l-a-c-k-o-p.com.

    From their website: "BlackenedPixels is a variation of the "basic black" screensaver concept. Not only does it turn your screen black, but it also powers down all the displays to keep the room cool and dark."

    MacUpdate reports the product this way: "BlackenedPixels is an improved version of the "black screen" ScreenSaver.  In addition to making your displays black, BlackenedPixels also trims the brightness control all the way down, allowing applications to run normally, but without the power consumption (and heat etc) normally associated with screensaver operation."

     

    However, it doesn't work under Lion.

     

    An alternative workaround for the Timbuktu/Lion wake screen glitch is to set screen sleep to never, set Screen Saver to never, and set screen brightness to zero. This way the backlight is turned off as well.

     

  • LEOinDC Level 1 Level 1 (55 points)
    Currently Being Moderated
    Jun 22, 2012 8:27 AM (in response to LEOinDC)

    Additionally, bumping the mouse, trackball or keyboard won't wake the screen and outwardly the computer appears to be powered off.

     

    A quick press on the keyboard brightness key and you're back in business.

  • vascularnerd Calculating status...
    Currently Being Moderated
    Jun 22, 2012 10:09 PM (in response to garygladstone)

    Hi Gary, Driven mad by no wake on Timbuktu Pro.  Solution was log in with Logmein which wakes computer then log out and sign in with Timbuktu Pro before computer sleeps again.  Usually use Timbuktu as much faster than Logmein.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.