Previous 1 3 4 5 6 7 Next 230 Replies Latest reply: Dec 8, 2014 10:08 AM by bradmcconnell Go to original post Branched to a new discussion.
  • Charmiepoo Level 1 (5 points)

    Yes, as I and others have already said, if it were a networking issue, then the Apple TV would have problems connecting to the network for everything......but it has no trouble with Netflix, or YouTube, Photo Stream, iTunes Match or any of the other things on the ATV.

  • Tweety_germany Level 1 (0 points)

    Hello All,


    Well since the last Apple updates (Mac-OS, iPad (5.1.1), ATV (5.0.1 [4224])) - and I think the plural is important here - it worked fine for me.. during the last two weeks my family looked dozends of hours of Videos and TV shows without any problem.


    So the last updates solved it all for me...


    BUT: I keep the "old" tries to fix the problem also, so I still

    - have fix IP adresses for the ATV

    - have switched off dolby surround

    don't know if this is nesseccary but just don't want to put any risk in here ;-))


    And as everybody can see on the eviroment list (see below), we have a very complex landscape, most wireless. I'm very sure, that this issue was not a network issue or something else outside the Apple products. The above mentioned updates came out all together. I think they found something and had to fix it it in all devices. Probably not a big thing, but it they had  to fix it ... and luckily they did ;-)


    Our family enviroment contains the following Apple products:

    - iTunes on a Win7 32 bit Noname PC (all content)

    - second iTunes on a iMac with OS 10.6.8 (all content)

    - third iTunes on a MacBook Pro with OS 10.6.8 (daughter, only selected content)

    - fourth iTunes on a Win7 32 Samsung Notebook (son, only selected content)

    - all iTunes sharing the same Home Sharing ID

    - 2 Apple TV second generation

    - 1 Apple TV first generation

    - 2 iPod touch (bought last year)

    - 2 iPads (second generation)


    The ATV, ipods, iPads and the Notebooks are connected wireless

    - 1 Airport extrem

    - 2 Airport Express (in WiFi repeater mode)

    except the old ATV first generation. This device is connected with a pair of Powerline adapters


    the IMac, the win7 machine and the printer are connected by a gigabit Ethernet switch - this also connects the Airport Extreme.


    OK that all for me... good luck to everybody....

  • zinto Level 1 (0 points)

    I just did an experiment and think this makes sense now.  About a week ago my ATV has having issues with home sharing where it would work ok and stop after a few minutes.   I made some adjustments to my router settings, including using a fixed channel, and since then it works like a charm.   However, I just ran a test where I was watching a program and the progress bar indicated full download, then I power cycled the router.  Within seconds, ATV kicked me out of the program and returned to the home screen.  So, it's not good enough to have a working network with sufficient speed to stream your program, or even to download the whole program up front by pausing a few minutes.  No, the ATV must be in CONSTANT contact with Itunes, even a momentary disconnect will trip it up.  There a lots of reasons this connection could be interrupted temporarily.  In my humble opinion this is either just an error in the ATV software, or incredibly poor design which is not accounting for real world network issues which include short term disruptions.   My guess is this is an overly zealous security feature which assumes that if your ATV cannot verify from Itunes you are an authorized user, it will stop immediately, even if you have content downloaded to the ATV memory (if you are not authorized, how would this content have downloaded in the first place???).  Simply revising the software to allow that connection to be broken for a short time (assuming a successful startup) would fix this.   Just a guess.

  • Charmiepoo Level 1 (5 points)

    Hi zinto.

    That would then beg the question....why did they consciously leave that capability out of the last big software update? I had no problems at all with either of my ATVs prior to that update, after using them for about 8 months. One also wonders who on earth is working on Apple software development these days??

  • ragelert Level 1 (0 points)

    I have the exact same issue - all was fine until about 2 or 3 months ago. However, I have determined that is not the ATV. My itunes program & library are installed on an external hardrive. When I use ATV on one laptop, all is fine. But if I connect to the other laptop, I have the same problem all of you are having. I've called apple tech support several times and they still can not figure out why this is - same itunes program & version, same itunes settings, same ATV, same WiFi, same library and same external harddrive so all of those can be ruled out as being the problem.

  • stephenfrompowell Level 1 (0 points)

    Has the update worked for anyone? I have 3 Apple TV's and never had a problem with any of them losing their connection until the previous update, now all of them will lose their connection after about 5-15 minutes.

  • zinto Level 1 (0 points)

    My theory is still this is a software bug which is trigger happy on stopping the program in the event of a momentary break in the connection instead of using the buffer and waiting for the connection to be re-established automatically the way it should.   I provided this feedback as a bug report to Apple but never got a response.   You can test that by getting a connection, let it build up a buffer in your program then turn your router off, then the ATV will stop playing within seconds even if it has a large buffer to run from.   But I'm able to run without problems after I made some adjustments to the router settings, so Apple will claim it's network settings even though the problem is the ATV is hypersensitive to network settings due to poor software design.  What helped in my case was directing ATV to pick up the 5 GHz signal which was set it my router to have a fixed channel.  Perhaps before my 2.4 GHz signal which had variable channel would blip every few minutes and then the ATV would error on that blip.  Just guessing there.  I don't want to open my router settings again or sneeze for fear I will not make the ATV happy. 

  • Charmiepoo Level 1 (5 points)

    Can I hear an Amen!  I agree wholeheartedly!

  • Alley_Cat Level 6 (19,210 points)

    stephenfrompowell wrote:


    Has the update worked for anyone? I have 3 Apple TV's and never had a problem with any of them losing their connection until the previous update, now all of them will lose their connection after about 5-15 minutes.

    Not the same issue, but I think something's definitely amiss with the latest update.


    Both my AppleTV 2 and 3 now constantly lose internet and Home Sharing connections if I watch a different input on either of my Panasonic TVs.


    I can have all icons present, switch to terrestrial TV, and when I switch back there's only Computers and Settings available and most of the time I cannot connect to the local itunes libraries.  All cured by restarting the AppleTVs, which are not set to sleep.


    I raraely had probems with AppleTV1s which I had since release,  and have never seen this issue with AppleTV2/3 until the latest update.



  • SteveK9123 Level 1 (0 points)

    Just bought my first Apple TV.  Asked permission to update this morning ... granted.  Tried Home Sharing for first time.  Works OK for a few minutes and then drops connection.  So, for me the latest hardware / software on the Apple TV side has a problem.  Hope someone at Apple is noticing this problem.

  • lagunabob Level 1 (0 points)

    Well, I was having trouble getting my AppleTV2 to see my iTunes on my computer, and I kept going to the iTunes preferences where you can turn on sharing, and not luck.


    I've been scratching my head for days, and then I clicked the (?) question mark in the sharing panel of iTunes, and I finally found my way to this page.....


    The screen shot tells it all, at least as far as my problem was. With iTunes open, you go to the "Advanced" tab on the iTunes menu (not in iTunes preferences), and there you will see an option to "Turn On Home Sharing".


    That took care of my problem. Everything was just working fine until recently when I finally upgraded my iMac and MacBookPro to OSX 10.7.4 Lion. Perhaps the upgrade has a default to turn home sharing off. Can't say.


    Hope this helps.....

  • stephenfrompowell Level 1 (0 points)

    I don't think it's your iMac/MacBook update that's the issue although I can't say for sure. I've had 3 atv's for over a year without any issues at all. After an update about a month ago (I was foolish enough to update all of them) they will no longer hold a connection for longer than 5-10 minutes. Absolutely nothing was changed "except" the upgrade. (so super users please refrain from telling me your canned "it's your network" response). I can still access YouTube without interuptions, it's only my iTunes. Of course not being able to access your iTunes pretty much makes your atv useless... oh, unless you purchase Match!!!!!

  • Mtanderso Level 1 (0 points)

    Using reserved/fixed IP addresses works for me. Thanks!

    This really needs to be addressed by Apple because unless a user is familiar with their router set up and what to change in it's settings to do this, they may have difficulty doing this.

    Apple's solution will hopfully be to release a new version of iTunes and atv iOS to prevent whatever comms atv and itunes uses from being dropped in such an annoying manner.

  • Charmiepoo Level 1 (5 points)

    I'm experiencing a whole new problem now since that last little ATV update several days ago. Now when I'm viewing something on Netflix the sound keeps losing proper sequence. I have to restart the program/movie to get the sound back to normal sequence. Thankfully I only applied the update to one of my ATVs, so my other one still works normally with Netflix. Tonight I will have to restore that ATV back to factory settings and then load all the updates again, except this last one.  I'm beginning to wonder if Apple is hiring monkeys to run their programming dept.

  • jds1761 Level 1 (0 points)

    Over the years I've had a collection of 9 apple products.  One thing I've noticed is that on all of them the OTA updates are a bad idea.  I've had the same problem with my 2 ATV's (that everyone seems to be having).  My ATV's recently asked me to update and so I did.  It was the start of all the losing connection problems.


    Has anyone tried turning off all the PC's and phones in the house?  I did.  Then I connected my ATV to internet radio and the connection was lost after about 20 mins.   Seems to be a problem with the ATV for sure.


    After restoring my ATV's (when I did it updated again even though no updates were showing in the ATV menu) everything was working fine again.

Previous 1 3 4 5 6 7 Next