Skip navigation

Outgoing SMTP : Stopped

1487 Views 5 Replies Latest reply: Jun 2, 2012 8:52 PM by Camelot RSS
ppina Calculating status...
Currently Being Moderated
May 30, 2012 3:47 PM

I Need help .


Outgoing SMTP : Stopped

incoming SMTP : Stopped


Fatal : the Postfix mail system is not running


Please help

  • Camelot Level 8 Level 8 (45,670 points)
    Currently Being Moderated
    Jun 1, 2012 8:55 AM (in response to ppina)

    Umm... you didn't give us much to go on, there.


    First, I presume you want/expect your mail server to be running - you don't actually state that.

    Second, what do the logs say - either /var/log/mail.log or /var/log/system.log would be good places to start. If postfix refuses to start it usually indicates a configuration problem, and that should be logged so you can pinpoint and correct the issue.


    As is, there's nothing more anyone can suggest without more detail.

  • Camelot Level 8 Level 8 (45,670 points)
    Currently Being Moderated
    Jun 1, 2012 8:40 PM (in response to ppina)

    hmm, so in nearly 100 lines of log you choose to focus on four messages related to postfix and ignore the other problems on your machine? strange.


    It's clear your machine is having issues - the postfix errors are almost certainly the system trying to send you a notice email but failing because postfix isn't running - there isn't anything there that tells me postfix is broken, per se., rather it's just not turned on.


    You should focus more on the other errors on your system. I'd be especially worried about Apache Tomcat respawning, assuming you're using that (if not, turn it off), and if you don't recognize the IP address then the emond messages might be of concern, too.


    As for your original question - enable mail (via Server Admin) and those four messages will likely go away, but it won't address any of the other issues.

  • Camelot Level 8 Level 8 (45,670 points)
    Currently Being Moderated
    Jun 2, 2012 8:52 PM (in response to ppina)

    OK, but you still have not explained whether you EXPECT the mail service to be running on this machine and it's not, or whether you do not expect it to be running.


    On one hand, these messages are normal and likely benign - the erratic timestamps indicate that it isn't postfix that's trying (and failing) to start up, rather some other process has tried to send a message through this machine, but the mail server isn't running.


    The simplest solution would be to enable the mail server - at least that way you have a chance to view the messages that are being sent, which might indicate some other problem that's going on. For example, you cn configure the server to send email alerts when certain events happen - such as the server getting low on disk space. It might be handy to recieve these emails.


    The only log message that does indicate a concern is the postmap error:


    Jun  2 15:58:32 xservecolt postfix/postmap[22935]: warning: /etc/postfix/sasl/passwd: logical line must not start with whitespace: "??:"


    which indicates an invalid entry in that file. Since that file isn't used in the default configuration it indicates that you have somehow tried to edit the config and made an error somewhere. Fixing this file will make these errors go away.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.