Skip navigation

Wifi Constantly Dropping in Lion

524132 Views 2,266 Replies Latest reply: Mar 28, 2014 2:35 AM by WSR RSS Branched to a new discussion.
  • goatcabin Calculating status...
    Currently Being Moderated
    Jun 1, 2012 9:43 AM (in response to luiz.kato)

    This is weird. I had this problem for quite a while. When I disabled 802.11n, it went away. After 10.7.4, I re-enabled 802.11n, and it works fine now. My router is a MicroTik RB751U-2HnD.

     

    Cheers,

    Alan Shank

    Woodland, CA, USA

  • As2x Calculating status...
    Currently Being Moderated
    Jun 3, 2012 6:48 AM (in response to MichelA)

    I set MTU to 1492 some weeks ago (page 120 of this topic).

    Also for me the issue is disappeared so far!

  • handi Calculating status...
    Currently Being Moderated
    Jun 4, 2012 1:05 AM (in response to lhale)

    MTU you can change on Mac, but not on the iPad and this is not working. there is no option setting possible about.

  • As2x Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 4, 2012 1:33 AM (in response to handi)

    No, you can't change on ipad... but I think it's a different issue...

    I have an iPad 2 on the same network, updated to last FW version, I've never experience the same problem...

  • MacDaddy_DaddyMac Calculating status...
    Currently Being Moderated
    Jun 14, 2012 9:59 AM (in response to lhale)

    I posted this on another post--same topic. Good luck!

     

    I've tried all the solutions posted on the internet:

    -Rolling back the wifi driver

    -Adjusting MTU

    -Running background internet activities: ping and Pandora

    -Deleting network settings: preferred network, keychain, etc.

    -Resetting PRAM and NVRAM

    -Router Settings

     

    It has been a frustrating process trying to resolve this issue.

     

    I finally have stable wifi on my 21 inch iMac.

     

    I downloaded Signal from the App store, and played around with the recommended channels.

     

    I tried channel 11; it worked for a little bit, but it eventually started dropping.

    I switched to channel 1, now I am on day two. Wifi has no issues when after waking, and no random drops.

     

    Wireless experts recommend channels 1,6, and 11, so I would start with those settings.

     

    I hope you guys have as much luck as I did with this solution.

  • levimaaia Calculating status...
    Currently Being Moderated
    Jun 14, 2012 10:38 AM (in response to lhale)

    I finally was able to get things stable for more than 48 hours on a 5 GHz 802.11n network.  I am using a Linksys Cisco E4200 with my iMac 27" (mid-2011).  Since the iMac only supports a limited number of 5GHz channels I manually set the Linksys to work on channel 153 - 5.765 GHz with WPA2 security.

     

    You can see what channels your particular Mac supports: Apple Menu > About This Mac > More info... >System Report > Network > Wi-Fi > Suported Channels

  • gphonei Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 14, 2012 1:05 PM (in response to levimaaia)

    levimaaia wrote:

     

    I finally was able to get things stable for more than 48 hours on a 5 GHz 802.11n network.  I am using a Linksys Cisco E4200 with my iMac 27" (mid-2011).  Since the iMac only supports a limited number of 5GHz channels I manually set the Linksys to work on channel 153 - 5.765 GHz with WPA2 security.

     

    You can see what channels your particular Mac supports: Apple Menu > About This Mac > More info... >System Report > Network > Wi-Fi > Suported Channels

    Using a fixed channel as a solution may be the answer for people with huge amounts of other users around them.  The automatic setting, may, in fact create more problems in this environment, if the radio keeps shift frequencies, causing your computer to have to constantly skip around.  Even on 5ghz, there may be enough noise that a fixed frequency is the right choice.  Look to see what's going on around you and pick a lightly loaded frequency.

  • levimaaia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 14, 2012 1:16 PM (in response to gphonei)

    There is a cool Dashboard widget called Airlock that can help you survey Wi-Fi networks.  It shows you the names, types and channels of all of the networks in range.  Pick a 5 GHz channel (they are all three-digits) not already listed that is supported by your Airport card (not all 5GHz channels are supported).

     

    http://www.pimley.net/projects/#airlock

  • levimaaia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 14, 2012 1:19 PM (in response to gphonei)

    I think one of the problems with the automatic channel selection with non-apple 802.11n 5GHz routers is that they sometimes skip to a channel not supported by Apple Airport cards leaving Apple devices out of the loop and offline.  A manual channel selection may be appropriate in this case even if you are not surrounded by other networks for the simple fact that the chance remains that the router could choose an unsupported channel as long as it is set to auto.

  • gphonei Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 14, 2012 1:51 PM (in response to MacDaddy_DaddyMac)

    I tried channel 11; it worked for a little bit, but it eventually started dropping.

    I switched to channel 1, now I am on day two. Wifi has no issues when after waking, and no random drops.

     

    Wireless experts recommend channels 1,6, and 11, so I would start with those settings.

     

    I hope you guys have as much luck as I did with this solution.

     

    The deal is how the channels are used by other users and the choice of 802.11b/g/n they are using.  Look at what's going on around you, and pick something open or with fewer users.  Using Channel 1, 6 or 11 is the right choice because it keeps users separated from each other, but if someone else is not on one of those channels, it may interfere with two of these channels, and you'd need to smartly pick another channel to be away from them.

  • LandSharkLaw Calculating status...
    Currently Being Moderated
    Jun 14, 2012 3:46 PM (in response to lhale)

    If you look back in this thread you'll see that I have been having connectivity issues since my upgrade to Lion.  I have tried every proposed solution here, I have spent hours on the phone with my ISP, I have spent hours on the phone with Cisco, I have spent, cumulatively, days either on the phone or at Apple, every one of my friends, acquaintances, colleagues, Starbucks baristas, lunch counter lady, strangers on the street, anyone who will listen know my connectivity problems as well as I do, I have exhausted my patience and reached the absolute limits of my technical abilities.  The result:  It still happens, some days more frequently, some days hardly noticeable, Apple couldn't be kinder or more helpful (except, of course, for fixing the problem) or understanding, and I have begun muttering and grumbling to my iMac much the way I muttered and grumbled to my HP PC before I chucked it and switched my whole life over to Apple a couple of months before Lion came out.  That's all understandable, but the scary part is that I caught myself thinking earlier today, "Don't worry, it'll all be better when they release and you install Mountain Lion . . . That'll fix everything!"  You would think I'd have learned by now. 

     

    Sincerely, a heartfelt good luck to all who are experiencing these issues along with a hope that These issues will be resolved soon.

  • James Brust Level 1 Level 1 (65 points)
    Currently Being Moderated
    Jun 15, 2012 8:04 PM (in response to LandSharkLaw)

    My two cents. I've seen this suggestion on this discussion before, but never tried it until recently. From the posts, it obviously hasn't worked for everyone...if it had, this discussion wouldn't be an incredible 122 pages!  Having said that, this worked for both me & a friend who was experiencing the exact same problem (both running Lion 10.7.4 on iMacs with current Airport basestations)  And that is: simply deleting the SystemConfiguration folder from the root Library and then rebooting. Important: the Root Library, not the User Library. HD>Library>Preferences>SystemConfiguration.

    After rebooting, the folder rebuilds itself.

     

    I'm always leery of messing around in the root level system, so if you are too, don't completely trash the folder you deleted...you can always retrieve it frrom the Trash if you don't empty the Trash. I kept a copy on the Desktop just to be safe but I haven't needed it.

     

    I know this may seem too simplistic given all the other solutions, workarounds, etc.....All I can say is, I don't understand it, but it worked for me.

     

    Good luck.

  • QJack Calculating status...
    Currently Being Moderated
    Jun 18, 2012 5:47 AM (in response to lhale)

    Further update:

    My iMac stays connected when I use "G" mode to a "G" only AP.  I've recently acquired a new WAP (e4200 Dual Band) and using the 5GHz band, I too stay connected.  I still cannot stay connected to my older airport extreme (single band N). 

     

    Until I just happened upon this new Cisco WAP, I had been plugged-in (ethernet) directly.

     

    Maybe now, I can remove the tripping hazard from my office.

  • kriskjellquist Calculating status...
    Currently Being Moderated
    Jun 19, 2012 1:51 PM (in response to QJack)

    FWIW I am using an old Airport Extreme and switch to Channel 8 from Auto and it has worked very well for the last 48 hrs or so.  Best solution yet for me.

     

    ::crosses fingers::

  • gphonei Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 19, 2012 3:13 PM (in response to kriskjellquist)

    kriskjellquist wrote:

     

    FWIW I am using an old Airport Extreme and switch to Channel 8 from Auto and it has worked very well for the last 48 hrs or so.  Best solution yet for me.

     

    ::crosses fingers::

    It would be best if any users of fixed channels on 2.4ghz used channels 1, 6 or 11.  Any other channel usage will cause interference on two "segments" simulaneously for 802.11n users.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (82)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.