Skip navigation

Profile Manager | Login Items | Network Mounts

5216 Views 14 Replies Latest reply: Mar 14, 2014 12:46 PM by arby2008 RSS
Newham Bridge Administrator Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 26, 2012 7:03 AM

I have Profile Manager set up to apply settings based on user groups and I'm trying to mount volumes that are appropriate to that user group but without success.


Through my testing I've done the following to try to rule out as many errors as possible...

  • In Finder preferences I have ticked 'Connected server' in the 'Show these items on the desktop' list
  • Connected manual via Finder to require mounts
  • Conected manually via the 'Go > Connect to Server' Finder menu
  • Changed something noticiable (dock position) to in indicate successful loading of new Profile
  • Logged out and back in to check for successful Network Mounts
  • Tried many variations of network path in Profile Manager including IP Address, Host Name, Computer Name and copying the mounted path from the 'Get Info' window of a manually mounted volume.
  • Altered permissions on Share Points


I've read that all I should need to do is mount the required volume on the computer where I'm accessing Profile Manager and drag and drop the mount on to the Add Mount Point box. This hasn't worked either.


The last set up I tried looks as follows:


Profile Manager | Login Items | Network Mounts.jpg


Can anyone help me with this? I've tried to rule out as many silly possibilities as possible. I look forward to any suggestions that you may have.

Mac mini Server (Mid 2011), Mac OS X (10.7.3), Lion Server
  • volderette Level 1 Level 1 (0 points)

    I have the same problem. Did you find a solution yet?

  • volderette Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 10, 2012 6:56 AM (in response to volderette)

    I even see the share in login items and if i double click it connects, so the credentials are right. But after a restart the login item is gone. Strange!

  • David Urban Level 1 Level 1 (0 points)

    I have been having trouble getting profile manager to be consistant.  I have it set up to show the network users on the login screen and not the administrators.  some times it shows them some times it doesn't.  some times it will show it then when the computer goes to sleep at wake up they are gone.  the login mounts dont work.  Parental control dont work at all.  There must be something that is on the client machine that gets passed around and there is a fight to which one controls.  I hope this gets fixed in Moutain Lion.  I have reinstalled three or four times and have had the same problems. kids can't logon due to time limits even though there there are none set.


    there must be something messed up in my system but I don't think so.

  • furby Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jun 13, 2012 2:16 AM (in response to David Urban)

    Having the same probelems as you David, profile manager seems to work very inconsistantly.


    Make sure in the Energy Control payload you have the setting to put the computer to sleep marked as Never. I think the preferences are applied in this order:


    1. User
    2. Computer
    3. Computer Group
    4. Everyone
    5. User Group


    So perhaps there is some conflict there?


    You can check which setting are applied on the local machine. Go to System Information app, sroll down the left to Managed Client and it should have the info there. Though it's not the friendliset of screens.



    @Newham Bridge Administrator


    What happens when you make it an item in the Dock Items of the Dock Payload? I think it takes a moment to authenticate with the users details and then (should) pop open. (mine is smb but you get the idea)


  • furby Level 1 Level 1 (25 points)

    I have the same (question mark) as well actually, sure I had it working. Hmm. Must be missing something simple.


    I was messing around and got this setup on my machine now, no testing other than a couple of restarts. Not sure how it would deal with permissions.


    1. I connected to the shared folder/voulme.

    2. Whilst on the desktop. Finder -> Preferences and ticked show Connected Servers.

    3. Right click on the volume icon and Create Alias.

    4. On the alias (shoudl appear next to the original) right click again and Get info (cmd+i)

    5. Click on Select New Original...

    6. In Finder scroll down to Devices and click on the Volume you want (should have the same name) and Open.

    7. I then renamed it something else more friedly.

    8. Move it to somewhere else that all users can get to. I just stuck it in Applications but I guess the Shared items folder would work just as well.

    9. I then dragged these (I did a couple) into the dock. And it seems to wok


    I'll see what happens when you add these applications as a login item and also if I copied them out across the newtwork (usign Apple Remote Desktop) and profile manager.


    What was your workaround


    Message was edited by: furby

  • ebrind Level 1 Level 1 (15 points)

    The fix for me was the finder preference had to be changed to show connected servers on the workstation.





  • Codeus Level 1 Level 1 (10 points)

    I know this is an old thread but the issue is still there.


    Seems Lion (and Mountain Lion) have a problem with mount points via Profile Manager - especially if you change anything or are trying to mount a share from a server other than the OD master.


    I could connect manually via ssh and via Apple-K and via mount_afp but home folders would not work, nor some shares.


    My resolution was: -


    1 - take a look your mount entries via dscl - seems PM messes them up somewhat.  You can check via terminal with: -


    dscl /LDAPv3/<serverip>/ -list /Mounts


    Now log on as a local use on a computer joined to your OD and type: -


    ls /Network/Servers/


    Both commands should list a mount point for each share you are trying to setup.  If not, you can create them manually using this apple doc:


    Once you've created them via Directory Utility as per that article, reboot your client machine then test again with the above commands.


    The other thing I did to help make things go easier is to use WorkGroup manager to set up your mounts rather than PM - it seems much more robust (downloadable from Apple).



  • arby2008 Level 1 Level 1 (0 points)

    Having the same issue here... I'm trying to follow your instructions but they make no sense... I'm thinking the spelling is wrong. Normally, it is /Volumes/<mountname> where <mountname> is the name of the local folder.


    Are you saying to do this directly on the server? This would work for a separate disk called <mountname>


    I just can't figure out what this means...

  • arby2008 Level 1 Level 1 (0 points)

    It seems that one aspect of the solution is to mount the volume properly. In the Login Items, enter the full URL to the volume:



    and nothing in the Volume field in PM.


    Then, you should be able to add the item to the Dock by referring to the /Volumes/<moiuntname> as a Dock item


More Like This

  • Retrieving data ...

Bookmarked By (4)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.