Skip navigation

iWeb, not able to open saved domain

938 Views 8 Replies Latest reply: Jun 14, 2012 4:08 AM by EAM34 RSS
Arnie M Calculating status...
Currently Being Moderated
Jun 4, 2012 11:22 PM



On my MB-Pro I have a couple of websites seperatly saved and auto named i.e. Domain.sites2 when I saved it that time (febr 2011). I put them in a folder named with the corresponding site. All I needed to do to work in iWeb is just click on the icon (called domain.sites2) and automaticly iWeb opened with the right site.


Now, (properly since I updated to Lion) iWeb isn't responding anymore and have to force quit iWeb.


Because the MBP is replaced to a MB-Air I dont care about it that much.


Now after dragging and dropping iWeb to an external disk and trying to work from there. The following occurred:


1. When I open iWeb I'm forced to choose a template but I want to open excisting (the old) sites. When i Cancel the whole iWeb app closes and I can't find an option <open> (after just choosing a template).


2. When I try to click on the saved file(domain.sites2) I get the same: choose template (the file icon shows the website layout)


These websites I can't change anymore now but I would like to.

Anyone have some tips or advise?



  • Wyodor Level 6 Level 6 (19,335 points)
    Currently Being Moderated
    Jun 5, 2012 10:03 AM (in response to Arnie M)

    Discussed a trillion times since Lion was introduced.


    Search this forum : Lion


    To get you started :


    where do I find "domain" in Lion?

    Problem with iWeb on Lion


    And my contribution, of course :


  • Old Toad Level 10 Level 10 (113,040 points)
    Currently Being Moderated
    Jun 5, 2012 3:23 PM (in response to Arnie M)

    In Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.


    To open your domain file in Lion or to switch between multiple domain files Cyclosaurus has provided us with the following script that you can make into an Applescript application with Script Editor. Open Script Editor, copy and paste the script below into Script Editor's window and save as an application.

    do shell script "/usr/bin/defaults write iWebDefaultsDocumentPath -boolean no"

    delay 1

    tell application "iWeb" to activate


    You can download an already compiled version with this link: iWeb Switch Domain.


    Just launch the application, find and select the domain file you want to open and it will open with iWeb. It modifies the iWeb preference file each time it's launched so one can switch between domain files.

    WARNING: iWeb Switch Domain will overwrite an existing Domain.sites2 file if you select to create a new domain in the same folder.  So rename your domain files once they've been created to something other than the default name.



  • EAM34 Calculating status...
    Currently Being Moderated
    Jun 12, 2012 1:17 PM (in response to Arnie M)

    I cannot open iWeb. Please help! I'm using MBP running Lion 10.7.4 and iWeb 09. Using a site I've had running since 2006. I have other sites. On last but one OS update I had to start using Domain Cracker to be able to select the file I wanted. Recently updated to current operating system and have had problems with iWeb since. Closed the file on Sunday morning. When I next went to open later that day, I got the following error message, 'Can't Open file "Volumes/EAM2011/Domain.sites2" Never seen that before. Never seen Domain.Sites2 before. Domain Cracker doesn't help. iWeb Switch Domain doesn't help. I have deleted the deleted and in preferences and in the Cache the contents of the folder and restarted. No luck. And the preferences files I deleted have returned.

    I hope you can help. This is a site I usually update every day!

  • Old Toad Level 10 Level 10 (113,040 points)
    Currently Being Moderated
    Jun 12, 2012 2:32 PM (in response to EAM34)

    Try the following:


    1. delete the iWeb preference files, and, that resides in your Home() /Library/Preferences folder.

    3. go to your Home()/Library/Caches/ folder and delete its contents.

      Click to view full size


    5. launch iWeb and try again.


    If that doesn't help continue with:


    1. move the domain file from your Home/Library/Application Support/iWeb folder to the Desktop.
    2. launch iWeb, create a new test site, save the new domain file and close iWeb.
    3. go to the your Home/Library/Application Support/iWeb folder and delete the new domain file.
    4. move your original domain file from the Desktop to the iWeb folder.
    5. launch iWeb and try again.




  • EAM34 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 12, 2012 2:40 PM (in response to Old Toad)

    Thanks OT!


    I already tried 1 and 2 and it didn't work. I restarted afterwards but didn't try repairing permissions though so will try it again and do that and see where it gets me.


    The domain is not in Home/Library/Application Support/iWeb folder - it's on an external Hard Drive. I usually use Domain Cracker to open it rather than the one in the Home/Library/Application Support/iWeb folder. Does that make a difference?


    I'm currently making a copy of the Domain I want to open and thought about moving that to Home/Library/Application Support/iWeb folder and then trying to open it.


    It's bed time here (UK), so I'll try all that tomorrow. Thanks for your help.

  • Old Toad Level 10 Level 10 (113,040 points)
    Currently Being Moderated
    Jun 12, 2012 2:44 PM (in response to EAM34)

    Try putting it in your Users/Home/Library/Application Support/iWeb folder and run it from there.  With Lion that my be the solution.

  • EAM34 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 14, 2012 4:08 AM (in response to Old Toad)

    Unfortunately that doesn't work. Any other ideas?


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.