1 Reply Latest reply: Jun 6, 2012 8:19 PM by roaminggnome
bwhitton Level 1 Level 1 (0 points)

Can my iTouch 2nd gen use  apps that require v4.3 ?


iPod touch, iOS 4.2