1 2 3 4 Previous Next 57 Replies Latest reply: Jan 12, 2014 5:03 PM by FabioPOBrazil Go to original post
  • 30. Re: Timeline Disappeared
    P Tremblay Level 1 Level 1 (0 points)

    Hello. I'm a new lucky one

     

    No need to say I got the same issue. Now, I am trying to reopen the app after re-importing the xml file. I had many problems with FCPX such as having to wait up to 5, probably 10 minutes between each tiny little move. Well, you can figure out the story....

     

    As we are in real time, right now, my app finally reopened with the new (re-imported) film AND I CAN SEE MY TIMELINE. Thank you so much. I hope everything will work fine. But I wish I knew what to do with my corrupted files (I mean the original movie). Should I trash it, and should I do it through FCPX or the finder. I don't wanna see it anymore !

     

    Seriously, what do I have to do with the movie I got in trouble with?

     

    And if ever I had to go through the same issue again, would it be accurate to reinstall the app? What do you think of that?

    Cheers

     

    Pascal

  • 31. Re: Timeline Disappeared
    jnetzer Level 1 Level 1 (0 points)

    Alas, the bug ate my project too! Thanks, everyone, for making this post.

     

    Working on a MAJOR project (due today) using FCP X, Trial Version to test before I buy. I was putting the final touches in this complex project with many layers and slick effects and then BLAM! Timeline gone.

     

    HERE'S WHAT HAPPENED: I had a few clips (including a freeze frame a.k.a. "hold") with credit text at the very end of the video just above the main storyline. It looked like it was connecting to series of gaps that were on the main storyline. I wanted rid of the gaps and drop the footage down to the main storyline. It wasn't necessary since it played fine as is, but wanted to figure out how to do it. When I selected and deleted the gaps, the other footage got deleted with it. So I tried the selector tool to trim the end gap that extended past the footage I wanted to keep. It may have been in combination to some rendering that was going on in the background simultaneously or something to do with the gaps (in a series) being connected to the other footage, but next thing I knew I'm looking at a blank timeline and kicking myself for not backing up the files. (SEE SCREEN SHOT)

     

    HERE'S WHAT I DID:  I backed up the files!!  BEFORE trying to restart the program/computer etc., I turned on my trusty external hard drive and copied all of the files related to the project.  In the meantime, I found this forum.  After the files copied over, I tried the steps described above without touching the files I backed up, just in case I would corrupt those too.  In doing the Export/Import thing, the files came back for the most part, but ALL of the text settings got totally undone to default Helvetica, white, position 0x0y etc. I have a bunch of text flying here and there and so it would take me a full day to recreate/re-render it. Plus, the color settings (Vibrancy filter, etc.) that were used in the clips also vanished. SO... since I figured I at least have some base stuff recovered and don't have to totally start from scratch, I then might as well try what I copied to my hard drive.  VOILA!  It's all there!!! It had to be re-rendered, but I didn't have to Export/Import etc.

     

    MORAL OF THE STORY: Back up files immediately! "Save early, save often." If something goes wrong, try copying where the computer left off BEFORE messing with other recovery techniques. It may not work all the time, but it's worth a shot. Saved me from redoing a huge project!

     

    And I hope the FCP makers hear us and make these fixes ASAP... I will call them when their office opens. We should all call to get their attention. I don't have Apple Care, but had no problems before since I'm running off the trial version and had questions in how to use it. It helps to be nice on the phone too.

     

    Screen shot 2012-06-08 at 3.56.59 AM.png

  • 32. Re: Timeline Disappeared
    Tom Wolsky Level 10 Level 10 (106,220 points)

    The way to get rid of the gap clips at the end is to select the liquid shots and use Opt-Cmd-down arrow to overwrite it into the primary storyline.

  • 33. Re: Timeline Disappeared
    P Tremblay Level 1 Level 1 (0 points)

    Hi Tom. Thanx a lot.

     

    English aint my first language so you can figure out I don't wanna do the wrong things.

     

    "The way to get rid of the gap clips"

     

    Do you actually mean : the way to trash the corrupted files (clip)?

     

    And

     

    "...is to select the liquid shots..."

     

    What do you mean by "the liquid shots" ? The wrong clip, the new rebuilt clip, the .fcpproject document ????

     

    I'm sorry but I just wanna make sure, and deeply understand what you mean.

     

    Thanx

  • 34. Re: Timeline Disappeared
    mcdrew Level 1 Level 1 (0 points)

    Thanks a lot Norman Jayo, as you have helped me with that workaround.

     

    All the clips from the Export XML file appear as composites on the timeline in the revised version.  Is that an issue?  Exported a sample from it (export media), seems ok ie has sound.

     

    As an observation it would be helpful if "discussers" stated what computer they are working on (as bugs are machine specific and the Apple designers might be within their rights to say it works, depending on which computer). Those using a MacPro v1.1 will recall not being able to update to the "essential" v 10.0.1 which worked fine with the rest of the apple range.

     

    Speculating, "it was this or that, that caused it" does that help most of us?  It's a bug, you dont know how it works, and the topic goes off relevance.

     

    Anyway best of luck to those of us who've in the dark leaped to FCPX.  

  • 35. Re: Timeline Disappeared
    Tom Wolsky Level 10 Level 10 (106,220 points)

    I wanted rid of the gaps and drop the footage down to the main storyline.

     

    That's what I was answering.

     

    The liquid shots. That's what they're called in the screen shot of the timeline you showed, liquid1hd.

  • 36. Re: Timeline Disappeared
    P Tremblay Level 1 Level 1 (0 points)

    Ah, OK. Now I get it. The liquid shots are actually part of jnetzer's point.

    I am somebody else !!!! Confusing for all of you

    So here's my question again, not talking about jnetzer's project.

     

    How do I trash the corrupted file (or are we talking of a corrupted project?)

  • 37. Re: Timeline Disappeared
    P Tremblay Level 1 Level 1 (0 points)

    Voilà.

    To Tom, Now I totally understand what you were talking about. Sometimes I have to read very slowly to get the meaning of everything. It may sound obvious for all of you but I'm not an english speaker, and with all the stress this issue brings to me, I gotta work to get everything.

     

    Now, I'll be more precise about my wonderings.The work around Norman suggested worked for 2 hours, and the same thing happened again. It's just a matter of knowing more about dealing with this problem since I finally decided to trash my 2 hour project and restart it from a very new starting point. I realized I kept on dealing with corrupted files so there was no way I could get out of it. I'll be late to my client, but it will be much easier, if not faster, to start again. I don't wish this anti-solution to anybody, but let's forget about my own problem where my timeline went off for a second time, and I wish somebody could tell us about the following:

     

    Once we've export and re-import the xml file, quit and restart FCPX, a new project has been created with our project and a timeline we can work with. From then, the old project (the one on which we lost our timeline) must be deleted? And through the finder or FCPX?

     

    Thanks again.

  • 38. Re: Timeline Disappeared
    Tom Wolsky Level 10 Level 10 (106,220 points)

    You can delete the old project through the project library.

     

    I would advise everyone to get Pro Versioner from Digital Rebellion and use it.

     

    There is at least one known cause for the disappearing timeline and it is a hundred percent reproducible. So the procedure of rippling a gap clip to delete it should be carefully avoided and never done. There may be other causes, but this is the only one I have heard of to date.

  • 39. Re: Timeline Disappeared
    jw005 Level 1 Level 1 (0 points)

    Can someone please help me with my earlier question, I haven't yet received a reply.

     

    Same thing happened with me on a huge project I was working on.

     

    After trying everything, (including Norman's work around - which I could only get to the exporting xml file step - because everytime I went to import the file, fcpx would freeze during the process of importing and unexpectedly shut down, so it would never work) I have decided to start again on the normal Final Cut Pro 7 - because I am in fear this will happen again.

     

    Can anyone please answer why my fcpx cannot import the xml file and continues to freeze and shut down during the process?? Because that is the only thing preventing me from continuing to work with fcpx.

     

    I like to give these things the benefit of the doubt and I liked the aspect of a very visually appealing new version of FCP, FCPX - but it seems that all the criticisms are becoming correct, and its so disappointing.

     

    APPLE - fix this immediately. It is not the consumer's job to fix what apple has created. Get it right.

     

    Thanks everyone for this forum - I am so glad to see such a team effort and people retrieving their projects.

     

    Hopefully someone can help me with mine,

     

    Thanks again. 

  • 40. Re: Timeline Disappeared
    jw005 Level 1 Level 1 (0 points)

    Tom,

     

    What did you mean with "the procedure of rippling a gap clip to delete it" - what is rippling? Could you please provide a screen shot or explanation? Sorry if its an obvious terminology.

     

    Kind regards,

  • 41. Re: Timeline Disappeared
    CAH88 Level 1 Level 1 (0 points)

    Exact same thing has happened to me. My problem is more widespread than one project, however. I can't edit at all! The timeline has turned grey for every project I have and I can't work on a single thing. I got the same response from an Apple rep on the phone about the $99 bucks per service call, which is a total rip off.

     

    I've tried resetting preferences, reverting to  original layout, and even deleting and re-loading the App, nothing! This is completely ridiculous on Apple's part to have such an obvious bug and do absolutely nothing to accomodate loyal customers in order to right it, or to make them pay so they can tell us it can't be fixed.

     

    This isn't just a minor bug issue, this is a livelihood issue. If I can't edit, I can't eat. Going into the Apple Store today to see if I can get ANY insight on the problem. Even if it costs $99 bucks...

  • 43. Re: Timeline Disappeared
    P Tremblay Level 1 Level 1 (0 points)

    Thank you very much Tom. It is quite easy to get what's wrong with the app - at least to understand clearly this move has a huge consequence. I did the exact same thing and from there, it's been quite a pain...

     

    As you said, maybe it's not the only reason for losing a timeline, but until we know the problem has been corrected, I'll be using bookmarks to mark the beginning and ending of a desired gap, which I'll put in at the end of my editing.

     

    If there was any other way to avoid the problem, let me know.

     

    Thank you

  • 44. Re: Timeline Disappeared
    fotoninja Level 1 Level 1 (0 points)

    Hi All,

     

    I'm a pretty newbie editor, using the trial version of Final Cut X for the first time and was loving it untill my timeline dissapeared. After having read through this thread, I'm pretty sure the XML export/import will fix this but I am having the same problem as jw005 (Jill). Upon reimport of the XML file, my app crashes. I am also unsure how to 'trash my preferences' as that is the only thing that I can think of I have not done yet.

     

    Any help on this very frustrating topic is appreciated.

     

    Tom, I will also follow your suggestion and NOT trip against a gap by pulling the handle bar as I'm pretty sure that is what happened. I can see my other projects just fine in the library but I'm leary about moving forward with any of them until this problem is fully resolved. I should also add, it seems pretty rediculous that Apple's Autosave only saves ONE version from 15 mins previous (standard preset?) and that'd we'd have to purchase a third party piece of software that does what (IMHO), auto save should do. Any add'l thoughts on this?

     

    Thanks,

    Greg