Skip navigation

Apple USB Ethernet cannot hotplug after 10.7.4

4246 Views 14 Replies Latest reply: Oct 9, 2012 10:44 AM by wiz562 RSS
rsalgado76 Calculating status...
Currently Being Moderated
May 16, 2012 1:38 PM

After upgrading to Mac OS X 10.7.4 on a MacBoox Air 2011, the Apple USB Ethernet adapter (A1277) loses the hot (re)plugging capability.

The OS recognizes and initializes correctly the device and en3 interface on fresh boot, however after an unplug and replug of the device, the en3 interface is not re-enabled.

Syslog as follows:

May 16 21:20:43 Ricardos-MacBook-Air kernel[0] <Debug>: AppleUSBEthernet(0xffffff806a974000): - Version number 2.1.51, Input buffers 64, Output buffers 32

May 16 21:20:43 Ricardos-MacBook-Air kernel[0] <Debug>: AppleUSBEthernet: Ethernet address 28:37:37:02:de:9d

May 16 21:20:43 Ricardos-MacBook-Air kernel[0] <Debug>: en3: attached with 4 suspended link-layer multicast membership(s)

May 16 21:20:44 Ricardos-MacBook-Air hidd[54] <Notice>: MultitouchHID: device bootloaded

May 16 21:20:44 Ricardos-MacBook-Air kernel[0] <Debug>: AppleUSBMultitouchDriver::message - kIOUSBMessagePortHasBeenReset.

May 16 21:20:44 Ricardos-MacBook-Air kernel[0] <Debug>: 0 e0000100 AppleUSBEthernet: message - The driver has been asked to close the device

May 16 21:20:44 Ricardos-MacBook-Air kernel[0] <Debug>: AppleUSBEthernet::prepareToClose - Link down, Device a9dd700

May 16 21:20:44 Ricardos-MacBook-Air kernel[0] <Debug>: AppleUSBMultitouchDriver::checkStatus - received Status Packet, Payload 2: device was reinitialized

May 16 21:20:44 Ricardos-MacBook-Air kernel[0] <Debug>: AppleUSBMultitouchDriver::_deviceSetReport - DeviceRequest for reportID 0xac returned with result 0xe000404f - retrying

The AppleUSBMultitouch messages intermixed with the AppleUSBEthernet always appear, looking as if those events are linked with the USB Ethernet events.

This occurs on both USB ports on the Macbook Air, left and right, and with no other devices connected.

 

The OS is able to reload the device and re-enable the en3 interface if the kext is reloaded manually:

$ sudo kextunload /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleUSBEth ernet.kext

$ sudo kextload /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleUSBEth ernet.kext

, but this is cumbersome to do on every reconnect (I do this several times a day, moving between my desk and meeting rooms).

 

Any thoughts on what maybe causing this and how to correct it? I've already tried re-installing 10.7.4 with the update combo.

 

Thank you.

MacBook Air, Mac OS X (10.7.4)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.