10 Replies Latest reply: Jul 18, 2013 8:39 AM by Elevatormusicmaker
Jason Zac Level 1 Level 1 (0 points)

Mainstage 2.2.2 has a CPU overload with any AU instruments I am running. All are legit for example Modartt's PianoTeq. It is actually manageable at about 60%. However, the moment I use the sustain pedal for about a bar of music, it spikes and then has audio dropout making it impossible to play.

 

I have made the settings to allow 256 samples as buffer size. Even after going to 512 samples, the CPU spikes are prominent.

 

I tested out the default keyboard concert with tons of patches loaded with the preset sounds. The pedal works fine and CPU usage doesn't cross 15%!!

 

I'm pretty surprised since the upgrade has cause this problem. All earlier versions of Mainstage ran fine.

 

Is there:

 

Any solution to this weird problem?

Any way to revert back to an older version which works fine on 10.7.4?


MainStage, Mac OS X (10.7.4), Mainstage 2.2.2
  • 1. Re: Sustain Pedal causing CPU Overload for Audio Units (AU) only
    chiccorosso Level 1 Level 1 (145 points)

    Do this:

    - open pianoteq plugin, set the volume of sustain pedal noise to 0 (if i remember correctly is under "action")

    - check the sample rate of pianoteq plugin in order to match mainstage one (and set both to 44.1Khz - 16bit)

    - set mainstage buffer to default, there's no real need to modify it IMHO

    - set mainstage master volume in order to just border the main audio meter red limit (you'll raise your mac volume or the output rig volume)

    - disable WIFI and Bluetooth

     

    this should help. if it doesn't look inside pianoteq plugins, there's a section inside options where you can tune it so that it doesn't fry your cpu

     

    good luck!

  • 2. Re: Sustain Pedal causing CPU Overload for Audio Units (AU) only
    Jason Zac Level 1 Level 1 (0 points)

    Tried all what you said. Sample rates are matched, sustain pedal is 0 and all defaulty setting. Any other solutions?

  • 3. Re: Sustain Pedal causing CPU Overload for Audio Units (AU) only
    chiccorosso Level 1 Level 1 (145 points)

    these are my settings:

     

    Pianoteq stage 4.0.3 (to check settings open plugin, then "options" then "perf"

    44100khz

    128 samples

    48 polyphony

     

    Mainstage:

    I/O buffer size 128, I/O safety buffer on, 128 samples driver latency (of course 44.100khz)

     

    Audio Midi setup:

    44.100khz 24 bit integer (integrated sound)

     

    Mac:

    2.4 Ghz Intel core 2 Duo with 4GB Ram.

     

    happened a couple of times with sustain pedal, the sustain pedal noise was overdriving and making lot of sub-150hz noise. i went to "Action" and muted sustain pedal.

     

    you can also try disabling internal pianoteq reverb and use a MS builtin one.

     

    Finally you can try removing your sustain pedal from your layout and placing it on again. Be sure nothing is overlapping!

     

    If you keep having issues try to use "activity monitor" to check if some background little software is eating up our computer cpu.

     

    Good luck, I'm sorry i can't be more straight-to-the-point.

     

    Chicco

  • 4. Re: Sustain Pedal causing CPU Overload for Audio Units (AU) only
    Jason Zac Level 1 Level 1 (0 points)

    Thanks a lot for your help! I'm on Pianoteq Pro, muted the sustain noise and all the other instructions you mentioned. Its a really strange issue. After 5-8 seconds, Mainstage gives up. So the problem is still unresolved!

     

    Is there any downgrade option?

  • 5. Re: Sustain Pedal causing CPU Overload for Audio Units (AU) only
    Jason Zac Level 1 Level 1 (0 points)

    Pinoteq runs perfect stand-along by the way! However, I need Mainstage to layer it with some strings etc..

  • 6. Re: Sustain Pedal causing CPU Overload for Audio Units (AU) only
    chiccorosso Level 1 Level 1 (145 points)

    I have MS 2.2.1 with macosx 10.7.3 (i'm having several concerts lately so i waited before updating my laptop, seems i got it right), i think the only option for downgrade is getting the app back from a backup or a time machine.

  • 7. Re: Sustain Pedal causing CPU Overload for Audio Units (AU) only
    Bryan Day Level 3 Level 3 (720 points)

    Hi,

     

    I've been struggling over the last few months, and was putting my frustration with CPU spikes and overloads down to updates to OSX and Mainstage, and the fact that I'm running a (don't laugh...) MBP 2.33GHz Core 2 Duo, with 3Gb Ram.

     

    However, I've found something that has really helped here.

     

    Disabling 'Multicore Rendering' in Pianoteq's Options, on each instance of the plugin in my set has helped immensely. It's returned my rig to the performance I was getting a couple of updates ago. I had not added anything (plugins or channel strips) to my main performance set (I've actually stripped it back as much as I could over the last six months because of overloads), but CPU load had been getting worse with every update to both OSX (Lion) and MainStage, to the point where it was almost unusable.

     

    I suppose this may apply to other plugins that have options for multicore rendering, particularly for those of us using antique core 2 duo technology...

     

    Hope this helps.

     

    B

  • 8. Re: Sustain Pedal causing CPU Overload for Audio Units (AU) only
    Elevatormusicmaker Level 1 Level 1 (0 points)

    Has there been any luck figuring out what the problem is here? This has only happened to me once on stage ever, and I had to reboot Mainstage for it to cop on. But of course that ain't ideal in a gig situation. I've notcied its mainly the ESX24, and one or two ther sampler plug-ins that do this unusual thing. Really annoying cuz thats all my string section compromised. If anyone has cracked it yet, please let me know, I'm so curious and ******!

     

    Using a Mac 10.6.8, 2.26 GHz Core 2 Duo, 8GB ram, 32-bit Mainstage

  • 9. Re: Sustain Pedal causing CPU Overload for Audio Units (AU) only
    Blueberry Level 4 Level 4 (2,860 points)

    MainStage 3 has more options to tweak the CPU usage, it might just solve this problem.

  • 10. Re: Sustain Pedal causing CPU Overload for Audio Units (AU) only
    Elevatormusicmaker Level 1 Level 1 (0 points)

    Cheers. I don't know if its a CPU problem though. It happens with every patch, light and heavy, and the CPU bar sits comfortably low throughout