Skip navigation

Mac goes super slow and doesn't see HD

417 Views 2 Replies Latest reply: Jun 14, 2012 4:54 AM by a brody RSS
RaniDHulster Calculating status...
Currently Being Moderated
Jun 14, 2012 4:26 AM

Yesterday everything was fine, nothing wrong at all.

But today when I started my iMac he first didn't show my external hard drive so I thought maybe my hard drive is broken so I tried instead of FireWire an USB cable but that didn't work either. So I tried connecting it to another computer and it worked so the problem must be with my Mac somewhere.

 

Now my Mac goes extremely slow and when I do 'Shut down' it takes minutes to get him powered off completely.

 

Now after a few minutes my Mac sees my Hard Drive again but the Hard Drive usual Icon isn't showing and when I open it to browse through it, it goes extremely slow. It looks like he is initializing everything on my hard drive, so I can't copy or open anything that is on it because it goes so slow.

 

Can someone please help me because I don't want to lose everything I have of movies etc...

iMac, Mac OS X (10.7.4)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.