Skip navigation

bluetooth not available

1768 Views 8 Replies Latest reply: Feb 25, 2013 5:16 AM by rafachile RSS
vtanasi Calculating status...
Currently Being Moderated
Jul 23, 2011 11:16 AM

I own a MacBook Pro with the following caracteristics:

 

Model Name:          MacBook Pro

  Model Identifier:          MacBookPro5,2

  Processor Name:          Intel Core 2 Duo

  Processor Speed:          2.8 GHz

  Number Of Processors:          1

  Total Number Of Cores:          2

  L2 Cache:          6 MB

  Memory:          4 GB

  Bus Speed:          1.07 GHz

  Boot ROM Version:          MBP52.008E.B05

  SMC Version (system):          1.42f4

 

 

The Bluetooth icon si grayed-out with a sig-saw sign over it. It says Bluetooth not available, and I can not activate it again. Any suggestions?

MacBood Pro, Mac OS X (10.6.4)
  • Barry Hemphill Level 7 Level 7 (33,110 points)
    Currently Being Moderated
    Jul 23, 2011 1:40 PM (in response to vtanasi)

    Hello:

     

    Try restting the PRAM and SMC.

     

    Barry

    iMac, Mac OS X (10.7), 4 GB memory,DSL
  • OregonRebel Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jan 11, 2012 9:49 PM (in response to Barry Hemphill)

    I'm just adding a comment to say a SMC reset worked for me.

     

    About an hour ago I was making a phone call via Google Voice, using my Bluetooth headset when my phone call got cut off and Bluetooth froze (beach ball over the menu bar icon). I tried to restart, but the system wouldn't fully shutdown so I did a manual shutdown. Upon reboot Bluetooth was not available and Bluetooth was completely gone from System Preferences.

     

    This had never happened before, so I was a bit concerned.  I repaired disk and permissions, then ran Disk Warrior. When that didn't help, I came to the Apple forums, typed Bluetooth into the search bar, and quickly found this thread.

     

    I followed Apple's instructions for resetting the SMC, and upon reboot Bluetooth was back!

     

    Since a link wasn't provided in the previous post and I had to search for the instructions, I'm including the link here to help others.

     

    How to reset the System Management Controller (SMC)

  • caledesign Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 2, 2012 4:46 AM (in response to OregonRebel)

    This was a great fix, thanks for adding the link as well. I applied the work around and that fixed the issue!

  • kcc9999 Calculating status...
    Currently Being Moderated
    Mar 2, 2012 2:58 PM (in response to vtanasi)

    Unfortunately, my bluetooth is still out... after the above.. any other ideas? Thanks.

  • Distant Cousin Calculating status...
    Currently Being Moderated
    Mar 4, 2012 3:17 AM (in response to Barry Hemphill)

    Hello all,

     

    Thought I'd ask here. I use a late 2008 MacBook Pro 15" with 10.6.8. I use bluetooth primarily for live music performance, controlling sounds and samples with Wii remotes. Since December or so my bluetooth has been showing as 'unavailable' completely unpredictably. I've tried that SMC reset and that didn't help. Sometimes it works fine, but other times it crashes mid performance, and obviously shutting down etc. in the middle of a concert is no good!

     

    I use a MOTU FireWire audio interface when I use the Wii remotes, and sometimes an Akai LPD8 USB Pad controller. Could either of these affect the bluetooth? I've tried various combinations of no devices, just the pad controller/audio interface etc. but they don't seem to have much influence; if the bluetooth wants to crash, it'll crash. The problem is that, as above, it's totally unpredictable. I'm taking it in to the Apple Store today but I was wondering if anyone had had problems with Wii remotes and/or FireWire/USB?

     

    Thanks.

  • nicolasmorin78 Calculating status...
    Currently Being Moderated
    Jun 15, 2012 1:47 AM (in response to OregonRebel)

    Thanks for the explanation and the link !!

    Worked like a charm on my MacBook Pro !!

  • flucutat Calculating status...
    Currently Being Moderated
    Dec 6, 2012 1:47 PM (in response to vtanasi)

    I had the same issue.  PRAM reset did not solve it.  SMC reset worked like a charm

  • rafachile Calculating status...
    Currently Being Moderated
    Feb 25, 2013 5:16 AM (in response to Barry Hemphill)

    Hi, after resetting both PRAM and SMC, problem didn´t solve.

     

    After doing those steps, i got this new problem. The name of my computer doesnt show up on Finder. I took a snapshoot to ilustrate the problem.

     

    Any clue?

     

    Regards

    Rafa

    Captura de pantalla 2013-02-25 a la(s) 10.20.19.png

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.