Skip navigation

Photostream keeps turning off in iPhoto.

35540 Views 118 Replies Latest reply: Mar 12, 2013 4:28 PM by Heat132 RSS
  • marchandeur Calculating status...
    Currently Being Moderated
    Jun 12, 2012 8:13 AM (in response to ermaly)

    Thanks, ermaly.  The thing is, I haven't deleted photos from Photo Stream via any of my devices in about a week, but every morning I have to Turn On Photo Stream in iPhoto on my MBP. 

  • ermaly Calculating status...
    Currently Being Moderated
    Jun 12, 2012 8:46 AM (in response to marchandeur)

    Well than probably I was wrong... This bug is driving me nuts as I use iphoto and photostream a lot. Or at least I used...

  • MBPierre Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 13, 2012 5:22 AM (in response to gschoenthal)

    I followed the deleting of plist files and this solved my issue for now.

     

    I have quit iPhoto and re-launched several times and Photostream is still enabled.

    I have deleted a photo from photostream and quit / relaunched and still OK

    I am now rebooting and testing.

     

    I just updated OSX Lion with all available updates today _before_ performing the deletion of plist files.

    I did not reboot my system after applying updates / performing plist deletions.

     

    EDIT

     

    After rebooting, photostream was turned off - this didnt' really surprise me - for a few reasons:

     

    1. After deleting plist files and re-launching iPhoto photostream was still enabled - I would have expected it to be off and for me to have to re-enable it.

    2. After deleting plist files and re-launching iPhoto the aforementioned deleted files were not regenerated

     

    After rebooting and finding photostream turned off I re-enabled it

    Checked ~/Library/Preferences and the plist files I previously deleted had returned - created today

    I quit iPhoto and re-launched - Photostream still enabled

     

    Am now rebooting again

     

    Launching iPhoto shows photostream disabled again.

     

    Message was edited by: MBPierre

  • MBPierre Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 13, 2012 5:38 AM (in response to MBPierre)

    For some reason I can't edit my post again.

     

    Furthermore:

     

    Quit iPhoto

    Open System Preferences

    In iCloud disable photostream

    Quit Sys Prefs

    Re-launch Sys Prefs

    Enable Photostream

    Launch iPhoto - photostream is enabled

     

    Reboot

    Launch iPhoto - photostream disabled

     

    Basically, a reboot kills photostream on my Macbook.

     

    For what it's worth, I have the following using iCloud:

     

    Macbook Pro

    Mac Mini

    iPad 1st Gen

    iPhone 4S

     

    The only device _NOT_ using Photostream is my 1st Gen iPad - I wonder if having one device disabled (in terms of photostream) is causing this??

     

    Photostream seems fine on my iPhone however i'm fairly certain my Mac Mini exhibits the same issue as my MBP.

     

    Does anyone else have a device that isn't using Photostream but is using the same iCloud account? clutching at straws here.. seems odd this is only affecting iCloud enabled OSX hosts (atleast in my instance).

  • Franc Chamberlain Calculating status...
    Currently Being Moderated
    Jun 15, 2012 4:19 AM (in response to gschoenthal)

    If I say 'no' to photostream when I launch iPhoto, then all of my streamed photos appear in iPhoto as events such as 'June 2012 Photo Stream'. I only noticed this today but my most recent photos were there (as well as all my earlier ones) - so the photos are being streamed to iPhoto.

     

    But because I've been fussing with why I was being asked to enable photostream on launch and thinking what a waste of time it was to wait for everything to be streamed again, I didn't check to see if my streamed photos were in events even if I did enable photostream at launch.

     

    Has anyone else noticed this (sorry, haven't reasd through all of the posts on this topic)

  • karpati Calculating status...
    Currently Being Moderated
    Jun 18, 2012 12:07 AM (in response to gschoenthal)

    What helped for me was

     

    1. Open your user's Library folder
    2. Navigate to Application Support
    3. Find&Delete the folder "iLifeAssetManagement"
    4. Restart your computer

     

    Now I was able to activate Photostream within the Prefs of iPhoto.

     

    Message was edited by: karpati (typo)

  • R. Polmans Calculating status...
    Currently Being Moderated
    Jun 18, 2012 5:27 AM (in response to gschoenthal)

    I'm having the same problem. I've tried every solution mentioned in this thread (expect the complete re-install of Lion) but nothing worked.

    The problem occurs on my iMac. I own a MacBook pro as well, but this does not have the issue.

     

    Any suggestion is welcome, it is very irritating.

  • MikeChrista Calculating status...
    Currently Being Moderated
    Jun 22, 2012 8:34 AM (in response to R. Polmans)

    I too have tried the various solutions mention in this thread to no avail.  Have also just update to Iphoto 9.3 and the problem still exists!!  On top of that 9.3 is VERY SLOW!!!

  • damongaspee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 22, 2012 4:44 PM (in response to gschoenthal)

    Just to add strength to numbers, I am also experiencing this issue. It's SO frustrating to open my iPhone and not find the images I expected.

     

    (2.4 GHz Intel Core 2 Duo MacBook Pro, OS 10.7.4, iPhoto 9.3)

  • Old Toad Level 10 Level 10 (113,495 points)
    Currently Being Moderated
    Jun 22, 2012 4:46 PM (in response to gschoenthal)

    Do you have more than one iPhoto Library?  Photostream can be active in only one library at a time.  So if you activate it in one library the next library opened will have it turned off.

     

    OT

  • MikeChrista Level 1 Level 1 (15 points)
    Currently Being Moderated
    Jun 23, 2012 9:41 AM (in response to Old Toad)

    I only have a single iPhoto Library.

  • Old Toad Level 10 Level 10 (113,495 points)
    Currently Being Moderated
    Jun 23, 2012 10:09 AM (in response to MikeChrista)

    Maybe you should revert to iPhoto 9.2.3 via this method by iPhoto Library Manager: Fat Cat Software - iPhoto Library Manager Help - Downgrading a library to an earlier version of iPhoto

     

    And wait a while before trying 9.3 again. 

  • R. Polmans Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 24, 2012 7:32 AM (in response to Old Toad)

    I own 3 macs, so I have 3 iPhoto librarys. All works well on only one of them, on the other two I keeps turning off, evenif I use only the library on one of them. (all computers off, enable photostream on a Mac with non working photostream, reboot and photstream is turned off again)

     

    All macs heve the same OS, iPhoto version and Apple ID.

  • ermaly Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 12, 2012 5:09 PM (in response to gschoenthal)

    So no solution still??

  • nastyswap Calculating status...
    Currently Being Moderated
    Jul 13, 2012 4:30 PM (in response to gschoenthal)

    I hade the same problem and solved it by disabling and then re-enabling spotlight.

     

    http://osxdaily.com/2011/12/10/disable-or-enable-spotlight-in-mac-os-x-lion/

     

    http://forums.macrumors.com/showthread.php?t=1284990

1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (9)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.