Skip navigation

iPhoto says "update needed to launch" but software update disagrees

766 Views 4 Replies Latest reply: Jun 17, 2012 10:36 AM by Terence Devlin RSS
jimthenuke Calculating status...
Currently Being Moderated
Jun 16, 2012 12:41 PM

After recent iPhoto 9.3.3 update, iPhoto would not finish loading (constant beachball over 36 hours).  So I rebuilt the library.  No change.  I deleted iphoto and reinstalled from iLife 11.  Now it says "Please update" and won't launch, but software update says no update needed.  How do I get software update to offer 9.3.3 update again?

 

I have tried launching with option key down and reinstalled from ilife 11 twice.  I went to app store and tried to buy iphoto stand-alone version since it was only $15 and I have 29,000 photos in my library that are inaccessible (but still in the iPhoto library).  It would not sell it because it said I already had it.

MacBook Pro, Mac OS X (10.5.5)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.