Skip navigation

"deny file-write-create"-errors in log system.log

8433 Views 22 Replies Latest reply: Nov 11, 2013 10:44 PM by kiiwii88 RSS
1 2 Previous Next
kra_ste Level 1 Level 1 (15 points)
Currently Being Moderated
Jul 25, 2011 12:23 PM

Hi,

 

since I upgraded Lion I got tons of these messages in my logs:

 

Jul 25 21:11:58 neptun sandboxd[5347] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.XTJXHr4

Jul 25 21:12:29 neptun sandboxd[5348] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.86EVSpI

Jul 25 21:12:59 neptun sandboxd[5349] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.CJaoJoj

Jul 25 21:13:30 neptun sandboxd[5350] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.ZGxllUy

Jul 25 21:14:00 neptun sandboxd[5351] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.NApWQdS

Jul 25 21:14:31 neptun sandboxd[5352] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.w1isGGi

Jul 25 21:15:02 neptun sandboxd[5361] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.TC4h3SQ

 

So this is just Preview adding this every 30 seconds to the logs. Similar errors occur, for example, when Spotlight indexes movies.

 

Does anyone have an idea what is causing this and how to fix it?

 

Thanks,

Stefan

MBP Late 2008, Mac OS X (10.6.2)
  • MC1220 Calculating status...
    Currently Being Moderated
    Jul 27, 2011 4:59 AM (in response to kra_ste)

    I am having the same issue.  Does anyone know what it means?  Thanks!

  • Barney-15E Level 7 Level 7 (33,270 points)
    Currently Being Moderated
    Jul 27, 2011 5:14 AM (in response to kra_ste)

    Looks to be a permission problem.

    Type this in Terminal and report what it says for the first line (it will end with a single . ) and also for the ByHost folder.

     

    ls -ale Library/Preferences
    

     

    Also check to see if either the first line or the ByHost line has a line immediately following it with a 0:

    MacBook Pro, Mac OS X (10.7), 2.33 GHz, 3GB RAM
  • MC1220 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 27, 2011 6:06 AM (in response to Barney-15E)

    The first line is: drwx------+ 335 Michelle  staff    11390 Jul 27 09:05 .

     

    The Byhost line is: drwx------   90 Michelle  staff     3060 Jul 27 09:03 ByHost

     

    Thanks so much!

  • Barney-15E Level 7 Level 7 (33,270 points)
    Currently Being Moderated
    Jul 27, 2011 2:44 PM (in response to kra_ste)

    I'm out of ideas. I don't know how the sandbox works, or why it is jumping all over everything trying to write files.

  • kkathman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2011 8:46 PM (in response to Barney-15E)

    For what it's worth, I'm getting those errors too.  Mine are sandboxd based and hit through either Safari trying to write to /private/vars/folders/zz

     

    I am also getting a lot of reports of buffer allocation zero.

     

    Here's the detail from the sandboxd out:

     

    mds(68) deny file-write-create /private/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T

     

     

    Process:         mds [68]

    Path:            /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadat a.framework/Versions/A/Support/mds

    Load Address:    0x106592000

    Identifier:      mds

    Version:         ??? (???)

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [1]

     

     

    Date/Time:       2011-08-16 22:45:26.988 -0500

    OS Version:      Mac OS X 10.7 (11A511)

    Report Version:  7

  • maxcasal Level 1 Level 1 (35 points)
    Currently Being Moderated
    Oct 11, 2011 5:23 AM (in response to kkathman)

    Are you using a username originally created in Tiger and migrated through different versions of OS X?

  • DaddieMac Level 1 Level 1 (15 points)
    Currently Being Moderated
    May 24, 2012 11:50 PM (in response to maxcasal)

    Are you using a username originally created in Tiger and migrated through different versions of OS X?

    Yes I am, and I am having these issues alot.

     

    My username was actually created in 10.0.

     

    I migrated through many 10.x's.

     

    When I came to Lion, when I first updated, my user account was not there at all. So I had to add it manually by creating a new user and pointing it at the old user directory. What would that have done?

     

    Oh yeah. I also changed my user's UID in Directory Utility so it would match the one on my laptop and I could access files between the machines without permissions issues. Was that bad to do?

  • Loren Ryter Level 2 Level 2 (495 points)
    Currently Being Moderated
    Jun 17, 2012 11:16 AM (in response to maxcasal)

    having this kind of logging too while re-indexing boot volume with spotlight (ie, mdworker).

     

    yes, this system has been upgraded through panther probably. what's the issue and the fix?

  • Leopoldnak Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 20, 2012 6:08 AM (in response to kra_ste)

    same issue here - especially with iPhoto, also upgraded account from 10.1 to 10.8 - any fix?

  • ossapha Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 8:06 PM (in response to Leopoldnak)

    Getting the following errors in console log after I upgraded to 10.8 on a client machine

     

    error message code

     

    sandboxd[6634]: ([6449]) Mail(6449) deny file-write-create /path

     

    I have creted a symbolic link to the location of the mail folders off to another hard drive. Worked fine in 10.7, looks like this is no longer supported.

     

    Mail can't seem to create new folders, or if they are already there the IMAP folders convert to Read-Only

  • baltwo Level 9 Level 9 (59,145 points)
    Currently Being Moderated
    Aug 24, 2012 4:00 PM (in response to kra_ste)

    Known bug, but they've not yet fixed it. File a bug report with Apple. The more users who report it, the higher on the priority list it moves.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.1), G4 450 MP w/Leopard, 9.2.2
  • asux Calculating status...
    Currently Being Moderated
    Oct 7, 2012 9:09 AM (in response to ossapha)

    Thanks for the hint: I upgraded to Mountain Lion (10.8.2) today ... since then I had two new "features" (among different others!):

    - Mail.app aborted every now and then

    - Mails from an Exchange server were "read only" (no remove/no move possible)

     

    Just found this discussion here by googling for "sandboxd ...: Mail(...) deny file-write-unlink .../Posteingang.mbox/".

     

    The directories were actually a symlink from ~/Library/Mail/V2 to a second hard disc since I wanted my external emails on some other disk which worked perfectly well under 10.7 (Lion). However, moving back the folder to the "right" place solved the two issues (at least until now).

     

    Cheers,

      Gerd

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.