1 2 Previous Next 18 Replies Latest reply: Jan 22, 2014 2:03 AM by mario.k
Flamez Level 1 Level 1 (10 points)

I upgraded [perhaps that should read downgraded] to 3.3 Some images appear lost although the thumbnails are there in the Projects window?

 

I have ran aperture repair, database rebuild etc. All to no avail.

 

Anyone help? I dont think I,m alone in this


Aperture 3, Mac OS X (10.7.4)
  • 1. Re: Aperture 3.3 lost images
    shuttersp33d Level 4 Level 4 (1,540 points)

    When you say appear lost, could you elaborate? Do they have a badge that indicates the master is missing?

  • 2. Re: Aperture 3.3 lost images
    Flamez Level 1 Level 1 (10 points)

    My library was 129 gig. Containing  perhaps 50 projects. Some projects transferred seamlessly with all the images showing and loading when clicked.

     

    However several projets show 0 in the folder but on the projects page several thumbnails are visible but will not open.

     

    There is no badge to show the master missing.

  • 3. Re: Aperture 3.3 lost images
    Clem Level 3 Level 3 (550 points)

    Do you see the images in Photos view?

  • 4. Re: Aperture 3.3 lost images
    Flamez Level 1 Level 1 (10 points)

    No unfortunately that didnt work either.

     

    I have ran the repair tools for aperture and verified the disk.

     

    The projects affected are towards the bottom of the library and do not seem affected by date by project name.

     

    In the project widow browser the thumbnails can be scrolled, but within the folder or project box there are no images to click or view...

     

    I guess they are gone. but i,ll keep my eye out for a better fix,

  • 5. Re: Aperture 3.3 lost images
    Jim Bridger Level 1 Level 1 (5 points)

    Same issue here. Lots of Zero's where thousands of images once lived. Twice I ran all three library first aid options. Nothing worked. The only good news is there are lots of us out here and hopefully the libraries aren't dead and Apple will get us a fix. But why does this crap have to happen?

  • 6. Re: Aperture 3.3 lost images
    léonie Level 9 Level 9 (51,740 points)

    From your answers is still not clear if your Aperture Library is referenced or managed. In Aperture 3.3 you need to enable the "Badge referenced items" option in the "Appearence" tab of the Aperture Preferences. Are there arrows on your thumbnails?

     

     

    If your images are referenced, check if Aperture still can locate the original masters by ctrl-clicking the thumbnails and selecting "Show in Finder".

     

    If they are not referenced, look inside the Aperture Library Package: Ctrl-click your  Aperture Library, then look inside the Masters folder, if your images are there.

    If you cannot find the originals in the "Masters" folder, I'd try to restore the library from your backup, but make sure that you this time run the "Rebuild Library" before you upgrade the library to Aperture 3.3. Apple recommends to make sure that the library has no problems by rebuilding before upgrading.

     

    Regards

    Léonie

  • 7. Re: Aperture 3.3 lost images
    msim20 Level 1 Level 1 (0 points)

    @Flamez - were you able to solve the problem. I have the exact same problem.

     

    I posted a detailed description of my problem in this post

     

    https://discussions.apple.com/thread/4036008?tstart=0

  • 8. Re: Aperture 3.3 lost images
    bradybruton Level 1 Level 1 (0 points)

    I'm looking for the answer as well!

  • 9. Re: Aperture 3.3 lost images
    chengjt Level 1 Level 1 (0 points)

    I am also having similar problem  after the 3.3 upgrade. Seems to affect projects that are about 18 to 20 mths old. All the older projects have no problem.

     

    - JT -

  • 10. Re: Aperture 3.3 lost images
    chengjt Level 1 Level 1 (0 points)

    Hi,

     

    I think there's a serious bug in Aperture in finding photos of time range, that's causing the above problem. Anyway, I found that if I sync the Aperture album with iPhone via iTunes, I still have those missing project images. And if I use the new "Last x months" feature, I could not get anything close to the real backdated photos. My raw files are still in the aplibrary package.

     

    PS: My aplibrary is on a NAS ... not sure if this is causing the bug.

     

    - JT -

  • 11. Re: Aperture 3.3 lost images
    Zane81 Level 1 Level 1 (0 points)

    Hi I have been working on this for the past week, I lost all images added after December 2011. To fix the problem I renamed Aperture.app to Aperture.appxx and downloaded a trial version of Aperture 3.1, I I installed this and then used the Aperture 3.2.3 upgrade from apple.com/support to match the version of my backed up library on Time Machine.

     

    I then deleted the corrupt library form my computer and recovered the old 3.2.3 library from Time Machine. I held alt + cmd and double clicked the Aperture library to open the Aperture repair window, repaired the library. Once complete I renamed Aperture 3.2.3 to Aperture.app123 and renamed Aperture 3.3 to Aperture.app. I opened Aperture 3.3 and the library was automatically upgraded. Once the library upgrade was complete I checked all my images and all were now visible within Aperture.

     

    One thing to note, when deleting the corrupt library from your hard drive it will not be deleted completely from your computer but instead moved to a backup folder in OSX Lion. In my case I had to disable the backup (http://toti.posterous.com/hidden-local-backups-with-mac-os-x-lion-filli) as I did not have enough space to copy my recovered library to my hard drive while the backup existed on the same drive.

  • 12. Re: Aperture 3.3 lost images
    Aye Es Oh Level 2 Level 2 (330 points)

    There is a new update out now (3.3.1). I had a small upgraded 3.3 library with a few missing images, and I did a repair, and it looks like they're back. Wonder if anyone else has seen the same thing.

  • 13. Re: Aperture 3.3 lost images
    bradybruton Level 1 Level 1 (0 points)

    Yes!

     

    Well, I posted recently and a rep from Apple emailed me, got my address and overnighted a harddrive and sent me a label to overnight it to him. Very good service. They didn't fix the issue and overnight the drive back to me but I saw the update, updated Aperture and rebuilt the library and everything is working perfectly now.

     

    Thumbs up to Apple for how much effort they put into this for me (even though they didn't send a repaired database or let me know how to fix the issue through support), they did capture the issue, read this (and another post I commented on) and fixed it.

  • 14. Re: Aperture 3.3 lost images
    rolandomerida Level 1 Level 1 (100 points)

    Aperture is now in its 3.4.3 version. I've been having problems with several images disappearing just like that. One day my library is complete, the next day some images are missing (offline).

    Curiously, I've always had a managed library from an external drive, and none image is referenced, in order to avoid such offline issues. I created a smart folder with the only condition as "label is offline", in an attempt to track missing images. Well, no matter if I rebuild or repair the database, several images still show as "offline" on a daily basis. Then I check the Aperture package, and yes, I confirm that those images are nowhere to be found in its folder/project. Sometimes I take notice after syncing my iPhone with iTunes, and I got a message "x images were not copied because they couldn't be found".

    Luckily, I always have several backups, so I just reimport the missing(s) image(s). But why should I do that? Sometimes they are so many (30, in one case, from different projects). Most of them, by the way, are images copied from my Photo Stream, but not always.

    I've exchanged emails with an Apple Support guy in recent days. They actually don't have an answer to this annoying bug. I've started to lost confidence in the safety of my photos in Aperture.

1 2 Previous Next