Skip navigation

clicking the lock does not work HELP

935 Views 6 Replies Latest reply: Jun 18, 2012 11:23 AM by lychee- RSS
lychee- Calculating status...
Currently Being Moderated
Jun 16, 2012 7:15 AM

clicking the lock at any kind of program does not work at all, not working in system pref,

not working at ''get info'' window, not working in any other kind of lock, i tried defragging via idefrag but that couldn't work because it needed a lock to be opened as well, i can't move my files to some folders, getting the ''The operation can’t be completed because an unexpected error occurred (error code 100022).''

plus when i log out, cannot log in because when i type my password it accepts it but then nothing happens, i had a root account as well but i can't enter it and can't create again because of the lock, but when i log in with guest account(no pass required) i can make changes via clicking the lock and filling in admin username and password in system preferences. and i created a new admin account in guest account by filling admin info for authorization in system preferences > users&groups , set no password, logged out but could not log into that account as well. my system is set to login to my account when the system starts. so thats how i can use the computer

macbook pro 17'' 2009 - imac 17'' 2006, Mac OS X (10.6.4), connected to a native instruments audio8 dj
  • macjack Level 9 Level 9 (50,445 points)
    Currently Being Moderated
    Jun 16, 2012 7:26 AM (in response to lychee-)

    First of all, it's doubtful your Mac needs needs defragging. Unless you're using your system drive to do a lot of heavy duty video or music editing.

     

    You may be able to unlock a folder a folder by launching Terminal and entering

    chflags nouchg

    then leave a space and drag the folder into the Terminal window to create the path.

    Press return.

     

    Before messing with that I would boot up holding command-r keys into Lion Recovery Volume.

    The screen should give you these choices...

     

    Restore from TM backup

    Reinstall Mac OS X

    Get help online

    Disk Utility

    Choose Reinstall OS X. This will be an install in place and won't affect any of your own data.

     

    Hopefully this will clear up your largest issues, like the login.

  • macjack Level 9 Level 9 (50,445 points)
    Currently Being Moderated
    Jun 18, 2012 7:08 AM (in response to lychee-)

    And you tried the re-install to fix the lock issue?

  • Linc Davis Level 10 Level 10 (107,825 points)
    Currently Being Moderated
    Jun 18, 2012 7:29 AM (in response to lychee-)

    Back up all data if you haven’t already done so. There are ways to back up, even if you can’t log in. Before proceeding, you must be sure you can restore everything to the state it’s in now. If you’re not sure you can do that, STOP.

     

    Briefly, you need to delete the following file:

     

    /var/audit/current

     

    If you already know how to do that, you can skip the rest of this message. Do it, and try again to log in.

     

    Step 1

     

    Boot in single-user mode by holding down the key combination command-S at the startup chime. If you’re using an external USB keyboard, it must be plugged directly into a built-in port on the Mac, not into a hub. Release the keys when you see a black screen with scrolling white text. In this mode, there’s no graphical interface; just a command line. Initially, you can’t make any changes to files.

     

    Step 2

     

    When the text stops scrolling, and you see a line ending in a pound sign (“#”), type the following command:

     

    rm /var/audit/current

     

    You must type the command exactly as given. If you don’t feel able to do that, STOP. At this stage, no harm will be done if you make a mistake, but later, it will be.

     

    Press the return key. You’ll get an error message about a “read-only filesystem” below what you entered. There must be no other error message. If there is, try again until you get it right. You’ll continue to get the read-only error.

     

    You might get the error “No such file or directory,” even if you entered the command correctly. If you’re sure that’s the case, stop and post again.

     

    Step 3

     

    Once you’ve taken steps 2, and received the expected error messages, enter the following command:

     

    mount -uw /

     

    Again, you must get it exactly right. This time, there should be no output at all. If there is, you mistyped the command, or something else is wrong.

     

    Step 4

     

    When you’ve taken step 3 with no error message, press the up-arrow key until the command from step 2 (rm …) reappears. If you got everything right on the first try, you’ll need to press the key twice. Make sure the command is correct, then press return again. There should be no output. If there is any, make a note of it and post a reply.

     

    Step 5

     

    Enter the command:

     

    exit

     

    Press return. The text will start scrolling again, and then the system will reboot. Try again to log in.

     

    Credit for this solution is due to ASC user AnthonyTW.

  • Linc Davis Level 10 Level 10 (107,825 points)
    Currently Being Moderated
    Jun 18, 2012 7:30 AM (in response to Linc Davis)

    The previous message was edited after posting.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.