Skip navigation

Search not working properly in mail

49140 Views 94 Replies Latest reply: Mar 11, 2014 6:57 AM by Di\'k RSS
  • PunkNugget Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2012 2:43 PM (in response to Glenn Leblanc)

    I hear you but this is an issue. Maybe not for you but this is insane. Two days ago with my other SSD it's working (in 10.7.2), now with my other SSD (in 10.7.3) it's NOT ??? And I'm not the only one. I'm sure there's many others out there that aren't expressing anything about it, but that's not what I'm seeing when I google it:

     

    http://www.google.com/search?q=mac%20mail%20search%20is%20not%20working&ie=utf-8 &oe=utf-8

     

    and it's happening with 10.7.0  and above. So again, I don't know why it didn't do it in 10.7 or 10.7.2 and now in 10.7.3 it's now not able to do a simple search. In any case this isn't good...

     

    I do hope you re-read my edit and try to explain it. I may be looking too far into things and it may be as simple as you say. Since it's already in there I should just take it out and it should re-index it for me? I hope this works... Agian, thanks...

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Jun 18, 2012 3:01 PM (in response to PunkNugget)

    I do understand that it's an issue for you. I just meant that it's not a problem that millions of people are having. Something went wrong when you updated and it could be something got corrupted.

     

    For spotlight preferences, open System Preferences. Choose the Spotlight icon and open it. Check that all boxes are checked off in the prefernce list. If so, click on the privacy tab and "+" sign to add your hard drive to it that your computer boots from. If it's already in the privacy list, then it means that nothing will search on the drive. Highlight the startup volume and click the "-" sign to remove it from the list. You should notice spotlight start to reindex the drive. Wait until it finishes and try searching.

    For more info: http://support.apple.com/kb/HT2409

     

    If your hard drive that you boot from is in this list, then highlight it and click the minus sign to remove it.

    Screen Shot 2012-06-18 at 4.55.04 PM.png

  • PunkNugget Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2012 3:09 PM (in response to Glenn Leblanc)

    Okay, I will do that. Also, just to let you know I am able to search by people's specific names when searching using spotlight and it works. I just prefer to use Mac's Mail Search Bar to make that happen. I'm at least thankful that Spotlight is working. Again, thank you for your time...

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Jun 18, 2012 7:31 PM (in response to PunkNugget)

    If it's working in spotlight, then it should work in mail search also. Did you change anything to make it work in spotlight?

  • PunkNugget Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 18, 2012 8:08 PM (in response to Glenn Leblanc)

    Nope, didn't delete or change anything yet. Isn't that funny? Nothing still is working on my search bar in Mail.app, but on Spotlight, everything is able to search even the most current emails from today... Don't know what to say about that..

     

    Did you still want me to try out that proceedure that you gave me instructions on? Thanks for the follow up...

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Jun 18, 2012 8:47 PM (in response to PunkNugget)

    If it's working in Spotlight, then no. Reindexing won't do any good.

     

    When you search in Mail, do you have the "All" mailboxes selected?

     

    Also, what kind of account is this? IMAP? iCloud? POP?

    If IMAP or iCloud, do you have it set to store messages for offline viewing (a setting under the Advanced tab in Accounts)?

     

    You could create a new user for testing. Log into that user and create your mail accounts there. Test to see if the search works there. That will determine if it's a problem in your user account or with the Mail application.

  • PunkNugget Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 19, 2012 8:14 AM (in response to Glenn Leblanc)

    Just to let you know Glenn, I did finally try that proceedure that you said to do and after I "-" the boot drive from the privacy section of Spotlight, it finally re-indexed everything (took about 20 to 25 min) and the search bar in Mail.app works just fine now. But since I've gotten used to using Spotlight now. I guess I'll be using that from now on as it's faster - LOL !!! Thanks for all the help !!!

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Jun 19, 2012 9:01 AM (in response to PunkNugget)

    Well, I didn't think spotlight reindexing would work for Mail since you said the search was working in it. Glad to see it did work.

    Guess you never know.

     

    To bill96744

    I see you hadn't resolved your problem. Have you tried the Spotlight reindexing?

  • kmartin696 Calculating status...
    Currently Being Moderated
    Jun 21, 2012 4:42 PM (in response to Glenn Leblanc)

    Glenn, deleting that MailData folder and allowing Mail to reindex itself worked great and solved my problem.  Thanks!!!  It's shocking that Apple allows such an obvious flaw to persist.

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Jun 21, 2012 4:57 PM (in response to kmartin696)

    I didn't say to delete the folder, but certain files within. If you delete the folder, then you will have to recreate the accounts. I assume you meant you deleted the Envelope Index files within the folder.

     

    I don't know what corrupts the files, but I don't think I would call it a flaw. Most people aren't having problems that I know of. It would be wonderful if someone could invent a flawless system though.

  • kmartin696 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 21, 2012 6:18 PM (in response to Glenn Leblanc)

    Sorry, thanks for clarifying.  I DID NOT delete the MailData folder, I only deleted the Envelope files from within the MailData folder, and that did the trick.

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Jun 21, 2012 6:23 PM (in response to kmartin696)

    I figured you did. I just didn't want anyone else to get the wrong info.

     

    Glad that helped you and you're welcome.

  • Steve Curtis1 Calculating status...
    Currently Being Moderated
    Jul 4, 2012 7:05 AM (in response to Glenn Leblanc)

    Glenn,

     

    After upgrading Snow Leopard to Lion this last week, I too experienced the loss of Search in Mail. It would search recent messages, but I've got mail that dates back 15 years, and all those messages were excluded from Search.

     

    I followed the directions for removing the Envelope Index files, then Mail took a while importing all old messages, and now Search works properly as before the upgrade. Thanks for a great tip!

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Jul 4, 2012 7:15 AM (in response to Steve Curtis1)

    Nice to see people are getting help from this.

1 2 3 4 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.