1 2 Previous Next 23 Replies Latest reply: Apr 19, 2014 7:45 PM by hexum311ad
darkhorse85 Level 1 Level 1 (0 points)

Hi I can't play YouTube videos on Safari any more. I have noticed that I can play videos on Safari but not on YouTube. When atempting to watch a video on You Tube it won't finish loading. It appears to load at first evenutally stops before the video can play. I then receive the "Plug-in Failure" message.

 

  • I am using Safari 5.1.7 on Mac OS X 10.7.4. 
  • I believe I am using the latest version of Abobe Flash Player, which I downloaded when I first noticed the problem.

 

Please note I do not wish change to a different web browser. Thanks for reading.


MacBook Pro, Mac OS X (10.7.3)
  • 1. Re: Can't play YouTube videos on Safari
    Linc Davis Level 10 Level 10 (117,970 points)

    Select Help Installed Plug-ins from the Safari menu bar. Besides the following, what plugins are listed?

     

    iPhotoPhotocast

    Java

    QuickTime

    WebKit built-in PDF

  • 2. Re: Can't play YouTube videos on Safari
    darkhorse85 Level 1 Level 1 (0 points)

    Hi Linc, thanks for replying. This is currently what Safari is showing me.


    • Google Talk NPAPI Plugin
    • Google Talk Plugin Video Accelerator
    • iPhotoPhotocast
    • Java Applet Plug-in
    • QuickTime Plug-in 7.7.1
    • SharePoint Browser Plug-in
    • Shockwave Flash
    • Silverlight Plug-In
    • WebKit built-in PDF
  • 3. Re: Can't play YouTube videos on Safari
    Linc Davis Level 10 Level 10 (117,970 points)

    Can you see your Flash version on this page:

     

    Adobe - Flash Player

  • 4. Re: Can't play YouTube videos on Safari
    darkhorse85 Level 1 Level 1 (0 points)

    Yes, but I could be mistaken. Below is the version of Flash Player I am using:

     

    Shockwave Flash

    Shockwave Flash 11.3 r300 — from file “Flash Player.plugin”.
    application/futuresplashFutureSplash Playerspl
    application/x-shockwave-flashShockwave Flashswf
  • 5. Re: Can't play YouTube videos on Safari
    Linc Davis Level 10 Level 10 (117,970 points)

    You should have seen something like this on that page:

     

    Untitled.png

  • 6. Re: Can't play YouTube videos on Safari
    darkhorse85 Level 1 Level 1 (0 points)

    I didn't see a message like that on the Adobe website. There was just an empty space where the "Version Information" box is. What should I do next? Thanks

  • 7. Re: Can't play YouTube videos on Safari
    Linc Davis Level 10 Level 10 (117,970 points)

    Please read this whole message before doing anything.

     

    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    The purpose of this exercise is to determine whether the problem is localized to your user account. Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box. Don't use the Safari-only Guest login created by "Find My Mac."

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem(s)?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault in Mac OS X 10.7 or later, then you can’t enable the Guest account. Create a new account in which to test, and delete it, including its home folder, after testing.

  • 8. Re: Can't play YouTube videos on Safari
    schoodle Level 1 Level 1 (60 points)

    I've been having mega trouble watching videos on many websites that require Adobe Flash too. Mostly notably are the news stations I watch regularly on the web. Happens with both my Macs (see info below). Tried updating from 11.2 to the latest Flash 11.3, which fixed nothing. Videos were missing upon clicking the start video arrows, some videos break up and reform, I see some stopping and starting, voice is not always synched with video, etc..

     

    Java has been disabled for quite sometime now.

     

    What I've done so far:

    Rebooted Safari. No fix.

    Rebooted computer with PRAM clearing. No fix.

    Ran Disk Utility. No fix.

    Emptied the history and cache for Safari (I do it every so often). No fix.

    Cleared website data from Safari Prefs (also done every so often). No fix.

    Installed Adobe Flash Debugger. No fix, but now this app is very annoying - everytime I go to some news sites, the dang debugger window pops up with all these errors(?) but what's the point of that? Video still doesn't play. There is no option to report the debugger data or fix anything! I only get options to Dismiss or Cancel. Doing either doesn't do anything. I can go on to read some of the articles but the videos are always missing. When I go back to the home page, the dang debugger window reappears! Urrrrgh!

     

    Real Player is not installed on MacBook Air.

    Have now uninstalled Adobe Flash.

    What next?

     

    Safari>Help> Installed Plug-ins:

    Adobe Acrobat NPAPI Plug-in, Version 10.1.3

    DivX Plus Web Player

    DivX VOD Helper Plug-in

    Flip4Mac Windows Media Plugin

    iPhotoPhotocast

    Java Applet Plug-in

    QuickTime Plug-in 7.7.1

    WebKit built-in PDF

     

    [My] HD>Library>Internet Plug-Ins

    AdobePDFViewer.plugin/

    AdobePDFViewerNPAPI.plugin/

    DivXBrowserPlugin.plugin/

    Flip4Mac%20WMV%20Plugin.plugin/

    iPhotoPhotocast.plugin/

    JavaAppletPlugin.plugin/

    nsIQTScriptablePlugin.xpt

    OVSHelper.plugin/

    Quartz%20Composer.webplugin/

    QuickTime%20Plugin.plugin/

     

    Have read to uninstall Adobe Flash, reboot computer, then install the Adobe Debugger version. I'll try that next and see if anything changes. Will report back later.

     

    What's next?

  • 9. Re: Can't play YouTube videos on Safari
    schoodle Level 1 Level 1 (60 points)

    Linc, I tried the diagnostic test you outlined above. The problem also occurs in the test account.

    Tried watching videos on NYTimes.com, 9News.com and CNN. Can not get them to play. Upon clicking the start video arrow for any vidoe on these sites, the picture of the video disappears and nothing happens. This happens in test accounts and my own account on both computers.

    What now?

  • 10. Re: Can't play YouTube videos on Safari
    canudropit2 Level 1 Level 1 (0 points)

    I am having the same problem.

     

    it just stopped working and says flash player is out of date.  I deleted all previous versions of flash player in the system pref. window and reset safari.....rebooted and when i try to watch a vid on youtube it says the plugin is still out of date when i know i installed the latest version of flash. I even tried unchecking the 32-bit in the safari get info box as well.

     

    Does anyone have a solution.

  • 11. Re: Can't play YouTube videos on Safari
    regi7 Level 1 Level 1 (0 points)

    For me, the problem was that I had the Google Disconnect extension.  Once I unchecked "Enable this Extension", youtube started working normally.  Hope this helps.

  • 12. Re: Can't play YouTube videos on Safari
    jczyz1974 Level 1 Level 1 (0 points)

    My husband prefers firefox, so I copied the links (youtube) into firefox & it worked great.  Looks like the problem is with Safari...not the OS.

  • 13. Re: Can't play YouTube videos on Safari
    key2kim Level 1 Level 1 (0 points)

    Hello Linc,

     

    I'm having trouble seeing all videos on YouTube while in my Safari browser. I can hear audio when a video is playing but I only see a ptich black screen. Also if I scroll on the time bar of the video I can see the thumbnail of that video but nothing on the screen. I can only see the picture of a select few videos while in Safari. I looked at the page to see what Adobe version that I have and I didn't see it on my Installed Plug-ins page either. Then I went to a guest account and everything was fine. I was able to view whatever video that I wanted as I used to be able to do while in my Admin account.  I also tested sending emails while in that account and it sent without a problem. For over a year now I haven't been able to use my email icon to send/receive emails so I have to get online via Safari/Firefox and log into my email service provider and send and receive emails that way. Can you please help me by letting me know what the next steps are after testing through the guest login? Also can you help me get my email from my desktop working again?

     

    Thank you in advance!

  • 14. Re: Can't play YouTube videos on Safari
    cgiambri Level 1 Level 1 (0 points)

    Couldn't watch videos (screen was all play and would not engage) using Safari. Updated Java and also switched browsers to view and Firefox worked.  Still will try to get Safari working but at least FF works. Found this tip at our Apple community by a Clinton in December 2012 but couldn't find yet to thank you about switching to another browser. Yeah.

1 2 Previous Next