7 Replies Latest reply: Jun 20, 2012 12:44 PM by Frank Jacob
Frank Jacob Level 2 Level 2 (475 points)

Hi I'm hoping someone has an answer to this:

I just purchsed a new MacPro 8-Core and installed Final Cut Studio (FCP 7) on Lion

It had been working fine, I had a system issue where tried to fix by providing rights to sub-folders and since I did that I have been having huge problems trying to get the Mac running again. One of which happens to be that the fonts which were accessible in FCP prior to the issue are now no longer available. in fact I had a huge collection all accessible. these are all gone. The same goes for Motion and the templates I try to open and use in Final Cut.

 

Does anypne have a clue as to why this happened and, more importantly, how can I get my fonts back??

 

thx

 

fj

 

PS. I have gone into font book and made sure all fonts are activated.


Final Cut Pro 7, Mac OS X (10.7.4)
  • 1. Re: FCP 7.0.3 why are my fonts suddenly not available?
    Gary Scotland Level 6 Level 6 (8,240 points)

    I had a system issue where tried to fix by providing rights to sub-folders and since I did that I have been having huge problems

     

     

    what did you do when you "tried to fix" ?

  • 2. Re: FCP 7.0.3 why are my fonts suddenly not available?
    Frank Jacob Level 2 Level 2 (475 points)

    Hi Gary,

    I had a problem where often when I tried to save a file I would get a prompt telling me I had no access rights. I found it strange because this is a fresh new computer and I installed all from scratch in what I thought was "the right" way... In Lion the finder has a different column view than my eralier 10.5.8. and I saw that when i clicked on "Macintosh HD" it showed the the little no access symbol. Since I was logged in as the admin I did a get info and noticed that only the "system" had read & write access. I clicked on the one called "wheel" (strange name btw) and changed it to R/W also and also checked the tab to "apply to enclosed items". it took about 10 min's to apply and then after that my chaos started.

     

    I have spent the past 7 hours trying to sort out why I can't open ANY of my Adobe software anymore, can't access the fonts I used to have in FCP or in Motion, and even in Pages I get nightmarish looking results when I open documents that were fine just this morning...

     

    does any of that sound familiar? (i hope for your sake not!)

  • 3. Re: FCP 7.0.3 why are my fonts suddenly not available?
    Brad Bechtel Level 1 Level 1 (130 points)

    While you're in Font Book, try validating your fonts.  I'm sure you'll find some problems.  Deactivate the problem fonts and try again.

     

    If everything checks out and you're still having problems, try creating a new user, logging in as that user, and seeing if your problems go away.

  • 4. Re: FCP 7.0.3 why are my fonts suddenly not available?
    Frank Jacob Level 2 Level 2 (475 points)

    There were some font issues, but not many. thx for the tip. I created a new user and was able to see all of the fonts again!

     

    So is there any easy way to rescue my existing user or is that account pretty much trashed?

     

    Thx!

  • 5. Re: FCP 7.0.3 why are my fonts suddenly not available?
    Brad Bechtel Level 1 Level 1 (130 points)

    You may be able to repair your font cache.  Adobe has a good article here:

    http://helpx.adobe.com/x-productkb/global/troubleshoot-fonts-mac-os-x.html

  • 6. Re: FCP 7.0.3 why are my fonts suddenly not available?
    Michael Grenadier Level 7 Level 7 (20,125 points)

    well you can save your fcp preferences using this

     

    https://discussions.apple.com/docs/DOC-2491

  • 7. Re: FCP 7.0.3 why are my fonts suddenly not available?
    Frank Jacob Level 2 Level 2 (475 points)

    Thx all for your help. I tried all of it. A friend suggested what Brad suggested:

     

    When I created a new user I found that the fonts were once again appearing as they should/were originally in both FCP and Motion. It seems that that one move to assign the rights to subfolders in my user account corrupted all of the font files. Regardless of having tried all of the various ways to fix the system caches and pref files nothing worked to get my user account and the admin account back to normal.

     

    But here's something I didn't expect and maybe it will save someone the hours i wasted. After I created a new account and assigned admin rights, I was still having problems with launching my Adobe applications: "Error 150:30 Licensing has stopped working..." So I uninstalled my entire Creative Suites apps and reinstalled them. This fixed it for the new user account.

     

    But get this: when I went back to the old "corrupt" user account, it was now working again also! Including FCP and Motion and all of the word processing and Adobe apps. I've been editing on them all day and knock on woodhead it all works perfectly again.

     

    Cheers f